10 Replies Latest reply: Jun 14, 2013 8:27 PM by Pondini
giantrats Level 1 Level 1 (0 points)

I have three hard drives in my mac pro:  two 5 gigs and 1tb for time machine and a few other small files.  Yesterday, both disks went heywire at once and I've spent today trying to restore from time machine.  One hard drive restored successfully, the other one didn't. 

 

The disk that struggled to restore seems dead.  It is going excrutiatingly slow (est. thousands of hours) to restore, or repair with diskwarrior, or even erase.  I have tried repairing and re-erasing the disk.   It seems dead, but  that's ok because I have a backup.

 

But my backup has just magicly disappeared.  Time machine suddenly has no record of anything before the restore of the first disk.  The hard drive that my backups are on suddenly has 336.63 gigs available.  I see a backup file that seems to have just been made from the HD I restored, but no trace of the backups of the one that failed to restore.  My icon, disk name, and few other files on the time machine disk are still there, so I didn't accidently erase them.  Did Time Machine just delete my entire backup without asking?  Or is there a chance it is hiding somewhere, even though there aren't any places to hide? 

 

Help.


Mac Pro, Mac OS X (10.6.8)
  • sanjampet Level 5 Level 5 (7,695 points)

    giantrats,

     

    Please read thru this as Pondini is the resident TM guru, and much info to offer.

     

     


    http://pondini.org/OSX/Home.html

  • Pondini Level 8 Level 8 (38,720 points)

    giantrats wrote:

    . . .

    I see a backup file that seems to have just been made from the HD I restored,

    Have you made any other backups since then?

     

    Take a look at the backups via the Finder.  You should see a single Backups.backupdb folder, with a single folder named for your Mac.

     

    Inside that is a series (we hope) of date-stamped folders, one for each remaining backup.

     

    Inside each of those is one folder for each drive/partition that was backed-up.

     

    If that's a little cryptic, see the green box in How Time Machine works its Magic for an illustration.

     

    TM's capacity to back up multiple drives, and keep track of drives that are no longer connected, or have been replaced, or even two with the same name, is very powerful, but can make some things a bit hard to see.  And it doesn't always treat a restored drive as being the same as the original automatically, so does a full backup of it, which is what it sounds like may have happened here.

     

    See what you can find and let us know.

  • giantrats Level 1 Level 1 (0 points)

    Nope.  The only thing there is a new back up of the working drive.  The failed drive is not listed, and the surprisingly large amount of free space now available is telling.

     

    When I first restarted from a CD to restore from backup, there were a list of dates and times to choose from.  But after TM made a new back up, only the later date has been an option.

     

    I have since shut off all TM activity and stopped using the failed disk and the TM disk. 

  • Pondini Level 8 Level 8 (38,720 points)

    giantrats wrote:

    . . .

    But after TM made a new back up, only the later date has been an option.

    Doesn't sound good, but still doesn't quite add up.

     

    Time Machine will never delete the last remaining backup, for obvious reasons.

     

    So even if it did a full backup of the restored drive, on that backup it wouldn't have deleted the last remaining backup, so the previous backup of the drive shouldn't have been deleted to make room.

     

    So, something else must have happened.  If, for example, you'd excluded the failed drive from backups, then done other backups, there wouldn't have been previous backups on those, so the older ones might have been deleted.  Seems unlikely, but what you see, and the empty space, would tend to confirm something like that.

     

    First, just to make sure there isn't some sort of directory problem, run Repair Disk on it, if you haven't already.

     

    If that doesn't turn up anything, you may have to try to recover the data, some of which has probably been overwritten.  See Data Recovery.  That probably won't be much fun.

     

    Sorry not to have better news. 

     

    You may have learned the hard way (most of us do ), that its; always prudent to keep "secondary" backups.  See the green box in  Time Machine - Frequently Asked Question #27 for some suggestions.


  • giantrats Level 1 Level 1 (0 points)

    Well, that's the problem.  I had been able to restore the disk partly, but the drive seemed to be failing physically.  And so I know the back ups were there, because I was working with them.  I tried erasing the target drive, and re-restoring twice.  And on the third time, the back ups were no longer there.  There are still other stray fuiles on the back up drive, so I know I didn't accidenty erase the wrong drive.  To be sure, all of the back ups from both my disks seem to have been replaced, but it's the failed drive I'm concerned about.  I do not recall emptying the trash either.

     

    The hard lesson I've gotten is mixed.  The stuff that survived is the stuff I've backed up manually.  The stuff from TM disapeared in a heartbeat, and I have no idea why.  It's too bad because for everyday recovery, TM has been great. 

  • Pondini Level 8 Level 8 (38,720 points)

    giantrats wrote:

    . . .

    And on the third time, the back ups were no longer there. 

    Bizarre.  I've not seen that, or any reliable reports of it, and have no idea how it could happen. 

     

    Wish I had something constructive to add.

  • giantrats Level 1 Level 1 (0 points)

    After that third time I had already had the start up drive restored, and started up my computor as normal to check email etc, as I'd been out of commission all day.  I opened Disk First Aid to try to fix the faling disk in the background, but it wasn't going well.  TM started working in the background.  TM did give me an error, which I think was about space, or that it was no longer connected to the backup I'd just restored from.  It was a normal dialog, and I hit OK.  Then restarted a short time later back into the CD to try restoring the failed disk again, and that's when I saw, from the CD, that the back ups I was just working with were missing.

     

    It seems like the data is gone and I'm looking at recovery now.  But I hope this information will be helpful in someway. 

  • Pondini Level 8 Level 8 (38,720 points)

    giantrats wrote:

    . . .

    TM did give me an error, which I think was about space, or that it was no longer connected to the backup I'd just restored from.  It was a normal dialog, and I hit OK.

    That's probably where it happened, and you likely got the after-the-fact message, so it was already too late:

     

    C4b ML disk full (w_name).jpg

  • giantrats Level 1 Level 1 (0 points)

    Why on earth would it do that?  In the future, if I find my self in a similar boat, the only way to prevent it is to turn time machine off before it starts working?   Which might not be possible?  

  • Pondini Level 8 Level 8 (38,720 points)

    It was different at first.  On Leopard, the title of the option was Warn when old backups are deleted.  Instead of a proper warning, though, the backup just failed.  Worse, the message wasn't clear (shocking, right!) that all you had to do was un-check the option and let the next backup run, so folks stewed or didn't know what to do, and backups just stopped.  Then a week or a month or six later, when something awful happened, they were out of luck.

     

    In addition, even if there was a proper warning, it would be hard to tell how many old backups would need to be deleted, unless you looked at the message carefully.  Plus, you'd probably see it fairly often, likely once a week, so eventually most folks would just dismiss it or check Don't show this again.

     

    Kind of a "catch-22."