3 Replies Latest reply: Jun 10, 2013 5:21 PM by Linc Davis
jed4golf Level 1 Level 1 (0 points)

I get "Finder wants to make changes. Type your password to allow this." I had just upgraded to OSX 10.8.3 when this started. HELP


iMac, OS X Mountain Lion (10.8.2)
  • mende1 Level 10 Level 10 (91,890 points)

    Open  > Software Update, and install 10.8.4. Then, recreate your user's Trash. To do this, open Terminal, in /Applications/Utilities, and type:

     

    sudo rm -ri ~/.Trash

     

    For more troubleshooting, visit > http://www.thexlab.com/faqs/trash.html

  • Linc Davis Level 10 Level 10 (173,420 points)

    1. Triple-click the line below to select it:
       
    ~/.Trash
      
    2. Right-click or control-click the highlighted line and select
      
    Services Show Info
      
    from the contextual menu.* An Info dialog should open.
        
    3. The dialog should show "You can read and write" in the Sharing & Permissions section. If that's not what it shows, click the padlock icon in the lower right corner of the window and enter your password when prompted. Use the plus- and minus-sign buttons to give yourself Read & Write access and "everyone" No Access. Delete any other entries in the access list.
     
    4. In the General section, uncheck the box marked Locked if it's checked.
      
    5. From the action menu (gear icon) at the bottom of the dialog, select Apply to enclosed items and confirm.
      
    6. Close the Info window and test.
      
    *If you don't see the contextual menu item, copy the selected text to the Clipboard (command-C). Open a TextEdit window and paste into it (command-V). Select the line you just pasted and continue as above.