6 Replies Latest reply: Jun 16, 2013 4:06 PM by Thomas Emmerich
nbjorklund Level 1 Level 1 (0 points)

Since I updated to Aperture 3.4.5, I see only a portion of some photos after I double click them in the library in Aperture.  The same partial view now shows up in iPhoto as well.  For a nanosecond, I see the full image as it is enlarging, but when it opens the image fully, it shows only a corner. It is possible that these are only photos that I edited in a  previous version of iPhoto, before I was using Aperture.

 

Anyone else seen this?  Any solutions?  Thanks!


Aperture 3, Mac OS X (10.7.5)
  • 1. Re: Aperture 3.4.5 displays only a portion of some photos
    Kirby Krieger Level 6 Level 6 (11,945 points)

    Two things to try:

    - Reboot

    - Delete your user preferences for Aperture.  Details are on this Apple support page.

     

    Deleting user prefs often helps clear UI issues.

     

    Can you determine what is different about the Images that are affected?

     

    Let us know how it goes.

  • 2. Re: Aperture 3.4.5 displays only a portion of some photos
    nbjorklund Level 1 Level 1 (0 points)

    Thanks Kirby for the suggestions.  I deleted preferences, and that did not change this behavior.  In Aperture, I repaired the library, and that did not help either.  In Aperture, I also repaired permissions, and that also did not help.

     

    I tried to determine what might distinguish the photos where this was happening, but haven't found the key yet.  They seem to be all photos that are labeled in Aperture as "iPhoto externally edited image," but not all the photos marked that way have this problem.  It is possible that the problem is confined to images from my old Canon 20D, that show up in Aperture labeled as "iPhoto externally edited image."

     

    I have confirmed that the entire image is there in each case.  If I open the library in iPhoto, I see the partial images, but then if I move through the affected photos with the arrow keys, I will see the entire image.  Otherwise, I always only see a small corner of the image at full size, in both iPhoto and Aperture.  It appears to be a thumbnail issue in Aperture.  May related to using my iPhoto library as my Aperture library?

     

    I'm stumped.

  • 3. Re: Aperture 3.4.5 displays only a portion of some photos
    nbjorklund Level 1 Level 1 (0 points)

    I've also restarted the machine several times, no help there either.

  • 4. Re: Aperture 3.4.5 displays only a portion of some photos
    léonie Level 9 Level 9 (51,740 points)

    Have you tried to rebuild the thumbnails in Aperture?

     

    From Aperture's main menu bar:

         Photos > Generate Thumbnails

     

    ?

     

    Regards

    Léonie

  • 5. Re: Aperture 3.4.5 displays only a portion of some photos
    nbjorklund Level 1 Level 1 (0 points)

    Yes, tried that also, to no avail.

  • 6. Re: Aperture 3.4.5 displays only a portion of some photos
    Thomas Emmerich Level 4 Level 4 (3,485 points)

    I sometimes get the same thing with old photos that were originally edited with an older version of iPhoto. The only fix I've found is to duplicate the version in Aperture. The duplicated image works fine. I then usually delete the problematic image.

     

    In the past, iPhoto used destructive editing. Everytime you edited an image, it reopened the edited JPEG file and resaved a new JPEG over it. Now it saves the edits in a database like Aperture does and create a preview image of those edits. Photos edited the old way (sometimes?) can't be edited in Aperture unless you create a new version. I'm not sure what this does. Does it just make the edited iPhoto image a new original? Or does it actually go back the the first original with no edits on it?