Previous 1 97 98 99 100 101 Next 2,158 Replies Latest reply: Aug 17, 2015 11:13 AM by smithers86 Go to original post Branched to a new discussion.
  • headcase Level 1 Level 1 (15 points)

    Ok, so as I said I would do some weeks ago, now that 10.8.5 is released into the wild, I installed a clean build of 10.8.5 onto a spare drive for my 2013 MBA.


    1) I checked the wireless driver version that is provided in this OS X 10.8.5 maintenance release, and its now version


    2) I pinged the various routers in my home (all current generation AC and N class), and the ping times with this latest wireless driver unfortunately averaged above 80ms, with many ping times above 250ms.  So this driver clearly contains the latency bug that was in the driver that came in the 2013 MBA 1.0 Software Update.


    3) While running 10.8.5, I rolled just the wireless driver back to the original driver that came with the MBA, and the ping times to my router were back under 3ms, as they should be.


    So... some things to note and where we are at:


    a) is the original wireless driver that came with the 2013 MBA, and does not contain any latency bug.  However, some 2013 MBA owners complained of frequent WiFi disconnects with this original driver, which is why Apple released an updated driver.


    b) is the wireless driver that came with the 2013 MBA 1.0 Software Update for OS X 10.8.4 to remedy the WiFi disconnect issue that some MBA owners were having, but it contains a persistent latency bug that impacts most if not all 2013 MBAs, which is detrimental to apps like VoIP (e.g. Skype) and even has a noticeable impact on non-critical activities like loading of web pages


    c) is the wireless driver that came with the OS X 10.8.5 maintenance release to specifically remedy the known AFP networking issue, which is not related to this support thread.  Unfortunately, this latest wireless driver from Apple and Broadcom still contains the persistent latency bug that came out with




    What I am suggesting for current 2013 MBA owners:


    - If you are happy with your Mac in how it performs, then chances are you're not even visiting this support forum... so go surf the Net and enjoy.


    - Per my previous posts on this support thread, if you are not happy with the latency issues on your MBA, you can either roll back to the original driver, return your Mac, sell it, or wait until Apple releases another update to the wireless driver.  As I know many folks are tired of waiting for a fix, and although I believe Apple and Broadcom are well aware of the latency bug, I will nonetheless try to contact a few of the Apple network engineers through my connections at work, and try to ensure that this issue is being addressed.


    - If you are one of those poor souls who experienced dropped connectivity issues with the original driver when using your home router, I would still recommend what has helped others in this support thread... namely, don't upgrade the driver, and rather first consider upgrading to one of the current generation routers on the market today (e.g. the top rated ASUS RT-AC66U, Linksys EA6500, D-Link DIR-868L or others I've tested, which all work perfectly fine with the .22 driver).  Some food for thought: as you probably wouldn't want to plug your brand new Mac into a crusty 10 year old Ethernet jack on a wall, I'd also consider upgrading that wireless connection on the other end if its aged beyond 5 years.


    Furthermore, by upgrading your home router to the latest technology, you will not only enjoy the full potential of AC wireless thoughput on your brand new MBA, but it will also give you important benefits which include:


    - a beefier CPU on the router for improved LAN <--> WAN routing performance

    - 5GHz band for less RF interference from other APs and other equipment operating on the 2.4GHz band

    - future-proofing with IPv6 addressing for when your ISP starts using IPv6 instead of tapped-out IPv4

    - a strengthened SPI firewall to protect your network from intrusions by hackers


    And if you're looking for something current that has all these latest features, but you're not tech-wise and want something "plug & play", the current generation Airport Extreme and Time Capsule are great for the average user too.  Btw, other great advice on home networks can be found at




    A how to:


    So for those wishing to roll back to the original wireless driver after you've upgraded your MBA to 10.8.5:  yes, there is a very simple 5 minute process that most can do, and yes this method is something that many others have done on previous MacBooks over the years (you can look back on the web and you'll see this method posted in many places and not just on this MBA thread, as the wireless networking industry which I am part of unfortunately still has a ways to evolve).  But with that said, I will still caveat that this is not something Apple supports, and I myself have only briefly tested my 2013 MBA with:


    a) after you've updated to 10.8.5, download the original driver I posted earlier here:


    b) copy that downloaded IO80211Family.kext file into /System/Library/Extensions of your Mac


    c) launch the Terminal app in your Utilities folder, and paste these commands into Terminal, hitting the Return key after each:

         sudo chmod -R 755 /System/Library/Extensions/IO80211Family.kext

         sudo chown -R root:wheel /System/Library/Extensions/IO80211Family.kext

         sudo touch /System/Library/Extensions/

         sudo reboot


    d) wait for your Mac to reboot, and then you can test for the latency bug by pinging your router in your home 15 to 20 times.  See previous posts from me on this support thread or google around on how to do that if you don't know how.  If you're seeing average ping times of less than 15ms, you're good to go.

  • raducan.mihai Level 1 Level 1 (0 points)

    Thank you very much. I can confirm that after updating to 10.8.5 my ping values were all over the place (between 1 and 80 ms). They seemed worse than using the .35 driver. I manually rolled back to .22 (instructions above) and my ping values are back to normal.

  • Super_eight Level 1 Level 1 (0 points)

    Heascase, thank you very much for the detailed analysis ... sorry to bother you again, but where do you look up the version of the related driver? I cannot find them on my system.

    A hint would be highly appreciated : )


  • raducan.mihai Level 1 Level 1 (0 points)

    upper left---- apple logo--- about this mac--- more info--- system report--- wifi (network)--- firmware version

  • Russets Level 1 Level 1 (0 points)

    It looks like this is a hardware issue and software updates won't fix it.


    The original problem was with the wifi not staying connected for some reason. It appears that the fix that the update gave did not solve the original problem, it did not stop the wifi disconnecting. Instead it was a Mickey Mouse fix, it detected when the wifi had disconnected and reconnected itself. It seems that this update not only didn't fix the original problem but also reduced the performance of previously perfectly functioning machines. Not very clever.


    It looks like the operating system update 10.8.5 still incorporates the Mickey Mouse fix.


    Headcase, thank you for the sound advice. Could it be that this process of becoming disconnected, detecting the disconnect then reconnecting itself would have inherent delays involved at each stage and hence the latency?


    Somewhere along the way (not in this thread) I read of somone with the disconnecting wifi problem in their new Macbook Air. They took it back to Apple who reportedly "reseated the wifi module" and they got the machine back working perfectly.


    Could it be that in a factory somewhere in China there is a person on an assembly line who inserts the wifi modules and has either got dirty hands or doesn't push them in properly?


    If it is a hardware issue the manufacturing batches and where they come from is the key to identifying which machines will have problems. You can play with the software forever and it won't solve the problem.

  • KlaatuBarada Level 1 Level 1 (25 points)

    Thank you for your detailed summary of the state of the MacBook Air latency issue. I have a pair of MacBooks one a week old and one circa 2011.  I have a Airport Extreme 6 generation.  On the surface everything works perfectly,  Speed tests with Comcast show that I am receiving my alloted bandwidth.  The new MacBook Air is showing 896 Mb transfer rates during Time Machine backups.


    But when you examine the ping times thats when it gets ugly.


    I am the erternal optimist and think that Apple/Broadcom will eventually get together and solve this problem.  In the meantime I will wait for a fix. 


    Remember that a bad day with Apple is better than a good day with Microsoft.

  • andQlimax Level 1 Level 1 (0 points)

    It seems strange that is an hardware problem..


    If I disable security on my router it works perfectly without drops..As soon I enable wpa2 security it start to drop, I tried every suggestion here like AES, TKIP, etc combinations..but it always drop..


    I still hope they found a way to fix this..

  • jaimehrubiks Level 1 Level 1 (0 points)

    Thanks a lot for the explanation and for the tutorial of getting back the .22 driver.


    For instance, has any of you tried disconnect or ping test using Windows on Bootcamp/refit?

  • jaimehrubiks Level 1 Level 1 (0 points)

    Ok, I need help, I tried what headcase said in order to get .22 back and it just won't work


    First of all, I copy the file but there is already one so I renamed the old one

    Then I don't know what you mean by "hit return key after each command"


    I reboot and there is still the newest driver, what could i be doing wrong?

  • raducan.mihai Level 1 Level 1 (0 points)

    You should just replace the old file. I did.

    Hit "return" means hit "ENTER" after each sudo command. Hope that helps.


    PS: If you take a look on your keyboard, on the "ENTER" key also says "RETURN"

  • jaimehrubiks Level 1 Level 1 (0 points)

    Ok Thanks problem solved, apparently as I kept both files it selects and installs the lasted one or whatever, so we need to replace it

  • Cloudi Level 1 Level 1 (0 points)

    Wonderful post headcase - thanks.


    Well, I've always been one of the lucky ones (see earlier posts). Despite that, I've loaded all the updates to see what happens and post here.


    Well the 1.0 update led to the first and oly problem I've had - wildly varying and sometimes absurdly long 'pings' to my local router.  The roll back to the ***** 22 broadcom firmware fixed that.


    So, I'cve just loaded 10.8.5.  I expected to find the same as headcase.  But I haven't got any problems at all.


    Here's my 'pings' to the local router which is two floors away (ac on 5MHz). I haven't posted the full list because despite 3 sets of 10 pings, the numbers are just the same as before I made the update.


    --- ping statistics ---

    10 packets transmitted, 10 packets received, 0.0% packet loss

    round-trip min/avg/max/stddev = 1.794/4.359/8.530/2.167 ms


    So, what does this mean?


    No idea, but I'm hoping that my experiences are helping Apple to work out what's going on.


    To me, it feels like it's part firmware but also part poor hardware quality control - why else does my MBA work perfectly now with all the updates as well as working perfectly when it came out of the box in June?





    A     P     P     L     E


                                     F     I     X             I     T    ! !





    A L S O:---






               It's now   185048 Views  and1,480 Replies all in only about 90 Days...........











  • headcase Level 1 Level 1 (15 points)

    Cloudi (and others) -


    Its tough to speculate if its a hardware issue or not, and whether it can or can't be resolved via driver updates... obviously that's something Apple and Broadcom engineers are best equipped to determine on their end.  Hence why I usually skip the speculation and focus more on best remedies to help (interim or not).


    As for your latest report, do me a favor, and double-check the version of your driver now installed on your Mac.  It could be that when you installed the 10.8.5 update on top of the .22 driver you manually rolled back to, its not trully running the driver now.  However, the *best* way to determine what's going on, would be to load a clean 10.8.5 on your MBA or I could post the full driver here and you're welcome to test that on your current install.

  • tabruhn Level 1 Level 1 (0 points)

    For several months now I've been a having a problem with my MBA'13 WiFi dropping from my university network every 30 seconds. It has been a very painful experience for me as every time I would sit down and connect to do some work my WiFi would drop. To make matters worse others (with non MBA'13 devices) weren't experiencing my issue and I also wasn't experiencing this with my other devices. I should also mention that, unlike some of you participating in this thread, I was not experiencing this issue on other networks. Today I think I might have just found a silly solution. After all of the complicated things I tried, I'm really surprised this worked.


         1.) I went to "Open Network Preferences"

         2.) Uncheck "Ask to join other networks"

         3.) Applied changes and waited for my network to reconnect.


    Since I made this change 3 hours ago I have not experienced the issue. I hope this will help some of you.

  • Cloudi Level 1 Level 1 (0 points)

    Hi headcase,


    Fair point about speculation - I'm certainly not in the least qualified to work this out.  I'll stop!


    Concerning the firmware, here's the screen shot you wanted.  It shows that I did get the new firmware:




          Card Type:          AirPort Extreme  (0x14E4, 0x117)

          Firmware Version:          Broadcom BCM43xx 1.0 (


    But here's an odd thing, my pings times have now deteriorated overnight.......



    This morning, several hours after the update, I'm getting the now familliar almost random range of pings again, exactly as you reported/predicted. Here's X30 consecutive pings just now:


    PING ( 56 data bytes

    64 bytes from icmp_seq=0 ttl=63 time=141.537 ms

    64 bytes from icmp_seq=1 ttl=63 time=147.818 ms

    64 bytes from icmp_seq=2 ttl=63 time=155.632 ms

    64 bytes from icmp_seq=3 ttl=63 time=6.203 ms

    64 bytes from icmp_seq=4 ttl=63 time=3.585 ms

    64 bytes from icmp_seq=5 ttl=63 time=4.095 ms

    64 bytes from icmp_seq=6 ttl=63 time=73.517 ms

    64 bytes from icmp_seq=7 ttl=63 time=9.698 ms

    64 bytes from icmp_seq=8 ttl=63 time=16.856 ms

    64 bytes from icmp_seq=9 ttl=63 time=9.549 ms

    64 bytes from icmp_seq=10 ttl=63 time=164.667 ms

    64 bytes from icmp_seq=11 ttl=63 time=164.888 ms

    64 bytes from icmp_seq=12 ttl=63 time=7.708 ms

    64 bytes from icmp_seq=13 ttl=63 time=42.684 ms

    64 bytes from icmp_seq=14 ttl=63 time=8.869 ms

    64 bytes from icmp_seq=15 ttl=63 time=10.614 ms

    64 bytes from icmp_seq=16 ttl=63 time=14.806 ms

    64 bytes from icmp_seq=17 ttl=63 time=17.363 ms

    64 bytes from icmp_seq=18 ttl=63 time=146.728 ms

    64 bytes from icmp_seq=19 ttl=63 time=1.999 ms

    64 bytes from icmp_seq=20 ttl=63 time=4.375 ms

    64 bytes from icmp_seq=21 ttl=63 time=8.363 ms

    64 bytes from icmp_seq=22 ttl=63 time=10.761 ms

    64 bytes from icmp_seq=23 ttl=63 time=18.873 ms

    64 bytes from icmp_seq=24 ttl=63 time=3.971 ms

    64 bytes from icmp_seq=25 ttl=63 time=5.889 ms

    64 bytes from icmp_seq=26 ttl=63 time=9.252 ms

    64 bytes from icmp_seq=27 ttl=63 time=3.377 ms

    64 bytes from icmp_seq=28 ttl=63 time=11.067 ms

    64 bytes from icmp_seq=29 ttl=63 time=5.303 ms


    --- ping statistics ---

    30 packets transmitted, 30 packets received, 0.0% packet loss

    round-trip min/avg/max/stddev = 1.999/41.002/164.888/57.995 ms



    I promiss the data I posted last night is accurate.  I ran three separate lots of X10 pings, one after the other immediately following the 'restart'. Then, I reviewed a few webpages and called it a day and went to bed.


    I left the MBA in sleep mode by closing the lid.  Then I woke it up, had a look at this forum again and then ran more pings - soemthing changed; I have no idea what.


    I'll roll-back to the ****22 firmware and report back later today......

Previous 1 97 98 99 100 101 Next