Previous 1 100 101 102 103 104 Next 2,159 Replies Latest reply: Nov 21, 2015 7:04 AM by mirvine1 Go to original post Branched to a new discussion.
  • dogschool Level 1 (0 points)

    I was also contacted by engineering a month or so no real answers or fix. Did the 10.8.5 update and it seems drop less often, but it still does. Was invited to "upgrade", but am convinced its still a hardware issue and am waiting for the real fix. If I didn`t like this MBA so much I would have returned it and got a pro.

  • headcase Level 1 (15 points)

    dogschool -


    Per the point of my last post, something I forgot to ask you earlier... what model router and firmware you having issues with?  And given its a heck of a lot easier to change out a router than it is to change out a laptop (along with the benefits gained from current generation routers that I stated on page 99), I'm just curious what your setup is.


    For the record, here's a list of recent generation routers I've tested against with zero dropped connections, zero dropped packets, and less than 3ms RTT in ping times (no latency issues) on the original .22 wireless driver that came when the MBA first shipped:


    (all running latest OEM firmware - no 3rd party firmwares)

    - ASUS RT-AC66U

    - Linksys EA6500

    - D-Link DIR-868L

    - Linksys E4200 v1

    - Linksys E4200 v2

    - Apple Airport Extreme 5th Gen

    - Apple Airport Extreme 6th Gen

    - Netgear WNDR3700

    - ASUS WL-330N travel router (awesome little device to stick in your travel bag and ideal for the MBA when you need USB Ethernet, btw)

    - Seagate Wireless Plus (great little device with 1TB of strorage you can turn into a full-blown NAS, btw)


    When traveling, I've also had no discernable issues when connected to public WiFi hotspots up to this point.


    Conversely (and as I have reported to Apple engineering), I've tested positively for poor latency with all of these devices when using the subsequent drivers.

  • ZOHEBZAA Level 1 (0 points)

    I just figured out that if I keep my MBA 13" connected to the adaptor and it has 100% charge, it does not get disconnected from the wi-fi at all. It seems that when it is on battery, it keeps going into some sort of a pseudo sleep mode ('pseudo' since you don't get to see it sleeping) to save charge even though it shows that there is wi-fi connectivity... Weird! But something's better than nothing! It did not have anything to do with the router, it seemed.

  • buffest Level 1 (0 points)

    Cloudi, my MBA (13" i7 8GB 256GB) are like yours. Never had any issues, other than the botched ping on the newer drivers. Did the rollback to the .22 driver after the 1.0 update, successfully fixed the ping values.


    I did the 10.8.5 combo update a couple of days ago - expecting ping problems anew and planning a new rollback. Checked the ping results (for spite or research matters?) after the update. Worse than ever, typically 90+ ms. Did the rollback to the .22 driver again and back to 3 ms pings.


    So my MBA still gives me no problems - with my Linksys EA6500. But it's pretty lame to have to rollback after every update, not why I chose to ditch Windows for OS X this time around, especially since driver rollbacks are a lot easier with Windows.

    (Still very glad to have ditched Windows, though.)

  • raducan.mihai Level 1 (0 points)

    We can't roll back for ever. And when Mavericks comes we'll probably won't be able to go back to .22.

  • KaushikRay Level 1 (0 points)

    I have always used Microsoft PCs and Laptops and this is my first tryst with Apple. Everytime I log on to my device to see a new update available I have look at it with reservations. I know that if I go on and do the update, I will need to backdate it wasting time in the process. Now I have stopped updating anything because of all the hassle I have been through to roll back. Should not Apple come back with an official statement now. I do not think anyone would be that angry if they knew what they were thinking and looking to do rather than being kept in the dark and fend off the issues by ourselves?


    I do not know what and when I can do my next update and how it will affect my device.


    I am having to do research on the net as to what update each is meant to be and what could be the potential implications. Thus am having to do more work to get my laptop working rather than getting any work actually done.


    I am sad.

  • Kader13 Level 1 (0 points)

    hey guys,


    i have a macbook air mid 2011 with same issue.

    after spending long hours on it, i want to share my solution.


    first here is my pb and so far what i did to fix it unsuccessfully:


    get  timeout connection for the past 2 days. sometimes it would connect to  it but the pages wouldn't load.but strangely, it will connect to my  hotspost shared connection from iphone5 AND iphone4...just not with my  modem...

    PS: my modem works fine with my phones, ipads, laptops and imac, just not my macbook air


    i tried:

    - forget the network

    - delete the network history from keychain (in disk utility)

    - reset the modem ( netgear with optus plan)

    - change the channel in the wireless settings of the modem

    - smc reset

    - pram reset

    - shut down the laptop for 2 days and try again

    - sleep mode for 2 days and try again

    - boot on safe mode

    - hold option and boot from the recovery partition then tried internet...still no success.


    i spent usless time on the phone with apple and finally called NETGEAR.

    we tried couple of things without success until the 2 last manipulations here they are:


    - go to your modem settings (http://....), enter your ID and pswd to access the settings.

    then go to the wireless settings. i changed my security options from

    "WPA-PSK [TKIP] + WPA2-PSK [AES]" to "WEP".

    then,  on the same page, go down to "Encryption WEP key" ( or whatever is the  closest depending on your modem provider) and on the first line "Key 1"  enter a NUMERICAL password then click down "Apply".

    Go on  top,Still on the same page, and change the name of your wireless  connection name ( SSID) to whatever you want and click down "Apply".




    -  go to disk utility=>keychain access and fine the line with your old  network name ( should have the "A" icon and say " airport network  password".once highlighted, delete it.

    then click on the wifi icon  (top of the screen) and click "open network  preferences"=>"Advanced"=>"Wifi" and delete any trace of preferred  networks.


    NOW try to connect to your wifi with new name and new numerical pswd and that should work ( at least worked for me)


    So far i tried ALL the tips and nothing worked.Optus and Netgear blamed my macbook air until i finally did these steps. 


    the explanation seems to be a conflict in the settings that blocked the macbook from accessing the modem.


    Please try and let me know how it goes.


  • lenixDE Level 1 (0 points)

    Hey Kader13, it seems like you don't have the slightest clue what you're doing.. i would strongly advice against changing your wireless encryption to WEP these days since it is highly insecure and easily hackable.. it's just a workaround, but not a real solution.


    Oh, and i did the 10.8.5 Upgrade on my mid 2013 Air and opposed to the 1.0 Upgrade earlier or my attempts with the .22 Driver it seems to run smooth and stable, no connection timeouts any more. I get ping times between 1-100ms to my router which isn't perfect but completly usable for me


    Hope this helps someone, when everybody else stated that the upgrade didn't make a difference i thought i would add a positive feedback as well.

  • Kader13 Level 1 (0 points)

    Hey lenixDE,


    i don't consider myself a tech but i have a good knowledge of the things i touch. all these modifications i made didn't come from my side but from the netgear technician.

    i honestly don't know about the .22 driver so i wn't go there, i also don't know if it's a workaround solution. i'm just sharing what worked for me just in case someone finds it helpful.


    if you think i shouldn't leave it on WEP for security reasons, i'm opened to any suggestions.



  • eppes Level 1 (0 points)

    My suggestion: a laptop which only works with WEP (that, as Ienix DE said, is highly insecure) is to be considered "broken" and should be returned.

  • jaimehrubiks Level 1 (0 points)

    First of all, he is not talking about Mid-2013 Macbook air, so do not include his deductions into any research, cause it might be completely different.


    With .22 patch latency is perfect but it might disconnect from some netwotks, however, the solution posted before semmed to work pretty fine using a new router, or some configuration that included wpa settings, in my case the amazon router tp-link works fine with wpa2-aes 300mbps and it costs about 17 dolars. (I will of couse not recommend using wep since it can be hacked in 3 mins)


    The problems now are:

    - Disconnections from public/work Wifi (on .22)

    - The unknown possibility to get back to .22 after new updates/maverik

  • floeff Level 1 (0 points)

    I am also affected with my new MBA mid-2013", on several OpenWRT routers. I rolled back to the .22 drivers and it works, however, it seems when I put the device into hibernation and wake it up again, the problem still is there - which yields to the assumption that it might be related to power saving mode.

  • Kader13 Level 1 (0 points)

    Yeah, i give up trying different things. the macbook is under applecare warranty so i'm just gonna take it in.

    I also put back my wireless connection back to WPA-PSK [TKIP] + WPA2-PSK [AES].

    Of course, the problem is back at the only exeption that it connected to my wifi but doesn't load any page...


    thanks for the advise though ( @eppes and lenixDE)

  • floeff Level 1 (0 points)

    Interesting spot:

    I only seem to have problems when my bluetooth headset is working... just discovered by coincidence. Maybe totally unrelated to the above problem, but who knows.

  • floeff Level 1 (0 points)

    After some more research, it indeed seem to be two problems:


    1. With the original .22 driver, latency is close to perfect for me.

    2. With the 10.8.5, latency is rather high


    In addition, the MBA indeed seems to suffer from bluetooth wifi interferences. Everytime my Bluetooth headset is active, with any driver, I have major connection issues. As soon as Bluetooth is off, all works like a charm. As a workaround, I just switched to 5 GHz wifi, no problems at all.


    Note that the Bluetooth interference issue is independent of the driver, and the latency issues independent of the Bluetooth thingie.