Previous 1 102 103 104 105 106 Next 2,159 Replies Latest reply: Nov 21, 2015 7:04 AM by mirvine1 Go to original post Branched to a new discussion.
  • Orhan360 Level 1 (0 points)

    It is preposterous to think that after 191592 views and 1,543 replies the issue of Wi-Fi connectivity is "still" yet to be solved.



    Just out of curiosity, has anyone tried trouble shooting this by usung various routers?! Try it - you may be pleasantly surprised!


  • bgsquare Level 1 (0 points)

    The latest update made my new MBA *****!!!

    What happened !??!!?

  • jebron Level 1 (0 points)

    Yup, just happened to me too.  Installed the latest update, rebooted, and now WiFi won't connect at all anymore.  I've tried 3 different AP's, and they all won't work.

  • SMT990 Level 1 (0 points)

    you can rollback the driver by using this method:


  • jebron Level 1 (0 points)

    Tried it.  Didn't work.

  • Anorax1 Level 1 (0 points)

    Just wanted to mention I have fixed my Macbook Air (2013) wifi woes. Like others I am having a problem with staying connected to the internet even though connection to the router is solid. My ping is also all over the place using the built-in Broadcom chip in the MBA. I also have a friend here at my work with the same model Macbook suffering the same issues.


    So I have worked around the issue for the foreseeable future by using an IOGEAR GWU625 wireless-N USB adapter. Rock solid ping and well supported with Mac OS X drivers by the IOGEAR company. The difference is like night and day!


    I will take my MBA into my local Apple store tomorrow and get them to run some diagnostics. I'll let you know the result.

  • Klaatu1947 Level 1 (15 points)


    Attempted your rollback on page 99. Received an error message about authorization during the initial copy.  Now my MacBook Air says (when i click on the WIFI fan) that I have no hardware installed.

    The error message indicated that the copy was unsuccessful but apparently it changed something.

  • Klaatu1947 Level 1 (15 points)


    The actual error message was "System extension could not be used, the system extension was installed improperly and cannot be used. Try reinstalling or contact vendor for update.

  • XYLIAO Level 1 (0 points)

    Hello Klaatu 1947,

    I have the same error message during the copy. But I presse ok and continue other steps in the terminal. Before reboot, my air freeze for a moment and after that il reboot automatically. Don't worry.

  • Kader13 Level 1 (0 points)

    Hey klaatu,


    I got the same message (3 windows in a row) once I finished entering the lines in the terminal,it rebooted and the MacBook is now stuck in the grey screen (with apple logo) and has these lines on the left side about "panic" and "kernel". One line says that the processor doesn't have the corresponding driver...another line says that no version of OS X is installed.

    The MacBook won't boot up not even in safe mode.

    U can still access the recovery mode though.


    I have an appointment at the Genius Bar tomorrow,hope they will fix that and the wifi issue.

  • floeff Level 1 (0 points)

    You probably forgot to run these commands in the terminal:


    sudo chmod -R 755 /System/Library/Extensions/IO80211Family.kext


    sudo chown -R root:wheel /System/Library/Extensions/IO80211Family.kext


    sudo touch /System/Library/Extensions/
  • Kader13 Level 1 (0 points)

    I entered them for sure and all in the right order. When entering the first sudo line,I had to enter my password them i kept entering the other lines finishing by "sudo reboot".

    I followed the steps religiously but I didn't get the outcome expected.

  • Klaatu1947 Level 1 (15 points)

    I pretty sure I entered all the commands as listed on page 99. No problem I have a 3:00 PM appointment at my local Apple Genius Bar.  My MBA is only a week old I will just re-migrate. Recovery partition is not an option because I will forced to buy an overpriced thunder to Ethernet adapter cord. I pass the Apple store every day.

  • headcase Level 1 (15 points)

    Klaatu1947 -


    Sorry to hear that.  You normally want to back up your computer (PC or Mac) before making changes like drivers, so that you can roll back if you encounter any issues.  For example, I've seen some people try to install a driver for a different model into their computer, and that results in issues given the driver is model-specific.  Alternatively, you could reinstall the original driver back into the existing OS.


    I will repost my instructions to include that.

  • mattw22 Level 1 (0 points)

    I've been through "3" Macbook Air's as of today. Some with build dates as short as 2 weeks ago and they all have

    huge latency issues. And those issues have shown up using three different routers at three different locations.


    I recommend if you have to purchase a macbook you stay clear of the macbook air's. The stores

    are clue-less on how to resolve it. I can confirm that the latest manufactured units are coming off the line with this issue.


    No latency issues using a wired connection on the macbook's to routers from (d-link, Buffalo, Asus).