Previous 1 11 12 13 14 15 Next 2,159 Replies Latest reply: Nov 21, 2015 7:04 AM by mirvine1 Go to original post Branched to a new discussion.
  • tthiel1 Level 2 (160 points)

    What update?  For what?


    Just occurred to me to wonder if people using Mavericks beta also have this issue.

  • wifiguru Level 2 (240 points)

    What router were you using and which model firmware did you upgrade from/to. That kind of detail might help some of the other posters here.

  • wifiguru Level 2 (240 points)


    What you are describin seems like a WAN side issue on your ISP side. If the Mac's could talk to each other within your network, then that means your internal LAN is good. What does running WIreless Diagnositcs tell you ?

    General rule:

    - if you can ping your router but cannot ping or, then its not a wireless LAN side issue. Its a WAN side issue.

  • elohquiel Level 1 (0 points)



    As a CCNP Wireless engineer, I'd like to add my name to the list of those affected and give my thoughts as to what the problem is.


    I have several SSIDs running at home, two G networks, one N network, and a new AC network. I have run into this issue connecting to all of my SSIDs, as well as a tethered connection to my Android. I can ping my wireless adapter's IP address, I show up in the DCHP server's pool, I even show up in my router's ARP table. But my laptop cannot ping it's default gateway, nor any other device on my subnet; the opposite is true.


    Here are is a list of my networking gear.

    APs: Airport Extreme (2012 and 2013 versions), Cisco 881w, Cisco AIR 1240 and Cisco AIR 1210

    Firewalls: Palo Alto (work), Cisco ASA 5505 (home)

    Multiple ISPs at work and a single at home, plus whatever Starbucks uses.


    There is no way that this is an upstream provider problem. If i cannot ping my own gateway, hosts in my subnet, or any servers within my DMZs, then that should point to a hardware failure.

    Hope this info helps.

  • wamapple Level 1 (0 points)

    Exactly.  I played around with my router at home and my new air is better there, but what about all the places I go now?  Are we supposed to dig into the network, router, etc., wherever we try to connect?  I just tried Panera and my friend's home- kept dropping.  I returned my Air last week because I thought it was a hardware problem.  Will return this one as well because obviously it's more than that.

  • Rosember Level 1 (0 points)

    wifiguru wrote:



    What you are describin seems like a WAN side issue on your ISP side. If the Mac's could talk to each other within your network, then that means your internal LAN is good. What does running WIreless Diagnositcs tell you ?

    General rule:

    - if you can ping your router but cannot ping or, then its not a wireless LAN side issue. Its a WAN side issue.

    Hi wifiguru, thanks for your help, appreciated. Yet, I just had a technician here, expert for all things Mac. He confirmed issues of both his and mine MBA 2012 connecting to the internet as described in my previous posts while - at exactly the same time - four (4) other Macs/iOS devices had not the slightest issue in going online. Of course, in a constellation like mine the first thought is: WAN problem. Yet, this seems to be highly improbable to me as only the two MBAs have problems (and the expert agreed with me - after checking some of his diagnosis tools which go far beyond the onboard wireless diagnostics). There is an issue at least with the 2012 MBA in certain wifi environments. I guess, it is software based as an hardware issue probably would show up in more environments. At least, exchanging the MBA doesn't seem to offer any improvement.

    I now cannot use my MBA, my work horse computer (I am a medical journalist), reliably any more for more than half a year at home and at other locations. This is absolutely unacceptable, and I am in contact now with a senior support guy from Apple (after having been the ball in a LONG ping pong match between Apple and two internet providers). I definitely need a solution for this "issue" very soon. And I hope I won't have to talk to my lawyer because Apple doesn't deliver what they are promising.

  • theliuman Level 1 (0 points)

    Yeah, I got the new 802.11ac Time Capsule and it's working flawlessly (as expected).


    But since this laptop is built for mobility, going anywhere else is a crapshoot for the time being.

  • tthiel1 Level 2 (160 points)

    Well that's interesting that the new router works.  No doubt that's what they are using in Apple stores.

  • theliuman Level 1 (0 points)

    When I picked up my the new 802.11ac Time Capsule yesterday, I asked what the store was using for wireless routers and the guy said some Cisco ones.


    Either way, I'm sure their wifi hardware is newer and has the latest firmware.

  • tthiel1 Level 2 (160 points)

    Interesting..should go by the local one and run a wirelss sniffer to see what they are using.

  • dwmreg64 Level 1 (25 points)

    Can someone please tell me if the problem persists if they hook up to the non-5 gHz network?

  • moo360 Level 1 (0 points)

    Hi guys, just thought I'd add my 2 pence here.


    I've got the 2013 macbook air 1.7ghz 256 ssd 8 gig ram.  Also have the new AirPort extreme (not timecapsule) and wifi works fine with it even at range.  But at work we have some cisco 801.11n accesspoints and it will connect and work for a short period but then stop working.  Pings start getting 'no route to host' even though the wifi shows as still connected.  Sometimes disabling wifi and re-enabling it fixes the problem, but most of the time you need to reboot.


    I also found that the wifi drop can be 'forced' by trying to SEND a lot of data out over the network.  For example if I'm on the work wifi and I try to mirror my screen to one of our apple tvs, it works for about 20 seconds and then my wifi dies.


    At home all this functionality is fine, I've been connected for 5-6 hours at once on the airport extreme and have no problems at all.


    So yeah it does seem that the new airport extreme works fine, but any other vendor routers are causing a problem with the mba.  Other devices I have work fine with the wifi at work so I can only assume it's an issue with the mba.

  • desertcaye Level 1 (0 points)

    I have both the new MBA and new AirPort Extreme.  As posted previous with AirPort Extreme works great, but elsewhere not....

  • Liquidfuture Level 1 (0 points)

    I have been having the same problems with dropped wifi on my new Haswell MacBook Air.  I either have to reboot or reboot my router in order to get connected again, and then it usually only lasts for one or two page loads.  All other devices, Apple or non, can connect without issue.


    I changed my wireless router (Netgear WNR2000) security protocol to WPA2, and so far, it seems to have solved the problem.  Only snag is, I changed the protocol to WPA a few months ago because my then new iPad Mini wouldn't stay connected to WPA2.  Not sure if the switch to WPA2 is responsible, but I thought I'd share.


    At this point, I'd rather my iPad Mini be screwed than my new Air, but Apple...let's get on it, huh?

  • Cloudi Level 1 (0 points)

    Hi. Just reading thread ahead of receiving my MAB 2013 13" next week. I have two 802.11 ac routers (Netgear + Linksys) - I'll report back on Wednesday.


    This different thread originating in 2010 has just had a new post that's interesting (JohnWI, 18/06/2013, 08:59) Is this evidence that the latest Airport update maybe part of the problem? Visit:


Previous 1 11 12 13 14 15 Next