Previous 1 126 127 128 129 130 Next 2,162 Replies Latest reply: Apr 14, 2016 12:51 AM by aliihsan Go to original post Branched to a new discussion.
  • Zackt2012 Level 1 Level 1

    I returned my first macbook air because of the wifi issue.  Purchased another macbook air and had the same issue of losing wifi connection at least 10 times a day.  As suggested in this post I turned the bluetooth off and it fixed the wifi issue.  I have not lost a wifi connection for the last 5 days.

  • Kevin Ford1 Level 1 Level 1

    Just wanted to say that I have had severe random latency issues on my Macbook Air right up until the time I disabled power nap on both mains and battery power, not sure if that will help you guys. I hope Apple patch the issue soon but until then for me good wifi performance is far more preferable than having it check my emails while I'm away.

  • GingerT63 Level 1 Level 1

    Thanks for the link and to all who suggested turning off the Bluetooth--that has fixed things for me I think, after tons of frustration.  I have a 2012 MBA, and while I've always had slow connectivity at times, it has gotten intolerable after  I upgraded to Maverick.  I am writing this on my HP laptop, because I could not connect AT ALL this afternoon with the Air.  The PC is sitting right next to the Air, no problems connecting--so it is not the router, it is the MBA and Maverick made it much worse.  Apple, you need to fix this.  I had just about given up on the Air, and I'm not happy about not being able to use my mouse. 

  • jcr2173 Level 1 Level 1

    I am really sad to know that 10.9.1 update didn't fix it for me.


    How can an update that doesn't mentions that it is addressing this particular issue really fix it?



    This update includes:

    • Improved support for Gmail in OS X Mail, and fixes for users with custom Gmail settings Improves the reliability of Smart Mailboxes and search in Mail
    • Fixes an issue that prevented contact groups from working properly in Mail
    • Resolves an issue that prevented VoiceOver from speaking sentences that contain emoji
    • Fixes an issue that prevented iLife and iWork apps from updating on non-English systems
    • Addresses an issue that may cause multiple prompts to unlock “Local items” keychain
    • Addresses an issue that may cause Japanese keyboards to retain a previously used language
    • Resolves issue that prevents a Contact group name from populating the address field
    • Includes Safari 7.0.1
      • Fixes an issue that could cause Safari to become unresponsive when filling out forms on,, and other websites Improves Credit Card Autofill compatibility with websites
      • Improves VoiceOver compatibility with
      • Updates Shared Links periodically when open in the Safari Sidebar
  • EMac93 Level 1 Level 1

    I have the newest macbook air with the same wifi problems as many have stated;however, they just started about two weeks ago with no warning. I've looked online at all the tips and tricks to work around with no luck. My bluetooth was never on to begin with so that fix does not apply. When I do get connected, it stays connected through sleep and such;however, it does not connect when I completely shut it down. A strange solution I have found so far to this problem is by first connecting the macbook to my iPhone's hotspot, I have no idea if the same goes for android/other phone's hotspots since I only deal with iPhones, then from there connecting it to my home's local network. So far it has worked every time I have tried it, granted its only been maybe a half dozen tries, but it revealed more promise then other solutions I have read. I have only tried this solution at home, and have yet to take my computer anywhere else. Let me know if this solution works for anyone else, it might be inconvienent, but when it works the connection is solid for me.

  • Itexz Level 1 Level 1

    I have same problem with my new MacBook Air

    I have MD711RU Model

    After wake up, my mac didsn't see my Linksys E3000 router and it networks Cisco2 and Cisco5. He see 10 other networks, but not mine 2.4 GHZ is not avalaible and 5GHZ not availablee too.

    My Air is near router, so it's not signal problem.

    I need to turn-of and turn-on wifi 5-6 times, to get connected to my network....



    Here you can see what channels are used

  • bwredman Level 1 Level 1

    Thanks! This works for me too.


    It's sad that we have to resort to work arounds like constantly driving network traffic to get the system to work as designed.

  • Jeff Geerling Level 6 Level 6

    Same problems here, and I just got back from my 2nd Genius Bar appointment, and the 2nd time I've had to leave my Air with the Apple Store for two days.


    See related post:


    The only workaround (which works most of the time, but flakes out sometimes too) is to ping the WiFi router 5 times per second, constantly, otherwise latency is all over the place (50+% deviation... I get 30ms ping to, then 2000ms, then 400ms, then 50ms, then 1800ms, etc.).


    There's no rhyme or reason to this problem, and I've had an AirPort card replaced, and the geniuses ran a 'stress test' on the laptop that returned in flying colors.

  • Chisleu Level 1 Level 1

    I had my case escalated all the way to developers. I sent them a wifi connection monitor log and they immediately replied that it was a known bug and they are working on it. It is not fixed in the latest update.

  • gmc74 Level 1 Level 1

    They have been working on this for ever, I bought my Air this summer right after they were released, soon there after I sent them two routers that it was happening on.  I haven't had the issue on any Apple routers.

  • Jeff Geerling Level 6 Level 6

    More troubleshooing info (also posted in this thread):


    On my home network, where I have control over the access points, I switched my AirPort Express from 802.11n (b/g compatible) to 802.11n (a compatible), and now everything works like normal (full speed, low latency, no hack required).


    Unfortunately, I can't change any settings on my employer's WiFi or anywhere else for that matter. But if you only use your MBA in one location and have control over the router, and can switch it to an 802.11n mode, it might help.


    I'll be scheduling another genius appointment soon .

  • CMCMC Level 1 Level 1

    Go to page 105 and read the entry from 'headcase'.  That is what I am referring to below.  (Sad that we're well over a hundred pages and no fix from Apple...) 


    I think this was the fix!  I am working on a Late 2013 MacBook Pro Retina 15".  It never did have the 74.22 driver, so has had this latency issue from day one.  I've had it for a few weeks now.  It came preinstalled with 10.9.1.  I've had a couple of drops after sleeping, but wasn't anything significant.  The latency however is/was enough of a reasonf ro me to return it.  I'm a network engineer and need performance to be top notch. 


    I wasn't quite sure if it was a hardware or software issue.  I was pretty certain it was software, but, being that I'm in a window to return, I was going to go that route instead of wait and hope for a fix.  I know many others have the same issue.  Even went to the Apple store and compared side by side a MPB (non retina) and an Air.  Same issue that I can produce at my house with a MBP and MPBr.  Running a rapid ping to anywhere keepts it going fine. 


    I won't say the latency is totally fixed after rolling back to another driver, but it is SIGNIFICANTLY better. 


    ********THANK YOU**********

  • spekkie Level 1 Level 1

    Well i was having the same issues very random pings etc but here is the deal!


    When i just run a ping it is very random latency issues and so on.

    like so

    4 bytes from icmp_seq=254 ttl=255 time=0.796 ms

    64 bytes from icmp_seq=255 ttl=255 time=223.147 ms

    64 bytes from icmp_seq=256 ttl=255 time=0.806 ms

    64 bytes from icmp_seq=257 ttl=255 time=1.353 ms

    64 bytes from icmp_seq=258 ttl=255 time=291.489 ms

    64 bytes from icmp_seq=259 ttl=255 time=212.696 ms

    64 bytes from icmp_seq=260 ttl=255 time=134.352 ms

    64 bytes from icmp_seq=261 ttl=255 time=55.820 ms

    64 bytes from icmp_seq=262 ttl=255 time=283.809 ms

    64 bytes from icmp_seq=263 ttl=255 time=204.195 ms

    64 bytes from icmp_seq=264 ttl=255 time=125.166 ms

    64 bytes from icmp_seq=265 ttl=255 time=46.287 ms

    64 bytes from icmp_seq=266 ttl=255 time=273.245 ms

    64 bytes from icmp_seq=267 ttl=255 time=193.455 ms

    64 bytes from icmp_seq=268 ttl=255 time=114.120 ms

    64 bytes from icmp_seq=269 ttl=255 time=35.243 ms

    64 bytes from icmp_seq=270 ttl=255 time=264.030 ms

    64 bytes f


    No i connect to an airplay device (appletv) and thus generate some traffic.

    the same ping is showing me.

    64 bytes from icmp_seq=370 ttl=255 time=0.792 ms

    64 bytes from icmp_seq=371 ttl=255 time=0.814 ms

    64 bytes from icmp_seq=372 ttl=255 time=0.844 ms

    64 bytes from icmp_seq=373 ttl=255 time=0.896 ms

    64 bytes from icmp_seq=374 ttl=255 time=1.254 ms

    64 bytes from icmp_seq=375 ttl=255 time=0.828 ms

    64 bytes from icmp_seq=376 ttl=255 time=0.865 ms

    64 bytes from icmp_seq=377 ttl=255 time=0.873 ms

    64 bytes from icmp_seq=378 ttl=255 time=0.847 ms

    64 bytes from icmp_seq=379 ttl=255 time=0.847 ms

    64 bytes from icmp_seq=380 ttl=255 time=0.878 ms

    64 bytes from icmp_seq=381 ttl=255 time=0.878 ms

    64 bytes from icmp_seq=382 ttl=255 time=0.799 ms

    64 bytes from icmp_seq=383 ttl=255 time=0.796 ms

    64 bytes from icmp_seq=384 ttl=255 time=0.878 ms

    64 bytes from icmp_seq=385 ttl=255 time=0.773 ms

    64 bytes from icmp_seq=386 ttl=255 time=0.890 ms

    64 bytes from icmp_seq=387 ttl=255 time=0.908 ms

    64 bytes from icmp_seq=388 ttl=255 time=1.285 ms

    64 bytes from icmp_seq=389 ttl=255 time=0.968 ms



    My guest is is has something to do with appnap!

    Although it seems more sensitive to ipv6 traffic than ipv4.


    So my conclusion is that it is OSX/driver related. Please apple fix this.

  • CMCMC Level 1 Level 1

    You're absolutely right!  When there is traffic using the connection it returns to normal level.  My guess is that it is so aggessisve at conserving power that it powers it off or to a deep sleep even at the "tenth of a second" level  My guess anyway from what I've seen. 

  • CMCMC Level 1 Level 1

    I also have to update my previous "fixed" post.  Although the latency was fixed by rolling back to an older driver, the dropping returned.  And that's far worse than the latency.


    Apple...Fix this!!