Previous 1 2 3 4 5 Next 2,156 Replies Latest reply: Jan 30, 2015 1:17 PM by tonywong Go to original post Branched to a new discussion.
  • gmc74 Level 1 Level 1 (0 points)

    It isn't my router, I have two networks at my house (two routers) and it happened on both.  I haven't had a reoccurrence of the issue since I did what was contained in my post above.

  • JakeThomson Level 1 Level 1 (0 points)

    It definitely isnt the router. Looks like a hardware problem and running diagnostics in the background prevents it dropping off.

  • gmc74 Level 1 Level 1 (0 points)

    Before you take it back, try what I posted last night, it seems to have worked for me-


    Here is what I have done -


    renewed DHCP lease, Change MTU (there is a link in the story linked below that explains how) settings and then followed the instructions on this page.


  • JoshuaKinsey Level 1 Level 1 (0 points)

    I tried these steps. It dropped again about two minutes after the reboot following deleting the preference files. Once the wifi drops, it will no longer see any wireless networks. If it's working correctly and I turn the wifi off then back on, it will continue to work correctly until it drops.


    After that, the machine will no longer see any wireless networks until it's rebooted or it wakes up from being asleep. I also noticed that the machine will "freeze up" for about 5 seconds at the same time as the wifi dropout. Definitely seems like some sort of hardware issue. i have an appointment this evening at the Genuis Bar. I'm hoping they can fix it quickly as I need the machine next week for a trip.


    Thanks everyone for your help. I'll keep monitoring here and report back what the Genius Bar tells me tonight.

  • gmc74 Level 1 Level 1 (0 points)

    Good luck, I hope they figure it out.  That sounds a bit worse that what I was experiencing.

  • Maliath Level 1 Level 1 (0 points)

    I just formatted the drive, and I'm downloading OSX for a fresh reinstall. If that doesn't work I am going to do what you did gmc74. By then, maybe I'll have another answer.

  • gmc74 Level 1 Level 1 (0 points)

    If a full reinstall does not work, I doubt what I did will, but good luck.

  • Xtna1016 Level 1 Level 1 (0 points)

    tried all ways posted here. didnt work. returned it this morning. they exchanged it. now its working perfectly fine. it has to do with the hardware.

  • JoshuaKinsey Level 1 Level 1 (0 points)

    I'm almost positive mine is hardware too. My concern is that they won't be able to just swap it out. I ordered mine from and upgraded the memory to 8GB. It doesn't look like they have that configuration available in stores around me currently. I'm wondering how they will handle it.

  • Hijej Level 1 Level 1 (0 points)

    Xtna1016: and it's still working good?

    I've also tried everything posted here and without success...


    Btw. I was today i Apple Store to show them my problem, and... I got no drops on their WiFi. Maybe it's something with 2.4 GHz broken? (They had 5GHz router)

  • gmc74 Level 1 Level 1 (0 points)

    Mine is acting up again.  I have taken to creating a wifi network on my MacBookPro and connecting to that to see if the issue continues. 

  • Maliath Level 1 Level 1 (0 points)

    Okay, I have reinstalled OSX Mountain Lion, and I will update this thread after a few hours to see how it's going. But, please read below:


    In order to reinstall, I attempted to use recovery mode (held down command-R at boot). First I booted into recovery mode, then I formatted the hard drive, then I attempted to install OSX via wireless connectivity. However, the wireless stalled halfway through. Again, just like what we have been experiencing in normal desktop mode, the wireless icon showed I was connected, but data simply stopped transferring. I disconnected the wireless and reconnected (while still in recovery mode) and the OSX download seemed to pickup where it left off, but it kept happening. I became impatient with this, so I made a USB bootdisk (I used several different methods, Lion Diskmaker, Disk Utility, and even using the Apple Recovery Disk app). None of these USB boot disks would work. When I attempted to boot and hold down the option key, I could see the USB, but it would not boot from any of them. It would simply return to the prohibitory sign (like a do not enter sign) and then turn off. So then I decided to try and go back to the regular recovery mode, but because I had formatted my drive earlier, the recovery disk partition was no longer there!!! Finally, I booted into Internet Recovery Mode (command-option-R at startup). This mode downloads a recovery mode environment from Apple servers. This time, after downloading the recovery disk software from the servers (instead of using the one pre-installed on the macbook air when I got it), the internet never stopped working. The download took about an hour and never stalled.


    The fact that the downloading of OSX never stalled at all after I downloaded a NEW recovery disk via the internet recovery mode (instead of using the preinstalled one) makes me think that this is actually a software issue and not a hardware issue. Perhaps it's possible that a certain amount of these machines were shipped with corrupted drivers. I simply don't know.


    If you do what I did, I recommend that you first get the ethernet thunderbolt cable, because it can take a long time to download OSX over wireless, and it's possible that this is indeed a hardware issue and you will end up with a formatted computer with no way to reinstall an OS and you'll have to either go to the Apple store or mail your machine in. Again, none of the USB boot disks I made worked.


    Good luck everyone, I'll update this thread later.

  • Maliath Level 1 Level 1 (0 points)

    Okay, update after about 4 hours after complete format a reinstall with internet recovery mode, and so far no hang ups yet. I'll post another update tomorrow. But, so far so good. Maybe a complete format and reinstall is the solution? If you decide to do it, make sure and read my previous post.

  • Fred Braches Level 1 Level 1 (10 points)

    Screen Shot 2013-06-15 at 8.56.20 PM.png

    This when the WiFi connection fails

    And the following when everything is normal.

    Screen Shot 2013-06-15 at 8.40.35 PM.png

  • JoshuaKinsey Level 1 Level 1 (0 points)

    Mine was doing the exact same thing. I took it to the Apple Store and the Genius said he believed it was a software problem and not a hadware issue but I guess he did not know how to correct it. They chose to swap out my unit with a new one.

Previous 1 2 3 4 5 Next