Previous 1 41 42 43 44 45 Next 2,156 Replies Latest reply: Jan 30, 2015 1:17 PM by tonywong Go to original post Branched to a new discussion.
  • Keith R Thompson Level 1 Level 1 (30 points)

    I just made the switch. My wifi was under one of the two Bluetooth choices. I won't know until later if it solves anything, since my home network is working fine. It'll be amusing if the solution turns out to be this simple.

  • AlexJames8 Level 1 Level 1 (0 points)

    Ok. Open "System Preferences" (from your Dock). Then go to "Network". On the left side at the bottom (of window) you'll see 3 small buttons (+, -, the_third_button). Click the_third_button. Select "Set Service Order...". Drag Wi-Fi service to the top and click OK.

    Now you can use your Wi-Fi connection. Good luck.

  • bricelin Level 1 Level 1 (0 points)

    i tried this trick, it didnt work for me. i still lost wifi after a few minutes, and have to disconnect and reconnect.

  • mukaltin Level 1 Level 1 (0 points)

    Half an hour and still no connection drops. I would be so hating myself now if I didn't listen the shop assistants yesterday when I came there to hand in my laptop. As I bought it from a third party, a process of refund would take me about 10 days.

    God bless the soul who discovered this solution.

  • AlexJames8 Level 1 Level 1 (0 points)

    Well, I'm not sure, but

    I did this too: http://osxdaily.com/2012/11/30/resolving-stubborn-wi-fi-connection-problems-in-m ac-os-x/ (turn off wi-fi, move 3 or 4 files to desktop, restart the computer) before  I've changed the order.

    Maybe it works together, I don't know. Maybe someone know.

  • rbothe Level 1 Level 1 (0 points)

    I have had my MBA for 10 days. It is a 13" i7' 8 GB 256GB ordered. So far I have had no connectivity issues at home or office. Home router is Cisco/Linksys set on WPA2 and the office is also Linksys, set on WPA 2. I have not yet tried other locations such as Starbucks, etc.

     

    I have been following this discussion almost from its inception and delayed ordering the MBA for some time. Not being a techie and not living near a retail store (closest one is almost 2 hours away) I had a bit of trepidation ordering one in the face of the storm.

     

    For all suffering from the myriad of issues discussed here, hopefully a solution comes sooner than later.

  • saldb Level 1 Level 1 (0 points)

    Hi all - i just got the mid-2013 macbook air. within the first day of using it at home the wifi was dying constantly with symptums described in this thread. I use the latest stable DDWRT on my linksys router (wrt160Nv3)

     

    I changed the encryption to WPA2 Personal Mixed and problems immediately went away. It's been 2 days without problems - perhaps they will return?

     

    I noticed there were also strange conflicts with the DHCP where my ipads would take the same IP as the macbook - but this could be a side effect of my heavy troubleshooting.

     

    If this really is the solution for this specific router, then it's totally a software problem and apple should be able to patch it.

  • daxbanjo Level 1 Level 1 (0 points)

    Having similar problems. Got new Haswell MBA 13" about a week ago (i5, 256, 4GB RAM).

     

    Wifi connectivity drops, but still shows fully connected status in toolbar. I can either restart computer, turn wi-fi off then back on, or attempt to connect to another random network and then reconnect to mine and connectivity will come back. But connectivity will eventually drop again, no matter what. At first it was only happening 1-3 times per day, but today it has happened every 15-30 minutes, sometimes quicker.

     

    Probably a coincidence, but seems to be happening a lot today specifically while browsing reddit (image heavy site).

     

    I just closed my dropbox and google drive applications (which continually sync) to see if that would free up the problem. I'll post an update if that has any effect.

     

    I've tried other suggestions in the thread but problem has always resurfaced.

     

    Other problems I'm having, my computer will randomly sleep (screen goes black), usually within a few seconds to a minute or so of sleeping it manually. Really annoying.

     

    Also, google chrome is having many plug in and flash/active x errors and needs to close. Pictures seem to be loading slowly. I have a few chrome extensions that it may be having trouble with, but all my other computers/devices (both PC and MAC) work flawlessly with the exact same browser/extensions.

     

    All other devices work flawlessly on my wifi as well (both PC and MAC devices).

     

    Belkin router, Motorolla DOCSIS 3.0 modem.

  • anuragwadhwa Level 1 Level 1 (0 points)

    Issue resolved with the Wifi 1.0 update.

     

    Ref:

    "

    You have been selected to join our AppleSeed Program. If you accept, we will provide you with a pre-release version of the MacBookAir WiFi Update 1.0 to install and use.

    While trying out MacBookAir WiFi Update 1.0, we ask that you provide us with your feedback. Our program includes a bug reporting system for our participants. If you wish to be a seed volunteer and help Apple release high-quality software, follow the instructions below........"

  • PlotinusVeritas Level 6 Level 6 (14,700 points)

    I wonder if (as i predicted) the fix is burried inside the upcoming 10.8.5 update which was released as beta to developers TODAY screenshot_06.jpg

  • wofsie Level 1 Level 1 (0 points)

    Having the same issues with my 13 inch MBA.  Got it and within an hour it stopped working even though it showed a strong WiFi connection.  I turn it off and reboot and it is fine for 5-10 min max before it locks down again.  Two iPhones, an iMac and an older 11" MBA are all working with no problems, while my brand new Air has me turning it on and off over and over.  I bought it at an authorized Apple Dealership and had it configured to order.  They would be able to take it back and refund my money if it were standard, but with the Apple policy that once a CTO macbook has been opened unless it is "dead out of the box", they won't take it back until Apple tells them they will honor the refund to the store.  The Apple tech ran me through some things on the phone and agreed my Air indeed fit the criteria for not working out of the box since the problems started within an hour of starting it up.  He had me send it back to Apple and a new configure to order Air was shipped to me.  Got it today, and within 30 minutes of starting it up, it refused to do anything on Internet and even though it shows a strong WiFi connection locks me out until I reboot.  This one is worse then the original New Air that was replaced.......totally worthless.  The Apple tech says because I purchased it at an Apple Authorized Dealer and not an Apple Store, Apple will not refund my money.  He says Apple will not refund the Mac Store for the CTO Air because only Apple stores are authorized to sell Apple computers!  The Tech is also saying Apple may not replace this computer again since they did it once already and it is a CTO and not a basic model!  The Mac Store says they will refund the money once Apple assures them they will honor the policy of refunding them for this special order Air that is dead out of the box.........but Apple refuses to acknowledge there is a problem, even though it has been confirmed by the Apple tech that my Air won't work or recognize WiFi!  My hope is to get a refund until Apple gets their act together and fixes this problem........and then I will purchase a new MBA that actually works.  I was even willing to send the second Air back to Apple and have them not reconfigure a new Air until this is solved if I can't get a refund, but they can't even agree to that!  Anyone else have this sort of problem with being caught in the middle between Apple not honoring their policy with one of their authorized dealers and not being able to return the bad Apple to the original Mac Store until that happens for a full refund?  Any suggestions???  Help!!!

  • zqx321 Level 1 Level 1 (0 points)

    I previously posted that my i7 8GB 512GB custom-build shipped from China would hang within a few seconds to a few minutes after connecting to any kind of wifi network. By hang, I mean screen frozen and no response from mouse or keyboard or anything else. Only recourse was to power down and cold boot (an old expression, for you youngsters.) All the configuration tricks mentioned here were tried, to no avail. This was tested with a Time Machine (802.11n version), iPhone tether, a Comtrend wireless router/modem (802.11n), a Cisco router (802.11g) and a rather old Linksys router (802.11g). Connecting to any of them caused the MBA to hang in short order. The MBA worked flawlessly in all other respects -- even with a USB wifi dongle.

     

    I also posted that Apple Customer Service was outstanding, escalating the problem quickly to an expert in the Network group who had me run tests that proved the problem was bad hardware (I booted from the Recovery partition with the same result.) Apple deemed the machine DOA and replaced it.

     

    When the replacement MBA arrived (again from China), I backed up the fist MBA to Time Machine. Rather than migrate immdiately, I booted the new MBA with the stock install and tested wifi. It worked perfectly. I then reloaded the new MBA from the Time Machine backup and tested it extensively with all the wifi devices listed above. Operation was flawless without changing any configuration parameters. Also went to Starbucks and tested three local wifi networks (two 802.11n and one 802.11g.) Again, flawless operation. No hangs, no disconnects.

     

    I haven't been able to test 802.11ac yet because I don't have (or yet need) ultra high-speed wireless at home (got gigabit Ethernet for that), and no one has it running loacally either (I live in a small town with only an Authorized Apple Reseller, no Apple-owned store.) I'll be traveling this weekend and will stop into a Apple-owned store to test 802.11ac.

     

    My fingers are crossed, but I believe I have a good machine now.

     

    Once I had the new MBA working, I erased the Macintosh HD partition on the bad MBA and attempted to reinstall OS X. This part of recovery needs some work -- it wants to download the latest version of the OS, and it comes up assuming you have wifi and tries to connect. Of course, the bad MBA would quickly hang after connecting. I managed to figure out that I could click on X to disconnect from my wifi network, plug in the Thunderbolt Ethernet cable, reboot, and download OS X that way, but it took several tries. The download estimate was 6-7 hours, so I went to bed. When I awoke, the install was in progress, with 23 minutes to go. But the MBA was hung. I think it might have reconnected to wifi after the download, but there's no way to tell. I tried running the install again and again, probably half a dozen times, and it always hung immediatley or after a few minutes.

     

    Then, having read the thread that speculated about a power problem that disables the mouse pad, I tried continuously "swirling" the mouse while the installation proceeded. I had to do that for something like 25 minutes, but by golly it worked! Got OS X installed. Amazing. Could have been a coincidence, but I don't think so.

     

    I booted into the vanilla install and deliberately turned on wifi to make the MBA hang. It did, and then I tried plugging in a USB memory stick and an SD card. I figured if it was just the mouse pad being torched, maybe the CPU would show some life when I plugged in another device. The MBA did not respond. Obviously the memory stick is USB, which might be part of the same bus as the mouse pad. Not sure about the SD card. My sense is that the CPU was either stopped or in an infinitel loop, but there's no way of knowing.

     

    Unfortunately, I was in a hurry to pack up the bad MBA and initiate shipping, so I didn't test "swirling" the mouse while connected to wifi to see if that would prevent the hang. I didn't have 20 minutes or so to do that, and it's hard to prove a negative.

     

    So, it's clear that my MBA had a hardware problem related to the wifi components. I'm sure that the small number of wifi-hung (dead) MBAs that have been reported here suffer from the same problem.

     

    As for the much more commonly reported problem in this thread, wifi disconnect shortly after connect, my guess is that the root cause is also defective or marginal wifi hardware, but that the severity of the problem varies from one MBA to another. I believe that's why certain "fixes" (WPA2, changing order of network devices, etc.) work in some cases, but they don't work in other cases.

     

    I'm very doubtful that the disconnect problem is due to bugs in OS X or the firmware because there are likely lots of new MBAs that work perfectly (like the one I just got), and most of the machines in question are running the same software and firmware. It's possible the migration process has bugs that allow bad configuration information to get migrated from another Mac, but I'm sort of doubtful about that, too. It's possible that the new wifi chipset doesn't work with certain routers, or only works with them if you change configuration parameters, but I suspect there are a very small number of such cases and Apple can probably address those in software or firmware.

     

    If I'm right that most of the problems reported here are caused by defective or marginal hardware, I wouldn't panic yet. It may be possible for Apple to fix the disconnect problems in firmware or hardware. It could be as simple as dealing with bogus loss of signal statuses or revising the power-saving algorithms to compensate for variations in chip tolerances (the latter is my leading theory on the hardware problem -- unexpected variations in voltage or current tolerances in the new wifi chips Apple is using.)

     

    One way or the other, I believe Apple will solve this problem.

  • anuragwadhwa Level 1 Level 1 (0 points)

    Since my previous post MBA has stopped working. whenever you wake up the computer it says connection time out with the saved wifi.. phones and other laptop working fine on same wifi!

  • daxbanjo Level 1 Level 1 (0 points)

    Hey all,

     

    Just posted earlier today.

     

    Afer stopping sync and closing both my dropbox and google drive apps, my wifi connectivity problem has dissapeared. I've been going on about 10 hours now of heavy use and haven't had a connectivity drop yet. Before quitting those apps, I'd get one every 10 minutes or so eariler today.

     

    Maybe it's a coincidence.

     

    If you have dropbox or google drive on your computer, you might want to try stopping their sync and closing them completely (right click on their icons that are near the wifi icon in the upper toolbar and "quit", making sure they dissapear from the upper toolbar). Let me know if you get similar results.

     

    I'm going to open back up and see if I can make the connectivity problem reappear.

     

    Of course, this isn't a "fix", just a work-around, but maybe it can help narrow down the problem.

  • wofsie Level 1 Level 1 (0 points)

    I hope you're right!  Congrats on getting one of the Airs that works.  With the Air I got today, I did not and have not migrated anything from my other Air stored in Time Capsule as well as an external hard drive.  Both of my configured to order Airs were also made in China.  Any idea if the CTO Air that is dead out of the box can be refunded from an authorized Apple dealer or why I am being told by Apple and the dealer that it isn't possible?  It would give such peace of mind to stop this sending a dead Air back so a new potential faulty one can be sent to me only to have to repeat the whole thing over again!  There would be much more peace of mind to get the refund, or even have Apple hold onto the defective dead Air and reconfigure a new one in a few months when this mess is straightened out.  Sorry for the rant, but I feel so caught in the middle with no answers and a second dead expensive Air! 

     

    Apple, where are you and why doesn't someone from Apple speak up?  I would love to even be one of the chosen ones to be an Apple Seed and try the new program out and see if it fixed this issue.  So frustrated!

Previous 1 41 42 43 44 45 Next