Previous 1 2 Next 15 Replies Latest reply: Jun 27, 2013 2:34 AM by meyers2112
meyers2112 Level 1 Level 1 (0 points)

So all of a sudden everything that requires Adobe Flash on my MacBook (2008 version) doesn't work and says there's a "missing plugin". YouTube provides a link to Adobe's website to download the latest version of Flash, however when I try to download it from the website, it doesn't download; in fact absolutely nothing happens.
So I uninstalled Flash on my laptop completely, and then downloaded it again with Firefox (the full version wouldn't even download from Safari), but even after re-downloading it, I'm still getting the "missing plugin" notice (even with Firefox), and the update still won't download from Safari.
Not only that, at the same time I'm now often getting these popups that say "Safari is no longer responding because of a script on the webpage "[insert webpage name and link]". Do you want to stop running the script, or let it continue?" The button choices are "Stop", which makes the message just reappear if clicked, and "Continue", which makes it go away.

 

So basically, how can I fix these problems (and are they related)? I've searched the internet forever and cannot find a solution. Hopefully someone here can help. BTW I do have plugins enabled in Safari, so that's not the issue.

  • Klaus1 Level 8 Level 8 (46,025 points)

    On what Mac is this, running what version of OS X?

  • meyers2112 Level 1 Level 1 (0 points)

    It's a 2008 regular MacBook (sorry I can't get more specific than that, but it is the black colored one, which I believe they only made for awhile), and I'm running OS X Version 10.5.8. If it helps any further, I'm running Safari 5.0.6 (I don't believe this is the current version, but when I go to update it, it says it's up to date).

  • Klaus1 Level 8 Level 8 (46,025 points)

    Yes, Safari 5.0.6 is the latest version for Leopard 10.5.8.

     

    The version of Flash Player you can run with that may not be sufficient to play some flash video files on YouTube etc, but try installing it again:

     

    You can check here:  http://www.adobe.com/products/flash/about/  to see which version you should install for your Mac and OS.  The latest version,10.3.183.23 or later, is for Intel Macs only running Tiger or Leopard. Version 11.4.402.265 or above is for Snow Leopard onwards.

     

    You should first uninstall any previous version of Flash Player, using the uninstaller from here (make sure you use the correct one!):

     

    http://kb2.adobe.com/cps/909/cpsid_90906.html

     

    and also that you follow the instructions closely, such as closing ALL applications first before installing. You must also carry out a permission repair after installing anything from Adobe.

  • meyers2112 Level 1 Level 1 (0 points)

    Okay so I uninstalled Flash, and now I keep going back to install it (but this time for my version of OS X). And just as what has been happening, when I go to download it, absolutely nothing happens. I click on the "Download Now" button, and it takes me to the page that says "Thank you. Your download will start immediately and may take a few minutes to complete (etc., etc,)", however nothing downloads. I open the "Downloads" window and there's nothing in it. So it's as if Safari is blocking Flash from even downloading.

  • Carolyn Samit Level 10 Level 10 (95,985 points)

    Reinstall Safari >  Safari 5.0.6 for Leopard

     

    Then restart your Mac.

     

    Then make sure the Flash Player plugin is installed.   HD > Library > Intenet Plug-Ins

     

    If it's not, install Flash from here >  Adobe - Install Adobe Flash Player

     

    Quit and relaunch Safari to test.

  • meyers2112 Level 1 Level 1 (0 points)

    Okay I reinstalled Safari, restarted, checked to see if the Flash plugin is installed (which it isn't), then went to install the Flash player from Adobe's website, and just has been happening, it won't download at all. I click the "Download Now" button, it goes to the next page, but absolutely nothing happens. I open up the "Downloads" window, and it shows nothing is downloading. So you could sort of say my problem is Flash simply won't download when I try to download it from Safari.

  • Carolyn Samit Level 10 Level 10 (95,985 points)

    Open the Finder. From the Finder menu bar click Go > Go to Folder

     

    Type of copy paste the following:

     

    ~/Library/Safari

     

    Click Go then move the Downloads.plist file to the Trash.

     

    Now empty the Safari cache. Press Command + Option + E on your keyboard.

     

    Quit and relaunch Safari. Try re downloading Flash.

  • meyers2112 Level 1 Level 1 (0 points)

    Okay I did all that, but when I tried to download Flash from Safari, it wouldn't download.

     

    I should mention that I tried downloading Flash from Firefox, and it downloaded perfectly, however Safari and Firefox are still indicating there's a missing Flash plug-in, even though it is in the Internet Plug-ins folder in the Library.

  • meyers2112 Level 1 Level 1 (0 points)

    UPDATE: So I was finally able to download Flash from Safari. However, since then, I've uninstalled/reinstanlled it several times now, yet I'm still getting a missing plugin message. While some YouTube videos actually do work, the others don't, and homestarrunner.com, which is pure Flash, doesn't work at all. This is also despite the fact the Flash plugin is in the "Internet Plug-Ins" in the Library (there's a "Flash Player.plugin" file along with a "flashplayer.xpt" file).
    So it now simply seems like Safari (and Firefox) aren't recognizing the Flash plugin. Any more help would on how to fix this would be appreciated.

  • dominic23 Level 7 Level 7 (32,195 points)

      Macintosh HD > Library > Internet Plug-ins

       Different versions of Flash Player? 

     

       _Flash Player.Plugin    with old date

     

         Flash Player.Plugin    with new  date

     

      Delete _Flash Player Plugin

     

    If there are

     

          Flash Player.plugin

          flashplayer.xpt

     

      Delete flashplayer.xpt with older date

     

      Keep  FlashPlayer.plugin

     

               Flashplayer.xpt

     

     

    Uninsall and reinstall Flash

  • meyers2112 Level 1 Level 1 (0 points)

    All I have in the Internet Plug-ins folder is Flash Player.plugin and flashplayer.xpt, and there are no duplicates, so as far as I know I only have one version of Flash player (and it's 10.3 because I have Safari version 5.0.6, so it's not the newest version of Flash. I tried downloading the newest version just to see what would happen, but it would quit unexpectedly every time I tried to open it).

  • Klaus1 Level 8 Level 8 (46,025 points)

    (If you are running a PPC Mac with Flash Player 10.1.102.64 and are having problems with watching videos on FaceBook or other sites, try the following solution which fools the site into thinking that you are running the version 11.5.502.55:)

     

    Download this http://scriptogr.am/nordkril/post/adobe-flash-11.5-for-powerpc to your desktop, unzip it, and replace the current Flash Player plug-in which is in your main/Library/Internet Plug-Ins folder, (not the user Library). Save the old one just in case this one doesn't work.


  • meyers2112 Level 1 Level 1 (0 points)

    Sorry for the late reply, but YES THIS WORKED! THANKS!

     

    However, now I'm having this problem in which Safari will unexpectedly quit and there will be no error message after it does so. It mostly does it when I have 2 different YouTube videos opened up in 2 different taps, and Safari usually crashes when I start to play the second video I loaded. But now, it's beginning to happen at random (usually after I've been using Safari for awhile). What could be causing this? It just started happening ever since I downloaded that file Klaus1 sent me. Could that possibly have anything to do with it?

  • Klaus1 Level 8 Level 8 (46,025 points)

    Having two YouTube videos playing at once can be a problem, due to the size of the cache required, the amount of RAM required, and the bandwidth required for Safari to handle all that. Stick to one at a time, and clear your cache between eash one!

Previous 1 2 Next