8 Replies Latest reply: Jun 18, 2013 5:41 PM by nelsonPTY
nelsonPTY Level 1 (0 points)

I've had this MBP for almost 2 years now and until today it was working perfectly, but for some reason today the fan won't stop running and the Activity Monitor shows that the system is using 80% of CPU capacity. All of which translate in a slow system and power drainage.

I googled it and tried a few of the suggestions I found (like erasing printer queue and the Shift+Control+Alt+Power key combination), but nothing has solved the problem.

Any help will be greatly appreciated.


MacBook Pro, Mac OS X (10.7.5)
  • clintonfrombirmingham Level 7 (30,000 points)

    Is there any particular process using 80% of the CPU?



  • OGELTHORPE Level 8 (45,142 points)

    Try a SMC reset:




    In there is no relief, set Activity Monitor top show 'All Processes' and '%CPU' to show values in a descending order.  Down load iStat pro and when it gets hot, post images of both like this:


    Screen Shot 2013-05-11 at 11.03.58 AM.png




    Screen Shot 2013-02-21 at 3.08.47 PM.png


  • nelsonPTY Level 1 (0 points)

    There doesn't seem to be any proccess using that much CPU capacity. Right after the system finish loading and I'm at login screen the fan goes ballistic.

  • nelsonPTY Level 1 (0 points)

    I checked the link you posted and my MBP seems to have all of the symptoms so I'll try a SMC reset later today.

    This is what the istat and Activity Monitor looks like:

    Screen Shot 2013-06-15 at 9.21.10 AM.png

    Screen Shot 2013-06-15 at 9.22.18 AM.png

    This is driving me crazy so any help will be very appreciated


  • OGELTHORPE Level 8 (45,142 points)

    You have set Activity Monitor to 'My Processes', set to show 'ALL PROCESSES'. Then maybe we can identify the cause if your problem.  There is evidence that an application may be in a 'runaway' status (if the SMC does not solve the problem).



  • Linc Davis Level 10 (192,549 points)

    The kernel is using excessive processor cycles. Below is a partial list of causes for this condition.


    When it gets high temperature readings from the hardware, or a low-voltage reading from the battery, the kernel may try to compensate by interrupting the processor(s) to slow them down and reduce power consumption. This condition can be due to


    • a buildup of dust on the logic board
    • high ambient temperature
    • a worn-out or faulty battery in a portable
    • the malfunction of a cooling fan or sensor


    Note that if the problem is caused by a sensor, there may be no actual overheating or undervoltage.

    If the computer is portable, test with and without the AC adapter connected. If kernel_task hogs the processor only on battery power, the fault is in the battery or the logic board.

    The Apple Hardware Test or Apple Diagnostics, though not very reliable, is sometimes able to detect a bad fan or sensor.

    Installed software

    User-installed software that includes a device driver or other kernel code may thrash the kernel. Some system-monitoring applications, such as "iStat," can also contribute to the problem. You can test for this possibility by completely disabling or removing the software according to the developer's instructions, or booting in safe mode. Note, however, that disabling a system modification without removing it or booting in safe mode may not be as easy as you think it is.

    Corrupt NVRAM or SMC data

    Sometimes the problem is cleared up by resetting the NVRAM or the SMC.


    Connecting an external display to some MacBook Pro models via Thunderbolt may cause this issue. I don't know of a fix, other than to disconnect the display.


    Transferring large amounts of data to or from an encrypted disk image or FileVault volume may put an extra load on the kernel. If both the source and the destination are encrypted, the load may be doubled. If you transfer data from an encrypted disk image on an encrypted partition to another such image on another encrypted partition, the load may be quadrupled.

    This issue probably doesn't affect late-model Macs with an Intel i-series, recent Xeon, or later processor. Those processors support hardware-accelerated encryption. You can determine what kind of processor you have by selecting About This Mac from the Apple menu in the menu bar.

  • nelsonPTY Level 1 (0 points)

    SMC didn't fix the problem.

    I switch the setting in the Activity Monitor to "all proccesses" and apparently it's the kernel that's running wild. Here's what I got from Activity Monitor:


    Screen Shot 2013-06-15 at 10.15.44 PM.png

    Any suggestion will be appreciated.



  • nelsonPTY Level 1 (0 points)

    Update: Was finally able to solve my problem. Restarted the MBP in Safe Mode and used disk utility to repaired permissions. That seemed to do it for me. Computer is working great (knock on wood) at least for now (stop, don't jinx it)


    Thanks for the help and all the great advices.