9 Replies Latest reply: Nov 19, 2013 1:17 PM by T-Clarke
Jim Bridger Level 1 Level 1 (5 points)

I recently decided to Merge my 550+GB library in to a completely new, empty Library. I was having some issues with the old Library regarding speed, hicups etc. I did a complete series of First Aid fixes which included the Repair Permission, Repair Database and Rebuild Database before I began the Merge. What I'm concerend about is this Merge has now been running for over 5 days and early on it made fast progress. However, the last three days the progress bar seems to be stuck in the same position. I have checked the Activity Monitor and it does seem to be transfering informatoion. But I'm wondering if anyone has Merged a Library of this size and how long it may take? I should mention that my 350,000+ images are almost all Refrenced, with a small 1000-2000 photos being managed. I've a ttached a screen shot that shows the Activity Monitor and what the screen looks like. Hope there is some sage advise out there. Screen Shot 2013-06-17 at 1.41.48 AM.png

Mac OS X (10.6.7)
  • gdippe Level 1 Level 1 (0 points)

    Wow! I haven't merged anything close to what you mention but you're probably better off checking the Activity Monitor than the progress bar. When I do merges the progress bar seems to hang halfway or so and then suddenly the task has finished.


    I wouldn't start worrying unless Aperture shows no activity in the Activity Monitor. As long as the process is alive and kicking everything should be fine.

  • Jim Bridger Level 1 Level 1 (5 points)

    Update on Merging my Aperture Library with a fresh new Library.


    After seven days of the Merge going nowhere, I contacted Aperture support and they asked if I had turned off Faces in the new Library I was merging to. I had not, so I stopped the Merge process, trashed the now incomplete newly merged Library, then started over with a new Library with Faces turned off. I was excited thinking Faces must have been the issue. Unfortunately that doesn't seem to be the case. My new Merge has now been running for 10 FULL DAYS! Still no movement on the progress bar for the past seven days. The Activity Monitor shows that data is still being written but if it is it's at a snails pace. Have no idea what the next step is. Wished Apple would see this post and drop me a note as they did on other issues pertaining to strange Aperture behavior over the past year.

  • gdippe Level 1 Level 1 (0 points)

    Does the size of the new file increase if you do command+i a minute apart?

    If you know a few simple commands like ls -la and cd you could do this in the terminal but that shouldn't be necessary.

  • JUN48 Level 1 Level 1 (100 points)

    It was good though if aperture library is on SSD.

    At huge library, SSD effects 'full throttled' at DB access.

  • Jim Bridger Level 1 Level 1 (5 points)

    No idea what you are even talking about. Thanks though.

  • léonie Level 9 Level 9 (79,540 points)


    I think gdippe is referring to using the command "File  > Get Info ⌘I" on your merged Aperture library.


    If you check the file size in the "Get Info" panel, you will see, if the file size is indeed increasing and Aperture is still making progress.


    Looking at the Activity Monitor, Aperture seems to be doing quite a lot of computing, judging by 104% CPU use.



  • T-Clarke Level 1 Level 1 (0 points)

    Any update on how things worked out?


    I've run into a similar situation in which I had my Aperture Library on my mac mini hard drive. I created a new Library (I couldn't figure out how move the library itself so I created a new one) a few weeks ago on an external HD when I filled up the mini's, then just bought a new iMac this week. I am attempting to merge the two into the external's library by importing the original library into the new one. This is where it gets hung. About 3/4 of the way down the progress bar and then nada, it just spin. I force quit after a few hours and when I reopened the folders are merged but no images yet. I tried the process a few times and get hung at same point.


    After several force quits I'm repairing the database. We'll see if this helps. If not, any suggestions?

  • gdippe Level 1 Level 1 (0 points)

    Try to avoid force quitsMacOS as well as other flavors of Unix can in some cases need several days to finish a process!


    I try to keep my files referenced as much as possible which means that my library file is relatively small. Create Aperture vaults (http://support.apple.com/kb/PH7627) and backup your referenced files.

    In case something goes wrong your pretty much safeguarded.


    In your case you might consider rebuilding the database instead of repairing it.

    http://documentation.apple.com/en/aperture/usermanual/index.html#chapter=27%26se ction=10


    Good luck!

  • T-Clarke Level 1 Level 1 (0 points)

    Thanks, I'll read through them to see about making sure images are refrenced as much as possible. I really had thought I'd set it up that way but was surprised when I started getting alerts that my disk was filling up. I tried a few simple drag and drops to move the library to an external but when it didn't work I just created a new library and figured I'd merge them (now) after buying the new system.


    For what it's worth the repair database seemed to do the trick. Last I wrote the folders were there, but empty. After running the repair both libraries seem to be merged to one...