4 Replies Latest reply: Mar 30, 2014 8:25 AM by Lapellegrina40
randyrider Level 1 Level 1 (0 points)

Apple TV stuck on setting date and time

  • Cragnium Level 1 Level 1 (0 points)

    I read in another discussion that you can turn off your routers firewall temporarily and it will work. I did that. I turned off my apple tv (3rd gen) and then I turned off my routers firewall. Then I turned my apple tv back on and made sure the time setting was set to automatic. Then it let me set my iTunes login and everything was fine. I turned my firewall back on and it all works now. Try that. I'm not saying it will work for everyone, but it worked in my case.

  • BillyBob_Lee Level 1 Level 1 (0 points)

    Your suggestion worked for me. I have a 2nd Gen Apple TV and I was able to get past the time/date issue by temporarily disabling my router's firewall. Thank you very much!

  • Edulujarapple Level 1 Level 1 (0 points)

    Thanks for your support. I found myself in front the same problem. After close to 1 hour trying everything I decided to look for help in the Apple Support Community as official support says nothing about it. I have turned off my router`s firewall, restarted the Apple TV 2nd Gen and everything works properly now. At last, I switched on back the routers firewall. Thanks for your 5 stars support.

  • Lapellegrina40 Level 1 Level 1 (0 points)

    I am a bit ignorant on all this tech stuff but I don't think I'm using a router, just a modem.  I've read through several of these responses and I still can't get my date and time to set and I'm getting thoroughly peeved at having to re-enter everything over and over just to get back to the same non-working issue I still have.  Any other suggestions?