Skip navigation

One more "Where did my space go"

1413 Views 34 Replies Latest reply: Jul 1, 2013 8:34 PM by wiz329 RSS
  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Jun 19, 2013 10:18 AM (in response to Linc Davis)

    As a friend of mine used to say, "That's un-good." 

     

    @ fditt:  It might be worth the $13 to try WhatSize (direct from the maker, not the AppStore), per the green box in Where did my Disk Space go?

  • Pondini Level 8 Level 8 (38,710 points)
    Currently Being Moderated
    Jun 19, 2013 2:05 PM (in response to fditt)

    fditt wrote:

     

    Thanks Guys.

     

    About Omni. I did not say that I ran Omni as root. I was logged in as admin on Mountain Lion.

    Ah, that's not enough.  The Admin user still can't see and doesn't have permission to everything.  Usually the other stuff isn't real large, but it can be.

     

     

    Just ran Omni as root (sudo open /Applications/OmniDiskSweeper.app and password) and the result was the same.

    Curious.  I experimented with it a bit, but don't use it.  And Linc said he tried that and it didn't show the correct sizes.  I have no idea why.

     

    Any chance of Volumes folder contains 40GB?

    Yup.  That's where we sometimes find large folders instead of aliases to drives, apparently because OSX lost track of a drive at the wrong time, created a folder, and wrote to it instead. Also if you do a TM restore wrong and tell TM to "recreate enclosing folders" when it really can't, it will put it in Volumes instead.

     

    This was the only folder/directory I couldn't run du -sh probably because it has alias for Macintosh HD or it has Mobilebackups.

    Omdi does show .MobileBackups separately, but without a size.  It's the same 14 GB of Backups in the Storage display (note that the Finder sometimes shows .MobileBackups as the same size as the OSX volume!).

    Those Local Snapshots are not counted as used by the Finder or Get Info, but are counted by Disk Utility.

     

    I would perfectly understand a difference of around 7-10% in these measures (base 2 or base 10, compression and so on), but 40GB from 150GB disk seems too much for me. Definitely I'm missing something, and I would like to know what so I can get at least part of this 40GB back to my SO disk.

    If you can't figure it out any other way, spring for the $13 to get WhatSize from the maker.  Take a look at the sample and explanation in the green box in Where did my Disk Space go?  In "As Admin" mode (really "as root") it does show the size of everything.  It has a number of other features as well, that you may or may not find useful.

  • wiz329 Calculating status...
    Currently Being Moderated
    Jul 1, 2013 11:22 AM (in response to fditt)

    Running sudo open -a AppName.app won't give root priveleges to the application. The best way to do this is to use the application LaunchAsRoot. (https://www.macupdate.com/app/mac/38617/launchasroot)

     

    I've never used OmniDiskSweeper -- I use DiskWave, but they look pretty much the same. Opening the process with sudo here:

     

    Screen Shot 2013-07-01 at 1.09.55 PM.png

     

    However, when you use LaunchAsRoot to launch Diskwave:

     

    Screen Shot 2013-07-01 at 1.16.41 PM.png

     

    As you can see in Activity Monitor, root has taken control of the process, allowing it more access to measure filesize. Today the difference isn't so large, but last night, there was about 20GB in .MobileBackups that wouldn't show up before. They seem to have cleaned themselves up today.

     

    The other thing you could do is log in as the root user (not just using sudo, but actually logging in), telling the system to show hidden files, then taking a look in finder at everything. I'm guessing that since finder would then be owned by root, it would show everything on the system.

  • wiz329 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 1, 2013 8:34 PM (in response to wiz329)

    Update: You can also run the app as root from the terminal, using a slightly modified code:

    In this case you would use:

     

    sudo -b /Applications/DiskWave.app/Contents/MacOS/DiskWave

    exit

     

    You just have to navigate within the app package itself. I've just created a script, saved it, and retitled it as DiskWaveRoot.command, changed the icon, and placed it in the applications folder.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.