1 Reply Latest reply: Jun 17, 2013 6:42 PM by Linc Davis
Deangelis Level 1 Level 1 (45 points)

All of the sudden, my iMessages say they are sent from my email address. Previously, it used my cell phone seamlessly and that was the way I like it. 

 

I've tried logging off and back on.  I've rebooted the MacBook Pro etc. 

 

All it shows are two of my email addresses on my AppleID account.

 

Any suggestions Smart People!?

 

Drue


imac g4, Mac OS X (10.3.9)
  • 1. Re: iMessage on Macbook pro doesn't sync with iphone
    Linc Davis Level 10 Level 10 (118,285 points)

    Associate your mobile number with your Apple ID, if you haven't already done so.

    Sign out of iMessage on the Mac:

    Messages Preferences ▹ Accounts ▹ Sign out

    Sign out on the iPhone

    Settings Messages Send & Receive Apple ID ▹ Sign out

    Then, on the phone, tap

    Use Your Apple ID for iMessage

    Sign back into iMessage on both devices and test. If there's no change, you may have to wait for a change in network conditions.

    Credit for this solution to ASC user SmittyLove and to Glenn Fleishman of tidbits.com.