1 Reply Latest reply: Jun 21, 2013 6:56 AM by jeremy_v
stevecirrus Level 1 Level 1 (0 points)

This has been happening for several months.

a restart of my Mac Pro temporarily fixies it for a few days but then it happens again

 

However I should also add that I am never able to shut down or restart the Mac Pro normally

It always gets stuck on the grey screen during shut down. It will stay there forever. I have left it overnight before and it is still sitti g there at the grey screen winner little spinning icon. The only way to shut down is to hold the power button down.

 

I have read many threads on the iphoto locked library issue and I have tried all of the suggestions except for the download iphoto library manager.

I don't want to do that unless I have to, and because of the issue with spotlight, I think that it won't be a permanent fix

I don't know if the spotlight search issue is causing the iphoto lock or visa versa, or if there is another thing causeing both,

but after experiencing this problem many times I know that both issues happen at the same time and must be linked in some way. Not sure if the shutdown problem is related but I suppose it could be.

 

restarting the mac pro (intel Xeon Dual Core os 10.7.5) solves the problem temporarily. both iphoto and spotligh search work fine after that until the next time.

I don't know what triggers it. and it's really frustrating because I don't understand how the os works and I really need to be able to use the search function for work. I need to be able to search my emails and files and it just doesn't give results except for older files and emails when this happens. the more recent files and emails are either not indexed or not coming up for some reason

 

my iphoto library is on a seperate drive from my operating system and it is formatted extended journaled and set to ignore permissions

 

I have tried deleting the iphtotlockdata file but when I do that and try to start iphoto I get a weird message saying

"the library "iphoto library" is open in iphoto. to open this library in iphoto you must quit iphoto."

 

I've rebuilt the iphoto library before (after restarting) but eventually the problem happens again.

 

I have also tried turning off the Mac Pro and unplugging the power cord. I can't remember what that is supposed to do but it didn't work anyway.

 

not sure what else to try

 

thanks in advance for your help

Mac Pro


Mac Pro