9 Replies Latest reply: Oct 3, 2015 6:47 AM by ra170
Martin Cloake Level 1 Level 1

Hi all,

 

I've just upgraded to an iPhone5, latest iOS (6.1.4) and restored my old iPhone 4 set-up via iCloud back-up. Everything's fine so far, except for my Twitter account. It works fine, until I try to share a page I've opened in Safari via Safari Twitter share button. I just get a message telling me 'Cannot send tweet [link details] because the connection to Twitter failed'.

 

I can RT and send Tweets, I'm signed in to Twitter via the iPhone app and via Safari. If I check my Safari settings, there doesn't appear to be anything I can set or change to sort things out. In my Twitter settings, I notice there are only two apps listed under 'Allow these apps to use your account' (and one of them, bizarrely, is Twitter!). There doesn't seem to be any way to add an app to the list that Twitter can use. What's annoying is that on my iPhone 4 there were a whole bunch of apps that I could use with Twitter.

 

Restoring from my old phone back-up should have simply transferred everything over as it was. That's what's happened with everything else I've checked. I'm guessing, only guessing, that my problem might have something to do with how Twitter is integrated into Safari in iOS 6 in a way it wasn't before.

 

The only other thing that could affect this is the fact that, because I was on an iPhone 4, I didn't upgrade to iOS 6, sticking with the final iOS 5 instead. Even so, I had no warnings or prompts telling me this might be a problem when I upgraded.

 

Sorry for involved explanation, but if anyone can help, I'd be grateful.

  • MrsMadgin Level 1 Level 1

    Hi Martin,

    I had exactly the same issue. Seems to have been resolved by not using Emoji in the tweet when sharing. Can still use emoji in an original tweet just not when sharing from safari or other apps.

    Hope that helps?

  • Martin Cloake Level 1 Level 1

    Thanks. It turns out the solution is simpler, but extremely annoying. Despite being signed into Twitter on my twitter up and being able to use Twitter in every way possible except for sharing, it turns out that I had to be signed on on my phone via my web browser version of Twitter for it to recognise that I was connected to Twitter. It makes no sense, and also means that the transefr between iPhone 4G and iPhone 5 is not quite as thorough as it wants us to believe, because everything was OK on my previous phone. Although I must confess I don't remember logging in via my browser on that - it was some years ago though.

     

    So, resolved, and perhaps a minor irritation - but one of those times when you wonder if things could be a little more intuitive.

  • Max Lukas Level 1 Level 1

    Have the same problem. Do you mean that you no longer use the twitter-app - but only the safariversion?

  • Martin Cloake Level 1 Level 1

    I use the Twitter app on the iPhone, but it appears i had to signed in via Twitter on my web browser for sharing to work, even though this wasn't the case on my iPhone 4. I suggest you log in via both the Twitter app and Twitter via Safari, and you should get full functionality.

  • NicolaZ Level 1 Level 1

    I fixed it

    By going in Settings

    Deleting my twitter account

    And re-adding it

  • Barnabee Level 1 Level 1

    I've got an iPhone 5s running iOS 7.0.2 and it simply won't share anything to Twitter (photos, web pages and the like). It used to quite happily on my iPhone 4s. I've tried deleting the app and reinstalling, but that doesn't work. I've tried signing in via Safari, but that doesn't work. Any more suggestions?

  • Warner Crocker Level 1 Level 1

    I'm now seeing the no sharing issue on both an iPhone 5s and the new iPad Air. Older iPads will share info (links, photos, etc.. just fine. But the two new flagship devices will not do so as of yet.

  • Joshua Lawton Level 1 Level 1

    I had the same problem but simply went into settings and signed into Twitter from the settings. I did not have to delete the account and add it again.

  • ra170 Level 1 Level 1

    I didn't have to delete it, just re-entered my password again.