Looks like no one’s replied in a while. To start the conversation again, simply ask a new question.

Question:

Question: AirPlay error (-15000)

I have an AirPort Extreme that is connected via Ethernet and Wi-Fi to my iMac. Am am trying to AirPlay my stereo connected to the headphone jack on my AirPort Express that is extending the 5GHz network on the Extreme. I have been doing this without any major problems for the past few weeks (apart from hiccups and pauses), up until today. Everytime I try to AirPlay the AirPort Express, iTunes returns the following message while attempting to connect. "An error occurred while connecting to the AirPlay device “AirPort Express”. An unknown error occurred (-15000)."
I can confirm that the AirPort Express is well within range and is functioning correctly extending the 5GHz network. I have checked to see if my radio channels are conflicting with any nearby networks, and it is not. Any help?


Thanks,



Drew






Running:
AirPort Extreme Version: 7.6.3 (802.11n 5th Generation) - 5GHz Channel on 36, 2.4 GHz Channel on 10
AirPort Express Version: 7.6.2 (802.11n 2nd Generation) - 5GHz Channel on 36, 2.4 GHz Channel on 11
iMac running Mountain Lion 10.8.4
iTunes Version: 11.0.4
Motorola Surboard SB6121, DOCSIS 3.0 Modem with Comcast Blast! Internet Service (roughly 66mbps download, 11mbps upload)

iMac, OS X Mountain Lion (10.8.4)

Posted on

Reply
Question marked as Solved
Answer:
Answer:

I have found a solution for my problem. For this to work, you will have to note that you are disabling IPv6 on your system.

  1. Use Finder to open the Applications folder
  2. Select the "Utilities" folder
  3. Select "Terminal"
  4. A screen will open. At the prompt, enter the following command to determine all of your Mac's network interfaces: networksetup -listallnetworkservices
  5. To disable IPv6 for wireless, enter the following command: networksetup -setv6off Wi-Fi
  6. To disable IPv6 for Ethernet, enter the following command: networksetup -setv6off Ethernet
  7. To exit the terminal window, open the "Terminal" menu next to the Apple menu at the top left of the screen and select "Quit Terminal"

Posted on

Page content loaded

Jun 22, 2013 7:41 AM in response to elementdude92 In response to elementdude92

Hey elementdude92


If you are having issues with AirPlay, I found an article that talks about that specific error that will be of help to resolve the issue.


Error -3256 or -15000 when streaming to AirPort Express base stations using iTunes

http://support.apple.com/kb/ts2278


Thanks for using Apple Support Communities.


Regards,

-Norm G.

Jun 22, 2013 7:41 AM

Reply Helpful

Jun 29, 2013 7:31 PM in response to tigwy In response to tigwy

That did not help me either. This started happening after I updated to AirPort Utility 6.3. I have called Apple and I spoke with a Senior Advisor about the issue. They were unable to help solve the issue. I have been stuck without the ability to use AirPlay on from my Mac to my AirPort Express ever since the update. Not a happy customer... Especially since that is the only reason I have the Express.

Jun 29, 2013 7:31 PM

Reply Helpful

Aug 24, 2013 11:42 AM in response to elementdude92 In response to elementdude92

elementdude92


I have a similar setup the an intermittent occurance of the "An error occurred while connecting to the AirPlay device “AirPort Express”. An unknown error occurred (-15000).". I have not yet determined the cause, but I do have a fix that has worked for me each time the error occures.


This solution is provided without warranty and you use it at your own risk! It does require some basic Unix/Linux commandline skills.


Do the following on the system hosting/running iTunes:


Open a terminal and at the prompt type: ifconfig (you may have to type sudo ifconfig)


You should see output similar to this:


system:~$ ifconfig

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384

options=3<RXCSUM,TXCSUM>

inet6 [removed be me for security]lo0 prefixlen 64 scopeid 0x1

inet 127.0.0.1 netmask 0xff000000

inet6 ::1 prefixlen 128

gif0: flags=8010<POINTOPOINT,MULTICAST> mtu 1280

stf0: flags=0<> mtu 1280

en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500

options=2b<RXCSUM,TXCSUM,VLAN_HWTAGGING,TSO4>

ether [removed be me for security]

inet6 [removed be me for security]en0 prefixlen 64 scopeid 0x4

inet [removed be me for security] netmask 0xffffff00 broadcast [removed be me for security]

media: autoselect (1000baseT <full-duplex,flow-control>)

status: active

en1: flags=8823<UP,BROADCAST,SMART,SIMPLEX,MULTICAST> mtu 1500

ether [removed be me for security]

media: autoselect (<unknown type>)

status: inactive

fw0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 4078

lladdr [removed be me for security]

media: autoselect <full-duplex>

status: inactive

p2p0: flags=8802<BROADCAST,SIMPLEX,MULTICAST> mtu 2304

ether [removed be me for security]

media: autoselect

status: inactive

utun0: flags=8051<UP,POINTOPOINT,RUNNING,MULTICAST> mtu 1380

inet6 [removed be me for security]utun0 prefixlen 64 scopeid 0x8

inet6 [removed be me for security] prefixlen 64


Your first active network interface should be en0. If you have more than one network interface configured you might also have an en1, etc. Basically anything that has an IP address is an active interface.


In my case I have one active interface en0. I fixed the problem by running the following command "sudo ifconfig en0 down" - this will shut down the interface and effectively KILL ALL active and stale connection associated with it.


next I did a "sudo ifconfig en0 up" - turns the interface back on - if your using DHCP you will aquire an IP address or you pick up the a statis IP address if that is how you've configured your network preferences.


You can run the commands on each configured network interface to "reset" it; this procedure should work. I'd love to hear about your (or anybody elses) experience using this solution.


--Jonathan


PS: the links to Apple Support Articles, although still active, are no longer updated by Apple. I have found that these particular articles were not helpful.

Aug 24, 2013 11:42 AM

Reply Helpful

Sep 1, 2013 8:52 AM in response to elementdude92 In response to elementdude92

I have this problem as well. Every time iTunes opens up, I get the message An error occurred while connecting to the AirPlay device “AirPort Express”. An unknown error occurred (-15000)."


I have to clear the message or restart iTunes in order to use AirPlay. It's really inconvenient.


The suggestions given have not worked.

Sep 1, 2013 8:52 AM

Reply Helpful

Sep 1, 2013 9:08 AM in response to a1000faces In response to a1000faces

a1000faces:


Thank you for mentioning the iTunes restart: "I have to clear the message or restart iTunes in order to use AirPlay. It's really inconvenient."


Clearing the message did nothing for me either, but I found that starting and stopping the network interface(s) in conjunction with an iTunes restart did do the trick. On review of my previous solution and in light of your experience the process should have read:


Stop/close iTunes

Stop network

Rerstart network

Restart iTunes

*An additional step that may be needed is to deselect your airplay device and select the computer, then re-select the air play device.


Time consuming and cumbersome in the extreme (to your point!).

Sep 1, 2013 9:08 AM

Reply Helpful
Question marked as Solved

Sep 1, 2013 2:42 PM in response to elementdude92 In response to elementdude92

I have found a solution for my problem. For this to work, you will have to note that you are disabling IPv6 on your system.

  1. Use Finder to open the Applications folder
  2. Select the "Utilities" folder
  3. Select "Terminal"
  4. A screen will open. At the prompt, enter the following command to determine all of your Mac's network interfaces: networksetup -listallnetworkservices
  5. To disable IPv6 for wireless, enter the following command: networksetup -setv6off Wi-Fi
  6. To disable IPv6 for Ethernet, enter the following command: networksetup -setv6off Ethernet
  7. To exit the terminal window, open the "Terminal" menu next to the Apple menu at the top left of the screen and select "Quit Terminal"

Sep 1, 2013 2:42 PM

Reply Helpful

Nov 29, 2013 9:29 PM in response to elementdude92 In response to elementdude92

If turning off ipv6 was all it took to fix the problem, maybe the previous settings of the AirPort Express ensured that it never encountered an IPv6 address. If that was the case, the following solution that keeps ipv6 available might have worked:

  1. hard reset the AirPort Express (unplug power cord, paper clip in the tiny hole while reconnectung to power).
  2. remove the AirPort Express from the network (use AirPort Utility.
  3. add the AirPort Express back to the network with AirPlay enabled (use AirPort Utility).

Nov 29, 2013 9:29 PM

Reply Helpful (1)
User profile for user: elementdude92

Question: AirPlay error (-15000)