2 Replies Latest reply: Jun 24, 2013 3:13 PM by Gary2802
Gary2802 Level 1 Level 1 (0 points)

I'm not able to import Romanian subtitles into DVD SP correctly.  I can see them correctly in a program on my computer called Jubler, but when I import them into DVD SP, non-English characters don't import correctly.  Any thoughts?

Thanks,

Gary


DVD Studio Pro, Mac OS X (10.6.8)
  • Nick Holmes Level 7 Level 7 (29,955 points)

    Are you using one of the "CE" typefaces which contain the special characters needed?

     

    http://www.aatseel.org/resources/fonts/macintosh_central.htm

  • Gary2802 Level 1 Level 1 (0 points)

    Hi Nick,

    I appreciate your reply, though it didn't help.  After working on it for several hours, I did figure it out however.  I'll include here what I figured out incase someone else runs across the same problem.

     

    I found out I can do it in both Jubler (which is a free program) and TextEdit.

     

    I Jubler, I needed to import the .stl file encoded as ISO-8859-2, and save it out in UTF-16.

     

    In TextEdit, I had to open it as Central European (ISO Latin 2), and save it out in UTF-16, manually changing the extension to .stl.  The way to get that option in TextEdit is to go to Preferences, then Open and Save. Under 'Plain Text File Encoding' where it says 'Opening files', click on that tab.  If it's not one of the options, then select 'Customize Encoding List...' at the bottom of the list, which will open up a ton of other opions.  Check Central European (ISO Latin 2), and select it in the tab beside 'Opening files'.  Next time you open up a file in TextEdit, that will be the default for the 'Plain Text Encoding'.  When you do 'Save As', you'll need to change it to Unicode (UTF-16) and change the extension to .stl.

     

    That took me about 5 hours to figure out.

     

    Hope this helps someone else out.