8 Replies Latest reply: Jun 29, 2013 2:30 PM by kostby
xyz2008 Level 1 (0 points)

I am having a lot of trouble trying to get a network  ricoh aficio mp 2851 printer to work. I have install the updated driver, added the printer through either or IPP or LPD. But either way, every time I send a simple one page test, the printer goes crazy and prints page after page, some just white pages, others with weird symbols on them.


Please let me know if you have a solution or some clue in terms of what's going on.



iMac, Mac OS X (10.6.8)
  • kostby Level 4 (2,780 points)

    Welcome to Apple Support Communities. We're all users here.


    What you describe typically happens when the printer and the sending device are not speaking the same 'printer control language'. I encountered it years ago when I used the wrong driver for a Hewlett Packard laser printer. The computer was 'sending' Epson print language, instead of the expected HP PCL. Page after page of 'gibberish' was the result.


    Generic Troubleshooting:

    1. Be certain that you are indeed using the newly-installed printer driver when printing, and not some other installed printer. I've noticed for example that Pages '09 document templates I create always revert to the default printer when they were saved, completely ignoring the current default printer.


    2. Connect your computer via USB cable directly to the Ricoh printer.

    You will need to re-add the printer in , System Preferences, Hardware, Print & Fax.

    Customize the new printer name to include 'USB', so you can distinguish it from the 'network' printer setup.

    3. Do a test print via the USB interface.


    4. If nothing happens, it's possible that the Ricoh is configured for 'network only', and I can't help you with that.


    If the printer works 'normally' when connected via USB cable, then the problem definitely is with your network print setup.


    If the printer still prints 'gibberish', then the wrong printer driver is being used. For compatibility, many modern office laser printers 'speak' older versions of HPPCL (Hewlett Packard Printer Control Language) in addition to any 'native' features that Ricoh might have with it's own commands and control language.


    If there ARE any recognizable words or phrases in the 'gibberish' please reply with them. I used to write simple printer control macros, so I might be able to decipher what's going on.

  • xyz2008 Level 1 (0 points)

    Thank you very much for your reply.


    The printer is at workplace and on a different floor from my office, so I won't be able to use a USB connection.


    I am pretty sure I am using the specified printer. I have also tried to print different files.


    There are lots of readbale words on the pages, it would be too much to me to type them in. Is there a way to send an image? I can sacn a page and see if it might provide some clue.

    I included a few lines here,


    42/FontType resourcestatus{pop pop false} {true}ifelse


    ...... (I skipped a few lines here)


    /FontType 42 def

    /FontMatrix matric def

  • kostby Level 4 (2,780 points)

    The strings you've typed look like Postscript printer language. Definitely not HPPCL.


    From this Ricoh specifications page, it looks like Postscript is an Option, but the standard printer language is PCL 5e/6



    Screen shot 2013-06-26 at 3.02.00 PM.png

    So, if you're trying to send the print job in Postscript, try PCL instead.

    If you're not trying to send Postscript, you've apparently got the wrong printer driver installed.

  • xyz2008 Level 1 (0 points)

    Thanks for the reply.


    The company does not have PCL driver for Mac on their web site, only PPD.




    So I guess this means I just can not use this printer.


    We do have another one back in service, so I now do have access to a printer.

  • kostby Level 4 (2,780 points)

    Have you verified with your tech folks that the printer does NOT have the Postscript option installed?


    It seems very odd that Ricoh would not offer a PCL driver for any flavor of OS X.

    Apparently Ricoh thinks that Macs are still rooted in 1980's when they HAD to use Postscript over an Appletalk network to an Apple LaserWriter!


    But depending upon what you're trying to do (print, scan, fax) with the Ricoh, there IS an easy "alternate" solution so you CAN at least print to that Ricoh printer upstairs.


    Install a genuine HP PCL laser printer driver for an HP LaserJet printer with similar capabilities to the Ricoh.

    HP drivers are already included in OS X.


    I know for a fact that the HP LaserJet 1320 is a 2005-era black-and-white duplexing laser printer supporting up to 3 trays. It uses genuine HP PCL5.

    It does not have any scan or fax capabilities, though. I know because I own one and still use it regularly.


    If your tech support people are OK with it, I suggest trying it.

    The Ricoh will probably print just fine, although you might have to do a couple of simple tests to find out which HP tray definitions are assigned to which physical trays on the Ricoh.


    Message was edited by: kostby

  • xyz2008 Level 1 (0 points)

    Thanks! This sounds like a great idea.


    I notice there is a generic PCL Laser Printer driver that is probably from OS X (with duplex option) and used it to readd the Ricoh printer. However, this time, the printer does not respond to the jobs I sent at all. It is not my network problem becaue I can print through other printers. I checked the printer, all cables are connected. However, I don't know how to definitively check its connection.

  • xyz2008 Level 1 (0 points)

    It occurred to me that I added the printer with IPP protocol, but maybe I should use LPD. So I did and it is finally working now!


    Thanks a lot for the help!!

  • kostby Level 4 (2,780 points)

    Glad you got it working, and thanks for acknowledging my answers as 'helpful' and 'solved'.

    Thankfully, I could decode the 'weird symbols' you encountered and point you in the right direction!