Previous 1 2 Next 16 Replies Latest reply: Sep 16, 2014 5:30 AM by Leftonred
ChiefTolu Level 1 Level 1 (0 points)

For at least the past year, I haven't been able to sync my phone with iTunes.  It either freezes, or, recently, has been giving me an "Invalid response blah blah" error.  I made two threads to no response.  Does anyone know how to fix this?  Can Apple make software that isn't complete ****?

iPhone 4S, iOS 6.0.2
  • Lawrence Finch Level 7 Level 7 (30,620 points)

    Apple makes excellent software. The problem is your computer. Which is probably running Windows.


    This error usually means there is a USB timing problem in your computer. If you are using a USB hub, don't. If your computer is not a laptop and you are using a USB port on the front of the computer, switch to a port on the back of the computer. If you have other USB devices connected disconnect all except mouse and keyboard. Reboot your computer just before trying to connect. Disable your antivirus temporarily. Install the latest version of iTunes.


    Try a different computer.


    It can also mean that your phone is jailbroken, but if that's the case you can't get help in an Apple forum.

  • ChiefTolu Level 1 Level 1 (0 points)

    My apologies for just responding to this just now:


    I've read past articles about my problem, and it offered each of your suggestions to no avail.  The problem is, unfortunately, not my computer.  And my phone is not and never has been jailbroken.  While I am running Windows, I tried my phone on a Mac Book Pro running Lion and another running Snow Leopard, both which gave the invalid response. 


    Let me elaborate- up until recently, it wouldn't even give me the error.  It would simply freeze.  If I was playing music, it would continue to play the music as if nothing was wrong but otherwise the iTunes window was not responsive. 


    Anyone else having this issue?

  • ChrisJ4203 Level 8 Level 8 (37,935 points)

    From this support document


    iTunes cannot connect to the iPhone because an invalid response received from the device

    This error occurs when there are problems communicating through USB. This may be resolved by following the steps for errors 13 or 14 above.


    Error 13, 14, 35 and 50 (or -50)

    These errors are typically resolved by performing one or more of the steps listed below: 

    1. Perform USB isolation troubleshooting, including trying a different USB port directly on the computer. See the advanced steps below for USB troubleshooting.
    2. Put a USB 2.0 hub between the device and the computer.
    3. Try a different USB 30-pin dock-connector cable.
    4. Eliminate third-party security software conflicts.
    5. There may be third-party software installed that modifies your default packet size in Windows by inserting one or more TcpWindowSize entries into your registry. Your default packet size being set incorrectly can cause this error. Contact the manufacturer of the software that installed the packet-size modification for assistance. Or, follow this article by Microsoft: How to reset Internet Protocol (TCP/IP) to reset the packet size back to the default for Windows.
    6. Connect your computer directly to your Internet source, bypassing any routers, hubs, or switches. You may need to restart your computer and modem to get online.
    7. Try to restore from another known-good computer and network.
  • ChiefTolu Level 1 Level 1 (0 points)

    The issue is not my computer or USB cord, I've swapped both various times having tried on several other computers to no avail.  Either it's my phone, or iTunes itself.

  • Lawrence Finch Level 7 Level 7 (30,620 points)

    If your phone is not jailbroken restore it using iTunes.

  • MRaza91 Level 1 Level 1 (0 points)

    I'm facing the same issue and I just started using my iphone about 15 days ago and synced it twice so far but ever since i reinstalled windows and updated itunes, its giving the same error...

  • ChrisJ4203 Level 8 Level 8 (37,935 points)

    Explain why and how you reintalled Windows. Did you do a fresh install, or did you do an upgrade? What version are you using now, versus what you were using before? Did you install over an existing version, or uninstall and reinstall? Which iPhone are you using? What version of iTunes do you have?

  • hero0912 Level 1 Level 1 (65 points)

    It may just be your USB cord. Have you tried a different cord? This sounds hardware related and not software related. If you can't get it to work using a different cord, you may try taking to the Apple Store.


    Also, you may even try re-installing iTunes. If you can, get a friend with an iPhone and see if your PC can detect their phone, that would help isolate it to being YOUR device.


    Also, if you re-installed Windows recently you may check for OS updates. If it's Windows 8, you may try running iTunes in Compatibility mode for Windows 7, or run as administrator.

  • MRaza91 Level 1 Level 1 (0 points)

    Thank God its working now! As for the answer to your question, read the first para, for attempted solutions, read second one, for the one that worked, read the third one. I'm using an Iphone 4 Factory Unlocked with IOS 6.1.3 (no system change) and iTunes (after the upgrade).


    My laptop had a virus because I didnt have any antivirus installed since I thought windows 8's built in Windows Defender was an antivirus (and well enough at that, but I was mistaken). After installing Kaspersky internet security and scanning my laptop, I removed the virus but still reinstalled windows and removed all my content from the laptop (the docs that mattered) and formatted it. After reinstallation, I reinstalled all the softwares and iTunes, which then asked me for an upgrade and I upgraded to vesion and when I got done with everything and plugged in my phone and it didnt read my phone and gave the error I mentioned before.


    I Synced my phone when I had the previous version of iTunes (before the Sep 10 IOS 7 and IPhone 5S / 5C Launch), but the newer version wasnt working. I read here about reinstalling iTunes, the apple mobile support driver and QuickTime (which I did twice), about rebooting my system before using it (which I did), about pausing my internet security/antivirus for a while (which I did againnnn!!!), but to no avail, I even went so far as to erase everything on my phone, and still no luck, and I even went and checked for the apple mobile support driver and iphone drivers in my recognized devices when the phone was plugged in and removed the driver and plugged in my phone again for the software to reinstall but no luck...


    Then I uninstalled my internet security (antivirus), uninstalled iTunes, reinstalled it (the latest version all along), and then plugged in my phone (without changing any setting or erasing the network settings) and thank God it started working again... But I was ticked at having to download and reinstall my apps on iTunes and my cell again... ... ... anyway, do tell me it works, i mean, unistalling your internet security, iTunes and then reinstalling them and plugging it in! good luck!

  • MRaza91 Level 1 Level 1 (0 points)

    I did try the chord, but that wasnt the fault, but it started working after I did the steps mentioned above, and it worked about 15 minutes or so after I wrote that, though I was considering what you're saying now, thanks, I'll keep that in mind if any of my friends have an issue like that

  • ChrisJ4203 Level 8 Level 8 (37,935 points)

    Just as another side note, Kaspersky is one of the worse anti-virus softwares to work with iTunes and other Apple software and devices. If you were to search this forum, you would find numerous issues with it, and it does make it very difficult when it comes to updating iOS. You will usually have to disable it to accomplish the task. There are settings in Kaspersky that allow for ignoring iTunes and other Apple software but it doesn't always work. Keep this in mind when it comes time to update iOS on the phone. Glad everything else is working now.

  • MRaza91 Level 1 Level 1 (0 points)

    thanks, will keep that in mind, as for the problem, did you look at your iTunes wifi sync option? i guess changing the name of the system also has issues in cases of reinstallation, and if not, try using iexplorer to get your data out or upload it on iCloud and then reboot your phone, or go to the apple store just to get that outta the way first

  • ChrisJ4203 Level 8 Level 8 (37,935 points)

    Maybe you misunderstood. I do not have any issues with my setup. Everything is working just fine. I was trying to provide you with information on how to get yours working again. Have a nice day.

  • MRaza91 Level 1 Level 1 (0 points)

    I got it, i was just saying if theres an issue with your setup, you could try that

Previous 1 2 Next