Previous 1 2 Next 16 Replies Latest reply: Jun 28, 2013 3:13 PM by jrllsls
jrllsls Level 1 (0 points)

Twice in one week all the permissions on my computer have changed, causing it to shut down. I have managed to repair them using start up disk and disk utilities but am worried as to why this is happening. Can anyone help? Thanks.

Mac Pro, Mac OS X (10.6.8), 2 x 2.66 GHz Dual-Core Intel, 5GB
  • Kappy Level 10 (263,335 points)

    To paraphrase, "Only you can change permissions." So, what leads you to believe the permissions for all the files on your computer have changed? If this were happening to your system files, then you would likely not be able to startup the computer.

  • jrllsls Level 1 (0 points)

    Because on verifying permissions in disk utilities I had a scrolling, endless list of differing permissions. I was very lucky to be able to start up the disk. It lasted only long enough for me to change the start up disc (for some reason I cannot boot up from pressing Shift + C) before crashing.

  • Kappy Level 10 (263,335 points)

    Since this suggests corrupted system files or a user tried to change all permissions on the startup volume, you will need to reinstall OS X:


    Reinstall OS X without erasing the drive


    1. Repair the Hard Drive and Permissions


    Boot from your Snow Leopard Installer disc. After the installer loads select your language and click on the Continue button. When the menu bar appears select Disk Utility from the Utilities menu. After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list.  In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive.  If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return to the installer.


    If DU reports errors it cannot fix, then you will need Disk Warrior and/or Tech Tool Pro to repair the drive. If you don't have either of them or if neither of them can fix the drive, then you will need to reformat the drive and reinstall OS X.


    2. Reinstall Snow Leopard


    If the drive is OK then quit DU and return to the installer.  Proceed with reinstalling OS X.  Note that the Snow Leopard installer will not erase your drive or disturb your files.  After installing a fresh copy of OS X the installer will move your Home folder, third-party applications, support items, and network preferences into the newly installed system.


    Download and install Mac OS X 10.6.8 Update Combo v1.1.

  • jrllsls Level 1 (0 points)

    Thanks very much, will do.

  • jrllsls Level 1 (0 points)

    Is there any reason why I cannot boot up by pressing Shift + C by the way?

  • Kappy Level 10 (263,335 points)

    I'm not aware of that as a startup shortcut. To boot from an installer DVD:


    Booting From An OS X Installer Disc


    1. Insert OS X Installer Disc into the optical drive.

      2. Restart the computer.

      3. Immediately after the chime press and hold down the "C" key.

      4. Release the key when the spinning gear below the dark gray Apple

          logo appears.

      5. Wait for installer to finish loading.


    Startup key combinations for Intel-based Macs

    OS X keyboard shortcuts

  • jrllsls Level 1 (0 points)

    Many thanks.

  • jrllsls Level 1 (0 points)


    The drive is fine, but the permissions are still not. I have verified and 'repaired' a few times, but the permissions remain wrong, even though First Aid says it has repaired them. I have tried reinstalling and it has failed, saying it cannot load the support files. (This is from a bona fide Install disk.) Is there anything else I can do?

  • Kappy Level 10 (263,335 points)

    What permissions, exactly? If you are referring to repetive unrepaired permissions appearing in Disk Utility, then just ignore them. They are innocuous and will recur everything you repair permissions.

  • jrllsls Level 1 (0 points)

    This sort: Untitled.png


    Is this a red herring? If so, then the real issue is that every few days the computer crashes, but the disk is okay when I check it with FirstAid, and I cannot reinstall the OS system.

  • Kappy Level 10 (263,335 points)

    I can't really tell because the full directory name is hidden. But the message has to do with a directory's permissions, and usually they are indeed meaningless errors arising from past, updated versions of OS X.


    Please provide more information on these crashes. In particular open Console in the Utilities folder and monitor it until one of these crashes occurs. See if the log entry helps point out the source of the crash. Also, using the Console's sidebar you can find the crash report based on date and time that can point out what crashed.


    Don't post a crash report. They are very long and hardly any user knows what the mean.

  • jrllsls Level 1 (0 points)



    This is the latest crash report from earlier today.

  • Kappy Level 10 (263,335 points)

    Appears a problem with your Wacom Tablet and its driver. Be sure you are using the most recent driver for the tablet. I would also contact Wacom tech support for assistance. Meanwhile, uninstall the Wacom software and disconnect the tablet from the computer. See if this results in no more crashing.

  • jrllsls Level 1 (0 points)

    Thanks very much. I've done that so will hope for the best. And any idea why I was unable to reinstall the software?

Previous 1 2 Next