Previous 1 2 Next 15 Replies Latest reply: Dec 31, 2013 5:08 AM by Woking57
notme11 Level 1 Level 1 (0 points)

I tried to update three apps on my iPad.  I hit the "update all" button and my ipad showed "installing".  They did not install.  They are stuck in the "installing mode".  I got a message that they could not install.  I got my husbands ipad and tried to update one app and his is doing the same thing.   I rebooted our wifi box and did a hard reboot of my ipad and my husband's also.  The apps are still stuck with the greyed out "installing" button showing.  It has been over three hours. 

 

Any ideas?

  • Demo Level 10 Level 10 (85,810 points)

    I have posted these suggestions quite a few times and some of these suggestions have worked for a number of users. Give them a try and see if one of them works for you. Ignore anything that you already tried, or try it again if you like. Sometimes something will work if you try it again. You might want to try one device at a time, rather than doing both together.

     

     

    1. Tap the "waiting" or "installing" icon and see if you can pause it. If it does pause, then tap it again and see if it will resume. If that works, repeat the same steps for each "waiting" icon.

     

    2. Reboot the iPad by holding down on the sleep and home buttons at the same time for about 10-15 seconds until the Apple Logo appears - ignore the red slider - let go of the buttons.

     

    3. Make sure that you do not have a stalled download in iTunes - a song or podcast .... if you have a download in there that did not finish, complete that one first. Only one thing can download at a time on the iPad so that could be what is causing the problem.

     

    4. If that doesn't work - sign out of your account, restart the iPad and then sign in again.

     

    Settings>iTunes & App Store>Apple ID. Tap your ID and sign out. Restart the iPad by holding down on the sleep button until the red slider appears and then slide to shut off. To power up hold the sleep button until the Apple logo appears and let go of the button.

     

    Go back to Settings>iTunes & App Store>Sign in and then try to update again. Tap one waiting icon only if necessary to start the download stream.

     

    5. You can also try deleting the waiting icons - tap and hold down on an icon until it wiggles - the tap the X on the icon to delete it. Then try to download again.

     

    6. You can try resetting all settings. Settings>General>Reset>Reset All Settings. You will have to enter all of your device settings again.... All of the settings in the settings app will have to be re-entered.

     

    7. If all else fails, download the updates or the apps in iTunes on your computer and then sync the content to your iPad.

  • Diavonex Level 9 Level 9 (66,520 points)

    There may be a download stuck in another area such as a song or podcast that is preventing the app from updating.

     

    Go to the iTunes app on your iPad. Check to see if you have any downloads pending there. That pending download may be blocking app updates. If so, delete the item. That may get the app installation going again.

  • BobGeorge Level 1 Level 1 (5 points)

    Thanks Demo for your reply ... this is not your fault !

     

    However, I am shocked by the frequency that this happens ... seems more prone on Iphone than on Ipad, but does happen regularly on both.

     

    Yet, I never seem to see a formal Apple acknowledgement of problem or suggested fix.

     

    The only approach I have found that works is to delete the app and then reinstall.  A pain tho as it loses its folder location on my device, then I have to re-sign-in, and I may lose any downloads inside.

     

    Perhaps Sen. McCain's request for auto-updates may cause a fix to this !  In the interim, whether trying Demo's work-thru or others, seems like Apple don't care and we are stuck with the problem ...

  • Demo Level 10 Level 10 (85,810 points)

    It has happened to me before as well and it is a bit annoying. I have usually been able to resume the updates by rebooting, but a couple of times I had to delete the waiting icons and reinstall the apps.

     

    I certainly don't know why it happens but I do know that I have much better success if I only update one app at a time and if I stay up with the updates and not let them build up to the point where I have to spend a half an hour just to update 20 apps.

  • notme11 Level 1 Level 1 (0 points)

    I finally figured out how to delete from settings.  I hate to admit I didn't know this, but I will post for others like me that didn't know.  By clicking General-Settings and waiting for the Usage to load, you can delete apps there.   Once deleted, I re- downloaded the apps and they all worked. 

     

    Thanks for the help!

  • brad163 Level 1 Level 1 (10 points)

    I had this same problem.  What worked for me was going to the icon of the app(s) on the ipad screen (not the App Store screen) and tapped each one.  The icons changed immediately from "installing" and resumed their download.

  • EmTwo1 Level 1 Level 1 (0 points)

    First solution that actually worked...and it was the simplest one.  Thanks Brad!

  • brad163 Level 1 Level 1 (10 points)

    Your welcome! Thanks for the kudos . Glad it worked out.

  • Da1eHamann Level 1 Level 1 (0 points)

    Thanks Demo!  I had a similar problem where I had a stuck update, but my issue was I'd get the notification icon on the App Store but when I went into the Update tab, the screen was blank.  I had to resort to hunting throug my purchased apps looking for the ones that said Update next to them to get my updates to work.  After doing that, I was left with one app that needed an update (I knew this from the red 1 notification icon on my App Store) but I could not locate it in my list of hundres of apps.

     

    I used steps 2 thru 4 to solve my issue.  After finishing step 4, I was able to go into the App Store and see my remaining app that needed to be updated.

  • memattson Level 1 Level 1 (0 points)

    The two times it happened to me, it was due to limited space. I *think* iOS tries to load the entire update, before it deletes the old version. When it discovers that there is not enough space for two versions of the app (old and updated), it gets stuck. (If this is the case, Apple should add a warning message that is a little more instructive.)

     

    After I freed up enough space (removed movies and TV shows that I already have on my computer), I was able to update the large App, and then put the movies and TV shows back on the device.

     

    Obviously, one way to have enough space is to remove the app, and then re-install (with the updated version). But if you can find other ways to get more disk space, you don't have to delete that app.

  • CoolJamz Level 1 Level 1 (0 points)

    Thanks Brad. Your solution was the only one that worked...and the simplest. Much appreciated.

  • brad163 Level 1 Level 1 (10 points)

    Your welcome. Thanks for the feedback

  • jvaa Level 1 Level 1 (0 points)

    Thanks Brad. As others have said, this is the one that worked for me.

  • 42Champion Level 1 Level 1 (0 points)

    After trying lots of things and doing quite a bit of search, Brad to the rescue.  This simple answer worked like a charm!  Thanks Brad!!

Previous 1 2 Next