2 Replies Latest reply: Jun 25, 2013 1:32 PM by AnaMusic
kanztee Level 1 Level 1 (0 points)

So I have this iMac from 2010, I have not used it in the past couple of years and I decided to whoop out this bad boy in my new office and then I realized uh oh... I cannot update my softwear beacuse I am still on software 10.5.8 and for that version, there is no app store and for me to get the next update I need the app store and to have the app store I need the new update.... this is really frustrating, it kind of like the chicken and the egg sitution.

What am I to do? Please help?

I am in Dubai and we do not have an apple store so I cannot just pop in to one of the geniuses to help me out.

Thank you and I look forward for your response


iMac, Mac OS X (10.5.8)