11 Replies Latest reply: Mar 21, 2014 2:56 AM by tîmster
Thanar Level 2 Level 2 (290 points)

Hello,

 

I am having a certain issue with Preview.app for over two years now, problem started with Snow Leopard, if I recall coreclty:

 

I am working with 11k by 8k 1bit TIFF images. Whenever I try to crop/scale/rotate one of these images, the resulting file is BLACK. File size is the expected (the TIFF is being saved as uncompressed), but there is no content whatsoever, regardless of the application I use to open the file as saved by Preview.app.

Tried on two iMacs, same result.

 

Anyone has faced a similar issue? Any solution?


OS X Mountain Lion (10.8.2)
  • jayv. Level 4 Level 4 (1,230 points)

    I have not experienced this issue but would like to test it on my end if possible, is this an image i could download somewhere?

     

    If this issue has been haunting you for a while spanned over a few OS X versions i'd think the original problem has been migrated along with all the upgrades but this theory kind of goes out the window as it happens on another Mac as well. (unless that had the same issue and migration pattern).

  • Thanar Level 2 Level 2 (290 points)

    Hello Pr0digy V., thanx for the idea.

     

    I have uploaded the image file to Dropbox, you could give it a try. Under my setup, opening the file in Preview, cropping it and saving into place damages the resulting image. Please post your result.

     

    Thanx.

  • jayv. Level 4 Level 4 (1,230 points)

    Exact same issues here. Even photoshop messes up the file even when saved to jpg or other formats after it's been edited. While i currently do no have a solution, i can tell you you're not going crazy I'll keep testing and will post if i have an update. perhaps someone else will come along with suggestions in the mean time.

  • Old Toad Level 10 Level 10 (130,160 points)

    Download and try Xee³.  It does lossless rotations, flips among other editing features. If you want the older, free verson get it here: Xee V2

     

     

    OT

  • Meg The Dog Level 6 Level 6 (10,690 points)

    Open the document in Preview, then go to the menu Tools > Assign Profile:

     

    PreviewScreenSnapz002.png

    and Assign ColorSync Profile to Image as Black & White:

     

    PreviewScreenSnapz003.png

    and click OK.

    Now rotate and crop your image and store it.

    See if this helps.

     

    MtD

  • jayv. Level 4 Level 4 (1,230 points)

    While B&W what not an available option for me, i did have Generic Grey Profile available. Set it, cropped and rotated, saved... it did the trick for me. Great tip. Hope it works for the OP as well

  • Thanar Level 2 Level 2 (290 points)

    Well, this solved it for me as well. I did not have the Black & White profile listed as well, but the Generic Gray worked just fine. Meg The Dog, I guess you ended up testing the color profiles after having a look in the console, or did you have prior experience to this issue with Preview.app?

     

    Concluding this discussion, this definitely seems to be a bug; A long-standing bug for sure. Is there anyone (Meg The Dog maybe?) that could escalate the issue or file a direct bug report on the issue?

  • Thanar Level 2 Level 2 (290 points)

    I am aware of this bug report procedure, however I don't think a single report on the issue will make any difference. I've heard that higher-level apple discussions members have the ability to escalate definite bugs "in-house", that's why I am asking...

  • jayv. Level 4 Level 4 (1,230 points)

    Ah gotcha. I don't know about that but it could help. Still, the feedback ends up somewhere... can't hurt.

  • tîmster Level 1 Level 1 (0 points)

    I had a similar issue. I rotated my images in Preview on the Computer I used for scanning the negatives in TIFF format. For some reason they were not displayed anymore in Preview, but I could still view them by pressing space from the Finder. I noticed that they were translucent, but I didn't think much about it. The computer was running an older version, 10.6.8, so I figured it is a bug and everything will be fine at home on the newer version.

     

    As soon as I came home and wanted to have a look at my photos, I still wasn't able to view them. I found this discussion but the proposed fix did not do the trick. I went back to Digital Photo Lab from our university where I scanned the Photos. I wanted to revert the photos to the original but the option was grayed out (On some other thread this was possible for some people). So I applied the "Black and White" color profile again and chose "Save As" - an option I did not have at home (different versions). The prompt included a tick "Include Alpha", ticked by default. I unticked it, saved under a different file name et voilà! I got my photos back!

     

    Apparently it was the alpha channel that was screwed up. Also explains why the photos were translucent with the Space-Preview from Finder. Also, this made the files significantly smaller - probably half the size if I'm not mistaken. I'm just super happy I got my photos back and don't have to scan them again!

     

    Hope this helps somebody else!

     

    Best

    Tim