14 Replies Latest reply: Jun 27, 2013 7:30 AM by vinayak1
Yakito Level 1 Level 1 (0 points)

Hello, this is starting to worry me a lot.

 

I had a pending update in the Apple store for OS 10.8.4 (not exactly surei remember the number correctly but it was the last one)

I proceeded with the update via the apple store and left. I came back around 7 hours later just to see my Macbook sitting on the gray Apple logo spinning wheel screen (the one you get after a reboot usually for a few seconds). I found it strange and I waited around 1 more hour but nothing happened so I decided to reboot my computer. Since then I am kicked out of my computer. I am prompted with the login screen asking me for my user password but it won't work when using the right password. I even changed the password using terminal/passwordreset/ and nothing. I even managed to create a new user and right after creating it I get the login screen which asks me for the password I just created and when I type it in it won't work.

 

I don't really know what else to do. when I reboot with cmd+S I can see my users and files there.I did a disk check and it said it was ok,but the os is not taking the right passwords.

 

I don't have a lion disk as it was bought on the Apple store.

 

Anyone know what else can I do? Any tip will be much appreciated


MacBook Pro
  • Linc Davis Level 10 Level 10 (153,800 points)

    When you enter your password, does the window shake from side to side?

  • Yakito Level 1 Level 1 (0 points)

    Yes, not the whole Window just the input box.

     

    Just finished a reinstall of the os and again same thing screen stalls on Apple logo andi have to turn off/on after that the password issue.

     

    ideas this is getting ridicules why won't a correct password work?

  • Linc Davis Level 10 Level 10 (153,800 points)

    First, make sure caps lock is not on.

    You must back up all data before continuing, unless you've already done so. If you need to back up but can't log in, ask for instructions.

    If the user account is associated with an Apple ID, and you know the Apple ID password, then maybe the Apple ID can be used to reset your user account password.

    Otherwise*, boot into Recovery mode. When the OS X Utilities screen appears, select

    Utilities Terminal

    from the menu bar. In the Terminal window, type this:

    res

    Press the tab key. The partial command you typed will automatically be completed to this:

    resetpassword

    Press return. A Reset Password window opens.

    Select your boot volume ("Macintosh HD," unless you gave it a different name) if not already selected.

    Select your username from the menu labeled Select the user account if not already selected.

    Follow the prompts to reset the password. It's safest to choose a password that includes only the characters a-z, A-Z, and 0-9.

    Select

    Restart

    from the menu bar.

    You should now be able to log in with the new password, but your Keychain will be reset (empty.) If you've forgotten the Keychain password (which is ordinarily the same as your login password), there's no way to recover it.

    *Note: If you've activated FileVault, this procedure doesn't apply. Follow instead the instructions on this page:

    If you forget the password and FileVault is on

  • Yakito Level 1 Level 1 (0 points)

    Thanks Linc I already tried thats several times and even though I am able to change the password then the login screen won't accept it.

     

    The keyword works fine because I can use it in recovery mode

  • Yakito Level 1 Level 1 (0 points)

    I noticed something else. Even when I do the password reset and I change the password and the hint , I still see the old hint when I reboot as if nothing happened.

  • Linc Davis Level 10 Level 10 (153,800 points)

    Please read this whole message before doing anything.

    This procedure is a diagnostic test. It’s unlikely to solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.

    The purpose of the test is to determine whether the problem is caused by third-party software that loads automatically at startup or login, or by a peripheral device.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. Note: If FileVault is enabled, or if a firmware password is set, or if the boot volume is a software RAID, you can’t do this. Ask for further instructions.
       
    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including sound output andWi-Fi on certain iMacs. The next normal boot may also be somewhat slow.

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem?

     

    After testing, reboot as usual (i.e., not in safe mode) and verify that you still have the problem. Post the results of the test.

  • Yakito Level 1 Level 1 (0 points)

    Hello Linc, I tried that, the issue is the same if I can not pass the login screen then there is nothing I can test and the problem is with the login screen. The system is not recognizing my password. There are many posts here on the board but with no solution. I refuse to format my drive, there must be a workaround.

  • Linc Davis Level 10 Level 10 (153,800 points)

    Back up all data, if you don't already have a current backup. You can back up without being able to log in. Ask if you need instructions.

     

    Boot into Recovery mode. When the OS X Utilities screen appears, follow the prompts to reinstall the OS. You don't need to erase the boot volume, and you won't need your backup unless something goes wrong. If your Mac was upgraded from an older version of OS X, you’ll need the Apple ID and password you used to upgrade, so make a note of those before you begin.

      

    If you installed the Java runtime distributed by Apple and still need it, you'll have to reinstall it.

  • Yakito Level 1 Level 1 (0 points)

    Yes I am reinstalling mountain Lion again. I tried this already and didn't work keys see if it does this time. Unfortunately I don't have the disk so it is being downloaded from the app store...6 hours. .. it is really frustrating, no error no nothing.

  • Yakito Level 1 Level 1 (0 points)

    I just completed a downgrade to snow leopard and I get the exact same behavior,the is wont accept the right password for any user,this is frustrating I don't know what else to do and I also been rebooting and turning on and of my computer all day I am now worried data will be damaged.

     

    I need instructions on how to solve this bug, any tip appreciated

  • Linc Davis Level 10 Level 10 (153,800 points)

    I just completed a downgrade to snow leopard

     

    That wasn't what I suggested. I can't help with a Snow Leopard problem. Good luck.

  • Yakito Level 1 Level 1 (0 points)

    Thanks, good luck to you too...

     

    I managed to solve the issue and I think it might help many people with the same problem as I couldn't find the solution anywhere else but I found lots of posts with the same issue.

     

    How to solve the issue when the OS is not recognizing the correct password at the login screen:

     

    1. Boot your computer pressing the alt key or the C key if you are on any system below Lion. Ir order to do this restart or turn on your computer and press the key before the grey screen appear and hold it until you see the spinning wheel.
    2. In the new screen you will see a top menu (on anything under Lion you might need to press 'install' before you see the top menu and remember than on anything under Lion you will need a disk in order to boot)
    3. Go to utilities->terminal
    4. Navigate towards your user folder (the one you are trying to use for loggin in and isn't working)
    5. Your user folder should be something like '/Volumes/Macintosh HD/Users/YOUR USER NAME'
    6. If you are not sure run the command ls /Volumes/"Macintosh HD"/Users
    7. So run cd /Volumes/Macintosh HD/Users/MYUSERNAME
    8. Go into de Library Folder  (run the command cd Library)
    9. Run the command mv Keychains Keychains.old
    10. Type reboot
    11. Log in normally and enjoy!

     

    Note: Before doing this make sure the 'resetpassword' procedure does not work. In order to learn about it google for 'resetpassword terminal boot mac'

     

    Hope this helps someone else and I also hope Apple takes care of the bug.

     

    After I finish setting everything back to the place it were before I started messing around trying to solve this bug I will come back and explain why that works!

  • PratikK Level 1 Level 1 (0 points)

    Thanks Yakito...

    Your solution perfectly works for me....

  • vinayak1 Level 1 Level 1 (0 points)

    Indeed this works for me as well