Previous 1 2 Next 22 Replies Latest reply: Jul 2, 2013 12:27 AM by Rhys.Perrin Go to original post
  • Rhys.Perrin Level 1 Level 1 (0 points)

    Hi again, Linc and Thomas.

     

    Many thanks for the advice re anti-virus.  Feeling a lot better having read over all of this - thank you!! :-)

     

    Cheers.

  • Linc Davis Level 10 Level 10 (173,080 points)

    Please read this whole message before doing anything.
      
    This procedure is a diagnostic test. It won’t solve your problem. Don’t be disappointed when you find that nothing has changed after you complete it.
       
    Third-party system modifications are a common cause of usability problems. By a “system modification,” I mean software that affects the operation of other software — potentially for the worse. The following procedure will help identify which such modifications you've installed. Don’t be alarmed by the complexity of these instructions — they’re easy to carry out and won’t change anything on your Mac.

     

    These steps are to be taken while booted in “normal” mode, not in safe mode. If you’re now running in safe mode, reboot as usual before continuing.

     

    Below are instructions to enter some UNIX shell commands. The commands are harmless, but they must be entered exactly as given in order to work. If you have doubts about the safety of the procedure suggested here, search this site for other discussions in which it’s been followed without any report of ill effects.

     

    Some of the commands will line-wrap or scroll in your browser, but each one is really just a single line, all of which must be selected. You can accomplish this easily by triple-clicking anywhere in the line. The whole line will highlight, and you can then copy it. The headings “Step 1” and so on are not part of the commands.

     

    Note: If you have more than one user account, Step 2 must be taken as an administrator. Ordinarily that would be the user created automatically when you booted the system for the first time. The other steps should be taken as the user who has the problem, if different. Most personal Macs have only one user, and in that case this paragraph doesn’t apply.

     

    Launch the Terminal application in any of the following ways:

     

    ☞ Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    ☞ In the Finder, select Go ▹ Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    ☞ Open LaunchPad. Click Utilities, then Terminal in the icon grid.

     

    When you launch Terminal, a text window will open with a line already in it, ending either in a dollar sign (“$”) or a percent sign (“%”). If you get the percent sign, enter “sh” and press return. You should then get a new line ending in a dollar sign.

     

    Step 1

     

    Triple-click the line of text below to select it:
    kextstat -kl | awk '!/com\.apple/{printf "%s %s\n", $6, $7}' | open -f -a TextEdit
     
    Copy the selected text to the Clipboard by pressing the key combination command-C. Then click anywhere in the Terminal window and paste (command-V). A TextEdit window will open with the output of the command. If the command produced no output, the window will be empty. Post the contents of the TextEdit window (not the Terminal window), if any — the text, please, not a screenshot. You can then close the TextEdit window. The title of the window doesn't matter, and you don't need to post that. No typing is involved in this step.
        
    Step 2

     

    Repeat with this line:
    { sudo launchctl list | sed 1d | awk '!/0x|com\.(apple|openssh|vix)|org\.(amav|apac|cups|isc|ntp|postf|x)/{print $3}'; sudo defaults read com.apple.loginwindow LoginHook 2> /dev/null; } | open -f -a TextEdit
     
    This time you'll be prompted for your login password, which you do have to type. Nothing will be displayed when you type it. Type it carefully and then press return. You may get a one-time warning to be careful. Heed that warning, but don't post it. If you see a message that your username "is not in the sudoers file," then you're not logged in as an administrator.

     

    Note: If you don’t have a login password, you’ll need to set one before taking this step. If that’s not possible, skip to the next step.

     

    Step 3
    launchctl list | sed 1d | awk '!/0x|com\.apple|org\.(x|openbsd)/{print $3}' | open -f -a TextEdit
     
    Step 4
    ls -1A /e*/{la,mach}* {,/}L*/{Ad,Compon,Ex,Fram,In,Keyb,La,Mail/Bu,P*P,Priv,Qu,Scripti,Servi,Spo,Sta}* L*/Fonts .la* 2> /dev/null | open -f -a TextEdit
      
    Important: If you formerly synchronized with a MobileMe account, your me.com email address may appear in the output of the above command. If so, anonymize it before posting.

     

    Step 5
    osascript -e 'tell application "System Events" to get name of every login item' | open -f -a TextEdit
     
    Remember, steps 1-5 are all copy-and-paste — no typing, except your password. Also remember to post the output.

     

    You can then quit Terminal.

  • Rhys.Perrin Level 1 Level 1 (0 points)

    Hi Link.

     

    Results of the test are as follows:

     

    STEP 1:

    com.Logitech.Control Center.HID

    com.Logitech.Unifying.HID Driver

    com.parallels.kext.prl_usb_connect (7.0

    com.parallels.kext.prl_hypervisor (7.0

    com.parallels.kext.prl_hid_hook (7.0

    com.parallels.kext.prl_netbridge (7.0

    com.parallels.kext.prl_vnic (7.0

    com.nvidia.CUDA (1.1.0)

     

    STEP 2:

    com.parallels.vm.prl_naptd

    com.parallels.desktop.launchdaemon

    com.oracle.java.Helper-Tool

    com.microsoft.office.licensing.helper

    com.google.keystone.daemon

    com.barebones.authd

    com.adobe.SwitchBoard

    com.adobe.fpsaud

     

    STEP 3:

    N4RA379GBW.com.busymac.busycal2.alarm

    com.fiplab.MemoryCleanHelper

    com.paragon.ntfs.trial

    com.parallels.vm.prl_pcproxy

    com.parallels.DesktopControlAgent

    com.parallels.desktop.client.launch

    com.oracle.java.Java-Updater

    com.nvidia.CUDASoftwareUpdate

    com.Logitech.Control

    com.google.keystone.system.agent

    com.spotify.webhelper

    com.google.GoogleContactSyncAgent

    com.akamai.single-user-client

    com.adobe.ARM.202f4087f2bbde52e3ac2df389f53a4f123223c9cc56a8fd83a6f7ae

    com.adobe.AAM.Scheduler-1.0

     

    STEP 4:

    /Library/Components:

     

     

    /Library/Extensions:

     

     

    /Library/Frameworks:

    AEProfiling.framework

    AERegistration.framework

    Adobe AIR.framework

    AquaticPrime.framework

    AudioMixEngine.framework

    CUDA.framework

    NyxAudioAnalysis.framework

    OSXFUSE.framework

    PluginManager.framework

    TSLicense.framework

    iTunesLibrary.framework

     

     

    /Library/Input Methods:

     

     

    /Library/Internet Plug-Ins:

    AdobeExManDetect.plugin

    AdobePDFViewer.plugin

    AdobePDFViewerNPAPI.plugin

    EPPEX Plugin.plugin

    Flash Player.plugin

    Flip4Mac WMV Plugin.plugin

    JavaAppletPlugin.plugin

    LogitechDeviceDetection.plugin

    Quartz Composer.webplugin

    QuickTime Plugin.plugin

    SharePointBrowserPlugin.plugin

    SharePointWebKitPlugin.webplugin

    Silverlight.plugin

    WidevineMediaOptimizer.plugin

    flashplayer.xpt

    googletalkbrowserplugin.plugin

    npgtpo3dautoplugin.plugin

    nsIQTScriptablePlugin.xpt

    o1dbrowserplugin.plugin

     

     

    /Library/Keyboard Layouts:

     

     

    /Library/LaunchAgents:

    com.Logitech.Control Center.Daemon.plist

    com.adobe.AAM.Updater-1.0.plist

    com.google.keystone.agent.plist

    com.nvidia.CUDASoftwareUpdate.plist

    com.oracle.java.Java-Updater.plist

    com.parallels.DesktopControlAgent.plist

    com.parallels.desktop.launch.plist

    com.parallels.vm.prl_pcproxy.plist

     

     

    /Library/LaunchDaemons:

    com.adobe.SwitchBoard.plist

    com.adobe.fpsaud.plist

    com.barebones.authd.plist

    com.google.keystone.daemon.plist

    com.microsoft.office.licensing.helper.plist

    com.oracle.java.Helper-Tool.plist

    com.parallels.desktop.launchdaemon.plist

     

     

    /Library/PreferencePanes:

    .svn

    CUDA Preferences.prefPane

    Flash Player.prefPane

    Flip4Mac WMV.prefPane

    JavaControlPanel.prefPane

    Logitech Control Center.prefPane

    NTFSforMacOSX.prefPane

    OSXFUSE.prefPane

    WinShortcutterPrefs.prefPane

     

     

    /Library/PrivilegedHelperTools:

    com.barebones.authd

    com.microsoft.office.licensing.helper

     

     

    /Library/QuickLook:

    ParallelsQL.qlgenerator

    iBooksAuthor.qlgenerator

    iWork.qlgenerator

     

     

    /Library/QuickTime:

    .DS_Store

    AppleAVCIntraCodec.component

    AppleHDVCodec.component

    AppleIntermediateCodec.component

    AppleMPEG2Codec.component

    AppleProResCodec.component

    DVCPROHDCodec.component

    DXVCodec.component

    FCP Uncompressed 422.component

    Flip4Mac WMV Advanced.component

    Flip4Mac WMV Export.component

    Flip4Mac WMV Import.component

    IMXCodec.component

     

     

    /Library/ScriptingAdditions:

    Adobe Unit Types.osax

     

     

    /Library/Spotlight:

    Microsoft Office.mdimporter

    ParallelsMD.mdimporter

    iBooksAuthor.mdimporter

    iWork.mdimporter

     

     

    /Library/StartupItems:

    HWNetMgr

    HWPortDetect

    StartOuc

     

     

    /etc/mach_init.d:

     

     

    /etc/mach_init_per_login_session.d:

     

     

    /etc/mach_init_per_user.d:

     

     

    STEP 5:

    iTunesHelper, Windows Server Launchpad, Microsoft Database Daemon, Skype, Canon IJ Network Scanner Selector2, Android File Transfer Agent, Canon IJ Network Scanner Selector EX, Dropbox, Battery Status, Leaf

     

     

    Hope this helps?  Many, many, many thanks for your assistance!

     

    Cheers.

  • Rhys.Perrin Level 1 Level 1 (0 points)

    Hi again, Linc

     

    I should also add that, having seen the Java Applet Plugin reference in the above test outputs, I have now disabled Java content in the Java Control Panel. I had already disabled it in Safari and Firefox. I don't know if this was necessary, but having read what you and Thomas have shared, I thought it prudent to do this.  Let me know if I don't need to take this step and I will re-enable it.

     

    Cheers. 

  • Linc Davis Level 10 Level 10 (173,080 points)

    The Java plugin is not causing this problem. See my earlier post on the issue of Java.

    Please read this whole message carefully, especially the warnings, before doing anything.

    1. I can only guess which of the modifications you've made to your system is causing the problem. The changes suggested here should be considered provisional; they may not solve your problem, or they may remove functionality that you find useful. If a third-party system modification that you want to keep is causing the problem, refer to its developer for support.

    2. WARNING: Back up all data now if you haven’t already done so. Before proceeding, you must be sure you can restore your system to its present state, even if it becomes unbootable. If you’re not sure you can do that, STOP — DON’T CHANGE ANYTHING. If you’re dissatisfied with the results of the procedure suggested below, restore from your backup. I will not be responsible for the consequences, and I will not be able to help, if you ignore this warning.

    3. You should either remove or update the following system modification(s), if an update is available from the developer:

    Parallels

    and definitely remove at least the following:

    Logitech Control Center

    CUDA

    Paragon NTFS (incomplete installation?)

    4. Whatever you remove must be removed completely, and (unless otherwise specified in this message) the only way to do that is to use the uninstallation tool, if any, provided by the third-party developers, or to follow their instructions. If the software has been incompletely removed, you may have to re-download or even reinstall it in order to finish the job. I can't be more specific, because I don't install such things myself. Please do your own research.

    You will generally have to reboot after uninstalling a system modification. Until you do that, the uninstallation may have no effect, or unpredictable effects.

    Here are some general guidelines to get you started. Suppose you want to remove something called “BrickYourMac.” First, consult the product's Help menu, if there is one, for instructions. Finding none there, look on the developer's website, say www.brickyourmac.com. (That may not be the actual name of the site; if necessary, search the web for the product name.) If you don’t find anything on the website or in your search, contact the developer. While you're waiting for a response, download BrickYourMac.dmg and open it. There may be an application in there such as “Uninstall BrickYourMac.” If not, open “BrickYourMac.pkg” and look for an Uninstall button.

    Again, please don't ask me to do this research for you. You can do it better than I can, because I haven't installed the product and I may not even know what it is.

    If you can’t remove software in any other way, you’ll have to erase your boot volume and perform a clean reinstallation of OS X. Never install any third-party software unless you're sure you know how to uninstall it; otherwise you may create problems that are very hard to solve.

    WARNING: Trying to remove complex system modifications by hunting for files by name often will not work and may make the problem worse. The same goes for "utilities" that purport to remove software.

    5. I recommend that you never reinstall the modifications marked with a dagger (†) above, if any. If your problem is resolved after uninstalling all the above modifications and rebooting, but you still want to use some of those not marked with a dagger, you can experiment with putting them back, one at a time, testing carefully after each step. Keep in mind that system modifications may be incompatible with each other or with future OS X updates, so it may not be clear which one is at fault.

    6. If you still have problems after making the suggested changes and rebooting, post again. Remember: if you don’t like the results of this procedure, you can undo it by restoring from the last backup you made before you started.

  • Rhys.Perrin Level 1 Level 1 (0 points)

    Thanks, Linc.  Sadly I will not be able to uninstall all of these items. To give you an idea:

     

    • Parallels is used to run Windows-based software my business has purchased, and given I am the only Mac user, it is cost-prohibitive to purchase an inferior Mac-friendly product.  Please note that I would not normally use the term "inferior" when it comes to Mac-friendly products (generally they're far from inferior), but in this case I have explored the possibility of purchasing such a product from the same distributor as the Windows product we own, and they have advised against it as the Mac product is nowhere near as good, as effective or as powerful. 
    • I run a Logitech mouse, so removal of the Logtech Control Panel is really not an option without going out and purchasing a Magic Mouse, which is not ideal in my situation. However, I will explore this option if I need to.
    • The Windows Server I mentioned earlier is the central storage for shared files. Of course, it runs NTFS format, which is incompatible with OS X without Paragon (this is not an incomplete installation, by the way).

     

    So... As a starting point, I will ensure all of the above are up to date.  I will also explore the possibility of removing CUDA.  I'm not exactly sure what it does, but I know it's associated with the Nvidia graphics card in the MBP.

     

    Many thanks again. I'll keep you posted on any progress.

     

    Cheers.

  • MadMacs0 Level 5 Level 5 (4,660 points)

    Rhys.Perrin wrote:

     

    1/07/13 10:38:05.172 PM WindowServer[154]: CGXDisableUpdate: UI updates were forcibly disabled by application "Disk Utility" for over 1.00 seconds. Server has re-enabled them.

    1/07/13 10:38:05.313 PM WindowServer[154]: reenable_update_for_connection: UI updates were finally reenabled by application "Disk Utility" after 1.14 seconds (server forcibly re-enabled them after 1.00 seconds)

     

    Given the reference to Windows Server in the above, I should also highlight out a couple of other points at this stage:

    1. The Windows Server has been on the network since before the MBP was purchased and has never given any grief other than (maybe) a slow initial connection to the Server via Finder.
    2. As part of the reboot into normal mode, I elected not to launch the Windows Server Launchpad, so this was NOT running at the time of the latest hang.

    Just a quick note that the reference to "WindowServer" is almost certainly not to a server on your network, rather it's the OS X process that manages all the windows on your desktop. We all see references to that occasionally.

  • Rhys.Perrin Level 1 Level 1 (0 points)

    Hi everyone.

     

    It looks like the cause of the Disk Utility "stop responding" issue relates in some way to Time Machine backups. I'm not sure why this would be an issue, but I have witnessed Disk Utility stop responding on at least three occassions today, each time as Time Machine commences a backup. I have tried to reset Time Machine (unmount/remount drive, reset drive), but this did not resolve the problem.

     

    FYI: Time Machine is backing up to a WD MyBookLive external HDD, connected to the network via ethernet. MBP may also be connected via ethernet, but more often is connection via WiFi (this does not seem to make a difference).

     

    Any thoughts?!?!?!?  Please?!?!?  Thanks!

     

    Cheers.

Previous 1 2 Next