Skip navigation

Photo Stream automatic import not working

3061 Views 12 Replies Latest reply: Oct 28, 2013 5:57 PM by phatty82 RSS
sflomenb Level 1 Level 1 (40 points)
Currently Being Moderated
Jun 28, 2013 7:49 AM

I previously just had an iPhone and iMac. When I added photos to either device, they uploaded to iCloud and appeared on both. When I did this from my iPhone to my iMac, it worked fine, and my iMac automatically imported the photos from my Photo Stream to my library.


I just got the new MacBook Air. I transferred my iPhoto Library through Finder. Everything works fine. When I add a photo from my iPhone to Photo Stream, it appears on the Photo Stream on both of my Macs and both automatically import it. However, if I add a photo to either of my Macs, the other Mac does not automatically import it, and instead, I need to manually import it each time.


How can I fix this so my Macs automatically import the photos? I have the appropriate settings enabled. Screen Shot 2013-06-28 at 10.44.57 AM.png


To clarify, the photos appear in the "Photo Stream" section correctly, they just do not import to my library automatically, and I need to manually import them.

MacBook Air (13-inch Mid 2013), OS X Mountain Lion (10.8.4), 8 GM Memory, 512 GB
  • Old Toad Level 10 Level 10 (113,125 points)
    Currently Being Moderated
    Jun 28, 2013 7:52 AM (in response to sflomenb)

    Give this a try:


    1 - delete the iPhoto preference file,, that resides in your

         User/Home/Library/ Preferences folder.


    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/ folder (Snow Leopard and Earlier).




    or with Lion and Mt. Lion from the User/Library/Containers/




    3 - launch iPhoto, reset all of its preferences and try again.


    NOTE 1: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.


    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.



  • Old Toad Level 10 Level 10 (113,125 points)
    Currently Being Moderated
    Jun 28, 2013 8:09 AM (in response to sflomenb)

    On the Mac that's having the problem importing.

  • Old Toad Level 10 Level 10 (113,125 points)
    Currently Being Moderated
    Jun 29, 2013 8:46 AM (in response to sflomenb)

    As a test launch iPhoto with the Option key held down and create a new, test library.  Check to see if the porblem persists. Does it?

  • Old Toad Level 10 Level 10 (113,125 points)
    Currently Being Moderated
    Jun 29, 2013 9:20 AM (in response to sflomenb)

    Do the following to both libraries: apply the two fixes below in order as needed:


    Fix #1


    Launch iPhoto with the Command+Option keys held down and rebuild the library.



    Since only one option can be run at a time start

    with Option #4 and then #1 as needed.


    Fix #2


    Using iPhoto Library Manager  to Rebuild Your iPhoto Library


    1 - download iPhoto Library Manager and launch.


    2 - click on the Add Library button, navigate to your Home/Pictures folder and select your iPhoto Library folder.


    3 - Now that the library is listed in the left hand pane of iPLM, click on your library and go to the File ➙ Rebuild Library menu option.


    4 - In the next  window name the new library and select the location you want it to be placed.


    5 - Click on the Create button.


    Note: This creates a new library based on the LIbraryData.xml file in the library and will recover Events, Albums, keywords, titles and comments.  However, books, calendars, cards and slideshows will be lost. The original library will be left untouched for further attempts at fixing the problem or in case the rebuilt library is not satisfactory.

  • Old Toad Level 10 Level 10 (113,125 points)
    Currently Being Moderated
    Jun 29, 2013 9:40 AM (in response to sflomenb)

    I'm out of suggestions.  Create a topic in the ICloud community, post your problem there and give a link here so responders will know what's altready been tried.

  • phatty82 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Oct 28, 2013 5:57 PM (in response to sflomenb)

    i had a similar problem - that a new iphone was populating image into photostream, but that those weren't importing into iphoto. the older iphone worked fine.


    i'm on mavericks, deleted the plist file, rebuild the photo library and all the new iphone images immediately imported.




More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.