3 Replies Latest reply: Jan 17, 2015 8:45 AM by Cliff85
chuckhendo Level 1 Level 1 (0 points)

We purchased a 2012 27" iMac at work which I connected to a 23" cinema display via a MDP->DVI adapter. It worked for a while, but then stopped working 1 day. Thinking it was the monitor or the adapter, I connected a 27" cinema display with a direct MDP connection - still didn't work.

 

After doing the typical SMC/PRAM reset, I noticed that in System Information under thunderbolt it said "Thunderbolt:          No hardware was found." I also noticed that the App Store listed a Thunderbolt Firmware Update 1.2. So, I updated that, restarted, it flashed the progress bar for a second but didn't move before restarting again and booting. The firmware update was still listed in the app store.  I tried downloading the DMG for the update on the Apple Download site, install seemed to go well, but did not install.

 

Then I found this: http://support.apple.com/kb/TS4579. I ran through that process (also reset SMC/PRAM again). Still no go. After calling Apple support, they recommended that I reinstall OS X. Still didn't work after that. I called back today, and apparently my only option is to carry it to the closest Apple Store, which is an hour and a half away (we have a closer authorized dealer, but they are closed until July 8th for some reason). I also asked if they could send a box so I could ship it and they said that wasn't an option.

 

Is there anything else I can do without having to wait until July 8? I am extremely disappointed with Apple right now, and I'm hoping I can get this resolved without having to run all over the place.


iMac, OS X Mountain Lion (10.8.4)