Previous 1 2 Next 16 Replies Latest reply: Oct 21, 2013 4:47 AM by bd_4
bd_4 Level 1 Level 1 (0 points)

I'm getting "iPhoto quit unexpectedly" every time i try to open iPhoto

 

I've tried deleteing the preferences stored at ~/Library/Preferences/com.apple.iPhoto, deleting the cache file at ~/Library/Caches and using iPhoto Library Manager to rebuild the library but none of the above have made a difference

 

The crash report i receive is as follows:

 

Process:         iPhoto [391]

Path:            /Applications/iPhoto.app/Contents/MacOS/iPhoto

Identifier:      com.apple.iPhoto

Version:         9.4.3 (9.4.3)

Build Info:      iPhotoProject-720091000000000~1

App Item ID:     408981381

App External ID: 15017489

Code Type:       X86 (Native)

Parent Process:  launchd [191]

User ID:         501

 

 

Date/Time:       2013-06-29 13:51:55.698 +0100

OS Version:      Mac OS X 10.8.4 (12E55)

Report Version:  10

 

 

Interval Since Last Report:          652 sec

Crashes Since Last Report:           3

Per-App Interval Since Last Report:  9 sec

Per-App Crashes Since Last Report:   3

Anonymous UUID:                      CBB17F1A-DCC0-84BC-8999-AF69106EB809

 

 

Crashed Thread:  0  Dispatch queue: com.apple.main-thread

 

 

Exception Type:  EXC_BREAKPOINT (SIGTRAP)

Exception Codes: 0x0000000000000002, 0x0000000000000000

 

 

Application Specific Information:

*** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[NSDocumentController setIgnoreMissingOnce:]: unrecognized selector sent to instance 0x7c09b140'

 

 

Application Specific Backtrace 1:

0   CoreFoundation                      0x92bd8e8b __raiseError + 219

1   libobjc.A.dylib                     0x99c4b52e objc_exception_throw + 230

2   CoreFoundation                      0x92bdcafd -[NSObject(NSObject) doesNotRecognizeSelector:] + 253

3   CoreFoundation                      0x92b24e87 ___forwarding___ + 487

4   CoreFoundation                      0x92b24c32 _CF_forwarding_prep_0 + 50

5   iPhoto                              0x000face8 iPhoto + 72936

6   AppKit                              0x9121e72b -[NSCustomObject nibInstantiate] + 397

7   AppKit                              0x911fe495 -[NSIBObjectData instantiateObject:] + 310

8   AppKit                              0x911fdbb2 -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 317

9   AppKit                              0x911dc472 loadNib + 373

10  AppKit                              0x911dba94 +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] + 819

11  AppKit                              0x911db66f -[NSBundle(NSNibLoading) loadNibNamed:owner:topLevelObjects:] + 256

12  AppKit                              0x911db3fc +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 418

13  AppKit                              0x911d7398 NSApplicationMain + 447

14  iPhoto                              0x000f90b9 iPhoto + 65721

15  iPhoto                              0x000f8705 iPhoto + 63237

 

 

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread

0   com.apple.CoreFoundation                0x92bd96a7 ___TERMINATING_DUE_TO_UNCAUGHT_EXCEPTION___ + 7

1   libobjc.A.dylib                         0x99c4b52e objc_exception_throw + 230

2   com.apple.CoreFoundation                0x92bdcafd -[NSObject(NSObject) doesNotRecognizeSelector:] + 253

3   com.apple.CoreFoundation                0x92b24e87 ___forwarding___ + 487

4   com.apple.CoreFoundation                0x92b24c32 _CF_forwarding_prep_0 + 50

5   com.apple.iPhoto                        0x000face8 0xe9000 + 72936

6   com.apple.AppKit                        0x9121e72b -[NSCustomObject nibInstantiate] + 397

7   com.apple.AppKit                        0x911fe495 -[NSIBObjectData instantiateObject:] + 310

8   com.apple.AppKit                        0x911fdbb2 -[NSIBObjectData nibInstantiateWithOwner:topLevelObjects:] + 317

9   com.apple.AppKit                        0x911dc472 loadNib + 373

10  com.apple.AppKit                        0x911dba94 +[NSBundle(NSNibLoading) _loadNibFile:nameTable:withZone:ownerBundle:] + 819

11  com.apple.AppKit                        0x911db66f -[NSBundle(NSNibLoading) loadNibNamed:owner:topLevelObjects:] + 256

12  com.apple.AppKit                        0x911db3fc +[NSBundle(NSNibLoading) loadNibNamed:owner:] + 418

13  com.apple.AppKit                        0x911d7398 NSApplicationMain + 447

14  com.apple.iPhoto                        0x000f90b9 0xe9000 + 65721

15  com.apple.iPhoto                        0x000f8705 0xe9000 + 63237

 

 



MacBook Pro (15-inch Mid 2012), OS X Mountain Lion (10.8.4)
  • léonie Level 9 Level 9 (63,925 points)

    Does iPhoto launch, when you create a new iPhoto Library and import a few images?

    Launch iPhoto while holding down the options-key ⌥ and select "Create New".

     

    Does that work, or can you not even create a new library?

     

    If you cannot create a new library, does iPhoto launch from a different user account?

    See Isolating an issue by using another user account

     

     

    Léonie

  • bd_4 Level 1 Level 1 (0 points)

    I get the same error when holding the option+command key or just the option key - Is it possible to create a new library without opening iPhoto?

     

    I also tried logging in under a guest account - when i launched iPhoto it crashed in the same way..

     

    Thanks for your response

     

    Ben

  • LarryHN Level 9 Level 9 (61,245 points)

    That implies that you need to reinstall iPhoto

     

    LN

  • bd_4 Level 1 Level 1 (0 points)

    i've tried re-installing iPhoto from the App Store - i'm still experiencing the crash

     

    Thanks for your response

    Ben

  • Terence Devlin Level 10 Level 10 (128,850 points)

    If re-installing didn't fix it then you need to reinstall the OS.

  • Old Toad Level 10 Level 10 (121,345 points)

    On the long shot that it's a damaged preference file that is causing the crash try the following: Try the following:

     

    1 - delete the iPhoto preference file, com.apple.iPhoto.plist, that resides in your

         User/Home/Library/ Preferences folder.

     

    2 - delete iPhoto's cache file, Cache.db, that is located in your

    User/Home/Library/Caches/com.apple.iPhoto folder (Snow Leopard and Earlier).

     

    home.PNG

     

    or with Lion and Mt. Lion from the User/Library/Containers/com.apple.iPhoto/
    Data/Library/Caches/com.apple.iPhoto
    folder

     

    iP11mtlioncache.png

     

    3 - launch iPhoto and try again.

     

    NOTE 1: If you're moved your library from its default location in your Home/Pictures folder you will have to point iPhoto to its new location when you next open iPhoto by holding down the Option key when launching iPhoto.  You'll also have to reset the iPhoto's various preferences.

     

    NOTE 2:  In Lion and Mountain Lion the Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and hit the Enter button - 10.7: Un-hide the User Library folder.

     

     

    OT

  • léonie Level 9 Level 9 (63,925 points)

    Ben,

    before reinstalling MacOS X you could do one more easy test - try to lauch iPhoto in Safe Mode. That will disable all non-standard extensions. If iPhoto runs in Safe Mode, it will be an indication that you installed some incompatible extensions that need removing.

     

    Mac OS X: What is Safe Boot, Safe Mode?

     

    Mac OS X: Starting up in Safe Mode

  • Peter Blackburn Level 1 Level 1 (25 points)

    Thanks for this helpful list of things to check.

     

    I upgraded from 10.6 to 10.8 a few weeks ago and this is the first time I have opened iPhoto. Long ago I transferred the iPhoto library onto an external disk, which has always worked flawlessly.

     

    The User/Library/Containers/com.apple.iPhoto/Data/Library/Caches/com.apple.iPhoto folder did not even exist on my drive, clearly a feature that the upgrade did not handle well. Not terribly impressive on Apple's part.

     

    I have deleted the od pref and cache files, but iPhoto still crashes when I try to open its library on the external disk.

     

    So, an issue after the upgrade 10.6 to 10.8 using an external disk to store photos.

     

    Is this worth reporting to Apple?

    --

    pqb

  • Old Toad Level 10 Level 10 (121,345 points)

    As a test launch iPhoto with the Option key held down and try to create a new, test library.  Can you? If so import a couple of photos, close and open iPhoto. Any improvement?

  • Peter Blackburn Level 1 Level 1 (25 points)

    There is a library on the internal disk with a few photos and this opens normally. But the external library does not. iPhoto quits shortly after it has opened. I tried opening holding Option key and then selecting the external library.

     

    Would an upgrade to iPhoto 11 cure this? Should it be necessary?

     

    TIA for any further help.

  • Terence Devlin Level 10 Level 10 (128,850 points)

    Upgrading will rarely fix  library issue.

     

    What format is the external?

  • Peter Blackburn Level 1 Level 1 (25 points)

    Mac OS Extended journaled, same as the computer.

  • Terence Devlin Level 10 Level 10 (128,850 points)

    Can you create a new Library on that external?

  • Peter Blackburn Level 1 Level 1 (25 points)

    Yes, that works.

     

    I suppose from there I can import the photos from the old library.

     

    Another path would be to ditch iPhoto altogether and try another app.

     

    Curiously enough the plist mentioned by Old Toad was not in the location shown. This may be a legacy of 10.5 and 10.6 which I was running earlier on this computer.

     

    Thanks for continuing dialogue.

Previous 1 2 Next