3 Replies Latest reply: Jun 30, 2013 5:28 AM by arthur
aapl.crox Level 1 (0 points)

For some reason my Sent folder in my exchange account is not showing mail from older than 3 weeks. I've tried clicking on "synchronize" and it doesn't work. I've tried deleting the account and readding it, same thing. I can see fro my online outlook access that there are a lot more mail in the Sent folder. How do I make Mail redownload everything from exchange?

  • arthur Level 5 (5,145 points)
    1. check Mail > Preferences > Accounts > Mailbox Behaviors and see what your setting is for "Delete sent messages when"
    2. try rebuilding the mailbox (Mailbox menu, Rebuild)
  • aapl.crox Level 1 (0 points)

    1) Never.

    2) Same number of emails after rebuild

  • arthur Level 5 (5,145 points)
    1. Maybe the preferences file is corrupt. You could try deleting it:
      1. hold down the option key
      2. in the Go menu in the Finder, go to Library
      3. in Library, go to Containers/com.apple.mail/Data/Library/Preferences and drag it to the trash
      4. restart
      5. you will have to reenter your preferences
      6. maybe do that and then rebuild the mailbox again.