4 Replies Latest reply: Jul 2, 2013 8:05 AM by Peter R.
Peter R. Level 4 (1,190 points)

I had this problem two years ago; now it's back:


My Macs are constantly changing their IP addresses (alert: "There is another machine with the IP address" etc.) and names ("there is already a computer named iMac; it is renamed to iMac (3)"). This occurs during work but also when I open my MacBook in the morning and wake it from sleep. The alert is already on the screen.


How can I stop this???


Thanks a lot for a good idea!

  • Ivan H Level 1 (5 points)

    On your Mac:

    Try Systems Preferences > Show All > Network > tab (TCP/IP), change Configure IPv4 from Using DHCP to Using DHCP with manual Address and give your favourite / allocated IP address;


    On the Router:

    Reserve the favourite / allocated IP address for your Mac.

  • Barney-15E Level 8 (45,240 points)

    Are you connecting both with Ethernet and WiFi? You will sometimes get that if you do.


    Ivan's is a good suggestion, but you should only need to reserve the IP address for a specific MAC address. You don't have to set up a manual IP on your Macbook. When your MacBook seeks an IP, it is given the the one that is reserved for the MAC address.

    Setting that up would be specific to your router. If you need help, post the make and model of your Router.

  • Ivan H Level 1 (5 points)

    Not all routers support "IP Address Reservation", e.g. Belkin's.  If a router restarts or repair, the IP Addresses will be re-assigned if DHCP service is on.  If, for example, a printer is on and the Mac is off, and the Mac's original IP Address is taken by the printer, then the Mac will later get a new IP when it turns on. 


    Barney's reminder is right. You only set a manual IP on your MacBook in trouble, not every Mac.  It gives you a peace of mind to go back to work and buy time to do a detail IP diagnosis / planning for the network.  In the example above, you may still get the IP conflict because your Mac is trying to get the same old IP as the printer has already got.


    Also, IMHO, avoid connnecting Ethernet and Wi-Fi to the same Mac and the same Router at the same time unless you're knowledgeable in IP.

  • Peter R. Level 4 (1,190 points)

    Thanks a lot, all!

    I have solved the issue be completely resetting the rooter to factory defaults.