1 2 Previous Next 28 Replies Latest reply: Jun 11, 2014 10:36 AM by sjlarson650 Branched to a new discussion.
pnewcomb Level 1 Level 1 (0 points)

I have an Epson XP-400 printer and am having trouble getting anything to print over the Wifi connection (I've already contacted Epson and they're saying it's probably an issue with OS X). The printer queue keeps telling me "The printer is not connected". I've gone through the whole wifi setup, and have gotten it to print in the past just fine, but whenever the printer goes to sleep, it ceases to wake up when I tell it to print. I have to manually go upstairs and hit the power button. But even then, it takes another minute or two to finally decide to print the thing. It's a huge pain in the butt...

 

Is this an issue with how my settings are configured inside OS X?


MacBook Air, Mac OS X (10.7.2)
  • 1. Re: Epson Printer Not Working Over WIFI
    Joe Bailey Level 6 Level 6 (12,095 points)

    When you go to System Preferences > Print and Scan does your Epson show up? Does it appear in the list of available printers when you click on the plus sign at the bottom of the window?

  • 2. Re: Epson Printer Not Working Over WIFI
    pnewcomb Level 1 Level 1 (0 points)

    Yes it shows up with a green light and "Idle, Default". But when I click on the plus, it does not show up. Should it if it's already added?

  • 3. Re: Epson Printer Not Working Over WIFI
    Steve_V Level 1 Level 1 (5 points)

    Has this just happened ?

    Both my brother's two HP printers and my 1 HP printer started doing this about  1 to 2 weeks ago after using them for 2 years without a problem !

     

    I was wondering if one of the recent mountain lion updates has caused this issue  eg the Airport Update.

    I tried connecting by USB and everything is fine, it's only over Wifi that there is an issue.

    Strangely it seems to have corrected itself now and so has my brothers. Very odd problem though especially as we both had the same issue at the same time and both cleared up within a day or two.

     

    We both had the same message as yourself and the Green Lights were on in Printers Prefs.

     

    Also the HTML page would not load using IP address due to the connection issue, as you would expect.

  • 4. Re: Epson Printer Not Working Over WIFI
    pnewcomb Level 1 Level 1 (0 points)

    Well this is weird. It just worked all of a sudden last night, from the printer being in a sleep state. I didn't change anything at all. Now this morning it doesn't work again. What the heck is going on?

  • 5. Re: Epson Printer Not Working Over WIFI
    Joe Bailey Level 6 Level 6 (12,095 points)
    I was wondering if one of the recent mountain lion updates has caused this issue  eg the Airport Update.

     

    The recent updates were to the Airport Utility which is only used to configure Apple Airport base stations such as Airport Express, Time Capsule, and Airport Base Station and an update to the firmware in the Airport base stations. There was also a recent update to the Canon printer drivers. So unless you actually ran Disk Utility and changed the configuration and/or updated the base station firmware they would have no effect on your printer connectivity.

     

    You may be encountering WiFi network interference from other WiFi networks on the same or adjacent channels. There are a number of apps that will analyze your local WiFi network environment, If you do not have one there are some available at reasonable cost from the App Store. There are several free apps but they only show your particular WiFi signal. You need one that shows ALL the network activity in your environment. WiFi Radar is one that will do nicely. If you find another network on the same or adjacent network channels when the printer quits working configure your wireless router/base station to work on another channel. That may solve your problem.

     

    Message was edited by: Joe Bailey

  • 6. Re: Epson Printer Not Working Over WIFI
    Eric Root Level 6 Level 6 (16,165 points)

    Have you tried shutting down the printer and then restarting it? Information.

     

    Network Printer Troubleshooting

     

    WiFi Printer to WiFi Network - Connect

  • 7. Re: Epson Printer Not Working Over WIFI
    pnewcomb Level 1 Level 1 (0 points)

    I've been having this issue for more than a month actually, so I don't think it's any latest updates causing the problem. I'm just now getting around to dealing with it. And it's an Epson, not a Canon.

     

    I've already analyzed the network and change the channel multiple times, but still have the issue.

  • 8. Re: Epson Printer Not Working Over WIFI
    pnewcomb Level 1 Level 1 (0 points)

    Yes.

  • 9. Re: Epson Printer Not Working Over WIFI
    san.sev Level 1 Level 1 (0 points)

    I experienced something similar and fortunately solved, please check:

     

    https://discussions.apple.com/thread/5149783?start=0&tstart=0

  • 10. Re: Epson Printer Not Working Over WIFI
    pnewcomb Level 1 Level 1 (0 points)

    Thanks sans, but I tried using epson webnavi to setup the printer and it wouldn't recognize my printer during installation. Apparently I'm having a different issue than you. You have a xp-400 correct? Also, you said in your other thread that you just started having this issue in early july with mountain lion 10.8.4, but I've been having this issue since april...

  • 11. Re: Epson Printer Not Working Over WIFI
    Eric Root Level 6 Level 6 (16,165 points)

    If you can hook the printer up by USB will it print? Try deleting the printer and adding it back.

     

    Reset Printing System

  • 12. Re: Epson Printer Not Working Over WIFI
    pnewcomb Level 1 Level 1 (0 points)

    Yes it prints via usb, but it also prints via wifi. As I stated in my original post, the issue only happens after the printer goes to sleep.

  • 13. Re: Epson Printer Not Working Over WIFI
    Eric Root Level 6 Level 6 (16,165 points)

    When hooked up by USB, if you put the computer to sleep, will it print when you wake it? I was trying to figure out if this is a WiFi only problem or if you get the same thing to happen with USB. I did understand your original post.

  • 14. Re: Epson Printer Not Working Over WIFI
    pnewcomb Level 1 Level 1 (0 points)

    Sorry for the late reply Eric, yes it does wake up and print properly when the usb cable is plugged in. It only happens (or doesn't happen...) when it's a wifi connection.

     

    I must admit this is getting pretty frustrating. Is there a way I can contact apple directly about this? I don't have apple care or anything like that.

1 2 Previous Next