4 Replies Latest reply: Jul 2, 2013 2:20 PM by Linc Davis
ukscribbler Level 1 Level 1 (0 points)

I have a Toshiba Ext 1TB Drive which I'm trying to use with my Macbook Pro Retina - fully upto date etc - I have formatted the drive several times as exFAT32 etc and it fials to show.  I took the drive around to my friends and the drive showed instantly on his desktop Mac, I re-formatted it on there as exFat32 and copied some data across, getting home and plugging the drive into my Macbook, the drive still fails to show up on either the desktop or in the Disk Utilities, this is the first Mac I've owned myself, so assume I'm missing a simple trick or something.  Data cable is fine, and the HD lights up, whirrs etc...  Kinda stumped.


MacBook Pro with Retina display, OS X Mountain Lion (10.8.4)
  • ukscribbler Level 1 Level 1 (0 points)

    That should read exFat not exFat32. Oops!

  • Linc Davis Level 10 Level 10 (154,445 points)

    If the drive has more than one interface (USB, FireWire, Thunderbolt, eSATA), try one of the other interfaces.

    Check that the data cable is securely inserted at both ends.

    Try a different cable.

    If you're connecting the drive through a hub, connect it directly to a built-in port on the Mac.

    If you're connecting it directly, try a different port.

    Disconnect all other devices on the bus, or as many as possible.

    Test the drive with another Mac. Test another drive with this Mac.

    If the drive is bus-powered, but has an AC adapter, connect the adapter.

    Boot into Recovery and launch Disk Utility. Is the drive recognized?

    Start up in Safe Mode and test.

    Reset the System Management Controller

  • ukscribbler Level 1 Level 1 (0 points)

    If the drive has more than one interface (USB, FireWire, Thunderbolt, eSATA), try one of the other interfaces. - Nope, just USB

    Check that the data cable is securely inserted at both ends. - ...

    Try a different cable. - already have.

    If you're connecting the drive through a hub, connect it directly to a built-in port on the Mac. - on a Macbook

    If you're connecting it directly, try a different port. - already have

    Disconnect all other devices on the bus, or as many as possible. - none on there

    Test the drive with another Mac. Test another drive with this Mac. - yeah, in the post.

    If the drive is bus-powered, but has an AC adapter, connect the adapter. - it's not

    Boot into Recovery and launch Disk Utility. Is the drive recognized? - Nope

    Start up in Safe Mode and test. - Again, nothing

    Reset the System Management Controller - seems a bit drastic, gonna hold off on this a while...

    Thanks, but still nothing.

  • Linc Davis Level 10 Level 10 (154,445 points)

    It's not clear whether you tested another drive, but I'll assume that you did, and that it worked. I'm also assuming that the drive is not bus-powered; that is, it always gets power from an AC adapter.

     

    If the problem drive still isn't recognized after you reset the SMC (which is not "drastic"), then it's either faulty or incompatible at the firmware or hardware level. Check with the manufacturer for a firmware update, or use another drive.