Skip navigation

Can't change clip speed

394 Views 5 Replies Latest reply: Jul 12, 2013 7:07 AM by Michael Grenadier RSS
Roxane Assaf Calculating status...
Currently Being Moderated
Jul 4, 2013 6:50 AM

Hope this is the right community.  I used to simply post to Final Cut Pro.  I got schooled once in recent years and don't quite know where to be now.  I'm trying Final Cut Studio.  Let me know if this is also wrong.


I'm using Final Cut Pro 7.0.3


I have some clips that I've successfully sped up before.  Now I'd like to speed them up some more.  What I did last time when I bumped into problems in my project timeline was to take the clip to a fresh sequence tab and work on it there, then copy it back to my project.  Worked perfectly.


Now I get an error message every time I try to change the percentage and click okay on the change speed function.  Doesn't matter if I'm working in a clean sequence with no other media around.


Thanks for your help.


MacBook Pro, Mac OS X (10.7.5), Final Cut Pro 7.0.3, iDVD, LiveType


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.