1 Reply Latest reply: Jul 4, 2013 11:57 PM by BDAqua
Chef Liz Level 1 (0 points)

I cannot download foxfire or mozilla because ot telling me it has been discontinue for mac osx 10 5 8 and that it was reported to apply but I do not remember receiving an update from apple. I should not have to pay for an error of a product that was issue a later and not get the update free. It telling me that I have to buy the 10.6 version and download it to be compatible to run my adobe and other app


iMac, Mac OS X (10.5.8)