1 Reply Latest reply: Jul 6, 2013 12:48 AM by seventy one
Damitrius Level 1 Level 1 (0 points)

Hi,

When I try to download the 10.5.8 update it tells me that i do not have "appropriate access privileges" to do so. I'm trying to install Sims 3 for my little brother but am running 10.5.2 and the game requires 10.5.3... Please I need help as soon as possible


PowerMac, Mac OS X (10.5.2)