Previous 1 2 Next 26 Replies Latest reply: Nov 4, 2013 4:20 PM by steno1
Fedux Level 1 Level 1

Finder "Search" isn't searching anymore in ~/Library/Preferences !!!

I don't know what happened but I used to have a saved search in Finder sidebar that searched in All HDD for All files, system and invisible included. I used it for complete uninstalling of programs and for being sure to have a very clean Mac.

Now, if I want to delete .plist files related to one program I have to enter that directory and search directly inside it, searching All HDD searches everywhere but that folder….! I'm going crazy.


I tried:

  • reindexing HDD
  • delete
  • repair permissions


Using a program like "Easyfind" I can find everything as usual, but I don't want external programs for doing something Finder could perfectly do before!

  • léonie Level 10 Level 10
    Photos for Mac

    Have you set the Finder to search "This Mac"?


    Check the Finder's preferences in the "Advanced" panel:

    Screen Shot 2013-07-07 at 13.17.04MESZ.PNG

    And to prevent "plist" files from being excluded, add a search rule: "Kind is Other > Property List"  or "File Extension is plist"

    Screen Shot 2013-07-07 at 13.19.33MESZ.PNG

    For me this finds all property lists.



    Start the search from the hidden Library folder and save this search.

  • Fedux Level 1 Level 1

    Everything is correctly set up but it didn't search inside that specific folder: ~/Library/Preferences.

    It seems like there's a special rule for that...

    I also tried to add this folder to the privacy tab in Spotlight and then to remove it, to force reindexing only for that folder, but nothing happened.


    Everything has always worked, I don't know what I did to make it stop!

  • léonie Level 10 Level 10
    Photos for Mac

    If I start the search from within the hidden "Library", the .plists in Preferences are listed.

    Screen Shot 2013-07-07 at 14.12.47MESZ.PNG


    I'd try to reindex your Spotlight index:


  • Fedux Level 1 Level 1

    Thanks for your assistance, you're very kind!


    I already tried what you suggest but it had no effect. Here's an example of what I'm experiencing:

    Schermata 2013-07-07 alle 14.25.01.png

    Inside the specific folder I can find it


    Schermata 2013-07-07 alle 14.25.06.png

    Outside and  with all the same criteria, it doesn't find anything!

  • léonie Level 10 Level 10
    Photos for Mac

    I just noticed - I reindexed the Library folder, and after reindexing Spotlight "~/Library/Preferences." does not work any longer on my mac either I cannot see, what is keeping this folder from being indexed in the latest version.

    Until an hour ago, the Preferences folder did show in the Finder search. Just like you are reporting, only the Preferences folder is excluded all of a sudden.

    As a workaround, while we are searching for a solution - how about adding ~/Library/Preferences to the Finder's sidebar? Drag the folder directly below the heading "Favorites (Preferiti) in your sidebar and you have always easy access to start your search from there.

  • Barney-15E Level 8 Level 8

    Take a look at this:


    You might need to modify the _rules.plist to INCLUDE the prefs folder or remove the entry from the EXCLUDES.


    Edit: However, I don't see this file anywhere.

  • Fedux Level 1 Level 1

    Oh my god! I'm sorry I indirectly caused this issue to you! This make me think is a 10.8.4 bug on indexing....


    I'll take a look to Barney's link....

  • Fedux Level 1 Level 1

    It does seem you can no longer open this folder... I also tried with "sudo cd /.Spotlight-V100", but no results... Also it seems that "_rules.plist" doesn't exist...

    Maybe something changed since 10.4.0, Tiger... I remember it was a great SO, the first complete OsX.

  • léonie Level 10 Level 10
    Photos for Mac

    No problem, Fedux!

    Barney's link looks really promising, but I do not see the file in the directory:


    sudo cd /.Spotlight-V100/

    dreschle$ sudo ls -laix .Spotlight-V100/







    Now we have a new search problem - where has _rules.plist gone to?

  • Fedux Level 1 Level 1

    Maybe something changed in spotlight with the new Os's...

    It would be nice to know if this is a common problem with Osx 10.8.4...

  • Barney-15E Level 8 Level 8

    Now we have a new search problem - where has _rules.plist gone to?

    I've been looking since I posted. I'm about to give up. Probably not using the right search terms, or nobody has looked at it since Tiger.

  • Fedux Level 1 Level 1

    Updated system to 10.8.5 but it didn't fixed anything... I only notice Finder still has 10.8.3 version...


    Schermata 2013-09-13 alle 22.02.07.png

  • Old Toad Level 10 Level 10
    Photos for Mac

    Try unhiding the library as follows:


    NOTE: In Lion and Mountain Lion the Home/Library folder is now invisible. To make it permanently visible enter the following in the Terminal application window: chflags nohidden ~/Library and press the Return key - 10.7: Un-hide the User Library folder.  Will have to be reapplied after any major update or upgrade.


    I'm able to search my ~/Library with a Command + F search or with the Spotlight search window in the menu bar.



  • Fedux Level 1 Level 1

    Thanks for replying but I think you didn't understand the problem... I made home folder visible since Lion was released but here the problem is that it's impossible to search for files stores under the path above even adding the right criteria to finder search tab... I always used it and never had such problem... Right now I'm trying to reindex spotlight from terminal with mdutil command... Hope to solve it... I'll keep you informed. Thank you very much!

Previous 1 2 Next