Previous 1 2 Next 27 Replies Latest reply: Mar 11, 2015 12:49 PM by Chris CA Branched to a new discussion.
gottabook Level 1 (0 points)

Hi all, I thought I would add this here because it took a number of hours of digging and working with people from both Apple and Samsung too resolve. I did post most of this information as a response in a thread about this issue but cleaned up the links and thought it would be helpful to have it in Messages are under the Tips section and thus am posting it here for better visibility and discovery.

 

After 14 days, I almost turned my new Galaxy S4 back into BestBuy tonight due to a persistent issue of being unable to disable iMessage such that I was recieving replies to texts that I sent to friends, however their replies would go to my old iPhone or iPad. My friends who had previously communicated with me over imessage had to turn off their own iPhone's iMessage in order for me to be able to receive texts from them on my new Android phone. I visited the Apple store the night before and they got me halfway to fixing the problem by following step number 1 below. Today, I went to a BestBuy location that has a Samsung "store in store" concept in East Plano, TX and the Samsung guy got online to chat with other Samsung technicians about this issue. Here is the link to a 9 page document that goes through a number of steps how to deactivate iMessage and get texts on your Android (while still maintaining iMessage on any other Apple devices that you might still have, if you so desire): http://bit.ly/iMessageproblem

 

If the link doesn't work for some reason, shorten the url to get to the Samsung support page at http://www.samsung.com/us/support/ or some variation of that and type the following in the search boxin the upper right hand corner in the support section "deactivate iMessage on iPhone" in the search box in the upper right hand corner of Samsung's support pages until it gets you to the support document titled "How do I turn off iMessage on my old iPhone before I switch to my new Samsung device?" Don't worry that you aren't going through those steps before setting up your Android or that it specifies Verizon or Galaxy Tab- this seems to be a generic issue when one moves from iPhone to Android, regardless of carrier or Android model! Most of us didn't know there was an issue until well after we were into setting up our new Android phone. I used these steps and they fixed the problem. I did have to enter the model number of the Android I am using (Galaxy S4, SGH i337) to get to the pages supplied to me from the chat session at the Samsung store in BestBuy.

 

The long and short of my fix was 1) going to my iphone Settings under "Messages" and assuming iMessage is set to "on" scroll down to where it says "Send & Receive" and click on that. It showed my phone number along with other email and Apple related addresses. Deselect the phone number now associated with my Android device as well as any email messsages from which I didn't want to send/receive iMessages (in my case I still want to receive iMessages at email addresses associated with my iPad and MacBook). After doing those steps, close out of Settings.

 

Then 2) go to the itunes/apple page and change your password at the following page: https://appleid.apple.com

 

When you change the password on your account it supposedly deauthorizes the phone number and other addresses just deselected addresses from iMessage.

 

There are some other steps in between that you may need to take and are listed on the support page but hopefully that will work for you as it finally did for me.

 

Good luck!

Andrea


iPhone 4, iOS 6.1.4, Disconnecting iMessage
  • seopro Level 1 (0 points)

    I could not communicate with my son for about a week after I upgraded to IOS 7 - Apparently iMessage must have activated on my phone or I somehow turned it on. After reading this page and several others I have decided to turn iMessage off completely.

     

    This is one of those issues where Apple needs to let the user decide how they want to send a message or communicate with another person vs. making the an Apple user have to access a device they may no longer have in their posession for one reason or another.

     

    For all the great things Apple does...this issue is one that does not look like it was thought through completely.

  • Chris CA Level 9 (78,690 points)

    seopro wrote:

     

    I could not communicate with my son for about a week after I upgraded to IOS 7 - Apparently iMessage must have activated on my phone or I somehow turned it on.

    This has nothing to do with why you could not send iMessages unless your son had an iPhone previously, had iMessage set to On and then got a new, non-iOS device and did not deactivate iMessage.

     

    Unless someone has an iOS device or a Mac and has iMessage set to On, you cannot send them an iMessage. It will ONLY send as an SMS.

  • p413943 Level 1 (0 points)

    Thanks so much for the info, I have the same exact problem, except I already cleared my iphone and returned it through the apple program, so I don't have it with me to disable imessage, and am still not getting messages from friends/family. Any help or ideas that do not require having the old iphone on hand?

  • p413943 Level 1 (0 points)

    Nevermind I found the bottom part of your link for if you no longer have the device, hopefully that works!

  • Corvette-07 Level 1 (0 points)

    Worked for me too..... Sales persons at AT&T stores need to brush up on this one.

     

    Thanks for investing all that time for us

  • robertokeywest Level 1 (0 points)

    Oh my god!!, thank you SO, SO much!!

     

    I'm actually pretty ****** at apple. After 10 years of being a loyal customer with sprint, I finally told them to take a hike. I paid extra for '4G' for 3 years or more...'it'll be in hour area soon' was their ******** reply. Anyway, I recently switched to tmobile and traded my iPhone for a galaxy. Your advice worked perfectly, so now, I actually get all my texts from friends with iPhones...what a concept!!!!

     

    Thanks again!!!

     

    Rob o

  • tanzeelafromca Level 1 (0 points)

    Hi gottabook,

     

    I don't have my iphone with me anymore. I traded it with sprint last week to get this samsung phone. is there any way i can turn the imessage option off?

     

    Any help would be appreciated!

  • racheypooh Level 1 (0 points)

    When I talked to apple support they said to reset my apple id password and that would work but it may take up to 24 hours before it works. I just did it so I can't say for sure whether or not its working.

  • Elainefromsd Level 1 (0 points)

    I can't get the link to work and when I search on the Support page there are thousand of entries ... any easier way to find the article rather than paging through thousands of pages?

  • dannysayso Level 1 (0 points)

    can anyone repost a link to the information. the link is dead and i searched but couldnt find it thru samsung

     

    thanks

  • p413943 Level 1 (0 points)

    It amazes me how many of you reply to this with a 100% useless response

  • bossodg Level 2 (265 points)

    The best part is that apple has a way to help with this if you call apple care. And they have it resolved in less then 24 hours....

  • bossodg Level 2 (265 points)

    Danny call applecare they will send you a text with in 5 minutes u are done. I did it earlier today

  • Elainefromsd Level 1 (0 points)

    What is the phone # for Apple Care and is there a charge?

Previous 1 2 Next