0 Replies Latest reply: Jul 9, 2013 4:24 PM by rsdio
rsdio Level 1 (20 points)

I am running Tiger Server 10.4.11 on a dual G5 Xserve Cluster Node and have successfully compiled and run several open-source Unix sources.


I downloaded passwordserver_sasl-59.4 from the Apple web site but have been unable to compile it on Tiger Server.



A) If I run 'make' from the top directory, the build fails with the following text at the end:


configure: configuring in saslauthd

configure: running /bin/sh '/Users/admin/src/passwordserver_sasl-59.4/cyrus_sasl/saslauthd/configure' --prefix=/usr  '--prefix=/usr' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--disable-dependency-tracking' '--includedir=/usr/local/include' 'CFLAGS=-arch ppc -arch ppc64 -g -Os -pipe ' 'LDFLAGS=-arch ppc -arch ppc64 ' --cache-file=.././config.cache --srcdir=/Users/admin/src/passwordserver_sasl-59.4/cyrus_sasl/saslauthd

configure: loading cache .././config.cache

configure: error: `LDFLAGS' has changed since the previous run:

configure:   former value:  -arch ppc -arch ppc64           

configure:   current value: -arch ppc -arch ppc64

configure: error: changes in the environment can compromise the build

configure: error: run `make distclean' and/or `rm .././config.cache' and start over

configure: error: /bin/sh '/Users/admin/src/passwordserver_sasl-59.4/cyrus_sasl/saslauthd/configure' failed for saslauthd


I won't dump the entire make output here, but some other interesting bits and pieces are:


/Users/admin/src/passwordserver_sasl-59.4/cyrus_sasl/config/missing: Unknown `--run' option

Try `/Users/admin/src/passwordserver_sasl-59.4/cyrus_sasl/config/missing --help' for more information

configure: WARNING: `missing' script is too old or missing



B) Alternatively, if I run './configure' from the cyrus_sasl subdirectory, it seems happy, saying:


Configuration Complete. Type 'make' to build.


... but then 'make' fails with the following:


make: *** No rule to make target `acinclude.m4', needed by `aclocal.m4'.  Stop.



Basically, I'm trying to get working binaries for saslauthd, sasldblistusers2, saslpasswd2, testsaslauthd, which do not seem to be distributed with Tiger Server (unless I somehow lost them since 2006).

Xserve G5 (January 2005), Mac OS X (10.4.11)