Previous 1 2 Next 17 Replies Latest reply: Jun 26, 2014 11:28 AM by archron
zvikico Level 1 (0 points)

I have a MBP retina and I'm using it with an external display, Dell U2711, connected via a Mini-DP to DP cable. It all worked amazingly well until 10.8.4 came out. Now, when I connect the display, it no longer shows the correct 2560 X 1440 resolution, but shows 1080p. The displays preferences pane does not allow going over 1080p. It does recognize the display model, though.


It started with one port. The machine has two TB ports, so one of them worked fine and the other didn't (the one closer to the user was acting up). Then it degraded further to the second port. Now, if I plug and unplug several times and fiddle with the displays control panels, I might just get it right eventually. It takes some time, but eventually the machine gets it right. At least that's what I've been experiencing in the last few days.


I don't think it's a hardware issue. It's possible that my cable is at fault, but I seriously doubt that. I'm wondering if anyone else got the same problem, just checking before I go and splurge on a new cable (these cables are not easy to find).




MacBook Pro (Retina, Mid 2012), OS X Mountain Lion (10.8.4)
  • tristian9 Level 1 (5 points)

    I can verify. Problem first appeared this morning - exactly the same problem with two DELL 2713HM. Unable to get resolution up to 2560x1440. At first with one port, now after hour of testing both ports. Have used these monitors for months without problems. I have ruled out cable and monitor problem. Must be new software or less likely broken MBP Retina.

  • Free 4 Live Level 1 (25 points)

    Have you already tried to reset PRAM and NVRAM or SMC?


    If not: search for the SMC reset on google or Apples Support page (i just can't look for the link right now because it says my computer isn't supported)


    for NVRAM/PRAM:


    shut down your computer

    Press the Start Button and the immediately press "CMD"+"OPTION"+"P"+"R" until the start tone sounds for a second time! release the keys and let your MacBook boot normally. Also try to reboot without the display(s) (and the cables) connected to your MBPr!

  • tristian9 Level 1 (5 points)

    This worked for me:


    Step 1: Delete system windowserver preferences

    1. In the Finder, from the menu bar, select "Go -> Go to Folder..."
    2. Enter: /Library/Preferences/
    3. Delete the file called

    Step 2: Delete user windowserver preferences

    1. In the Finder, from the menu bar, select "Go -> Go to Folder..."
    2. Enter: ~/Library/Preferences/ByHost/
    3. Delete all files that start with   (On my rMBP, there was one file called

    Step 3: Reset the PRAM    (These instructions are from

    1. Shut down your Mac.
    2. Locate the following keys on the keyboard: Command (⌘), Option, P, and R. You will need to hold these keys down simultaneously in step 4.
    3. Turn on the computer.
    4. Press and hold the Command-Option-P-R keys before the gray screen appears.
    5. Hold the keys down until the computer restarts and you hear the startup sound for the second time.
    6. Release the keys.
  • zvikico Level 1 (0 points)

    Thanks for the thorough answer! For the record, I did try to zap the pram before posting the question.


    For some reason, since I posted this, the machine was fine with serveral connect-disconnect events. I'm not sure why, but it seems to be better. I also read several other people complaining about similar problems in 10.8.5. I'll update if the problem persists.


    Thanks again,


  • Mazzlefizz Level 1 (0 points)

    The same problem is occurring for me.  I also just updated to 10.8.4 on my MBP retina (mid 2012), which is hooked up to a Dell U2711 monitor via a displayport cable.  Right now, it seems to only occur with the far back displayport port.


    Unfortunately, your steps did not work for me.


    A couple things of note:

    • I did not even have the file that you listed in the first step.  I was perplexed.
    • I did have a one in the ByHost folder, as well as a lockfile with the same name.  I deleted both.
    • After following your steps, the resolution options did change.  They now only had 2 options: 1080p and 2560x1440.  I was excited.
    • I chose the latter, but it did not actually change the resolution.  I was no longer excited.
    • I switched to the closer displayport port, and it still worked fine.  I was relieved.
    • And then I switched back to the far non-working port.  The display options had gone back to the original list of resolutions that did not include 2560x1440.  I was disappointed.


    Anybody have any other ideas?  I'm really hoping that what Z described in the original post, namely the situation eventually degrading so that neither displayport ports work, will not happen to me also.


    Thanks for posting this!  I'm glad to see I"m not the only one with this issue.

  • Mazzlefizz Level 1 (0 points)

    Is there a way to revert back from 10.8.4 without losing all the work since I updated?

  • Level 1 (0 points)

    I followed the steps provided by tristian9 and it resolved my problems. I have a 15" Retina MacBook Pro connected to two Dell U2711 displays running 10.8.4. My problems did not start immediatly after installing 10.8.4 and only started yesterday when the display connected to the Thunderbolt port (via a mini Displayport to Displayport adapter) nearest to the MagSafe power port was the only one that could display native 2560x1440 resolution. The other port would only display at 1080p. Then today both monitors would only display at 1080p and I couldn't get either of them to display at native resolution.


    Deleting the windowserver preferences and resetting the PRAM (actually NVRAM for Intel) restored native resolution for both of my monitors.  Thanks tristian9!

  • zvikico Level 1 (0 points)

    I did not follow up, since the last couple of months went smoothly, up until this morning. I'm not sure why, but the problem returned today. I tried following the steps outlined by tristian9 , but that did not solve my problem. I tried it twice. The third time I tried it, I also stopped by the disk utility to repair my hd and the permissions. Doing that, combined with the steps outlined solved the problem for me. At least for now.


    So, to sum up, if the above steps does not solve the problem for you, try booting into disk utility (Command-R pressed when starting the machine) and repairing your hd and hd permissions.


    Good luck,


  • zvikico Level 1 (0 points)

    Quick update to those struggling with this issue: it degraded on my machine to a point where non of the steps worked. Simply nothing.


    However, I did find a way to solve it: in the System Preferences → Energy Saver, turn off "Automatic graphics switching". This will force the machine to use the more powerful NVIDIA graphics card rather than the built in Intel. After doing so, disconnect and reconnect the monitor and the problem should be gone. You can turn the graphics switching back on afterwards if you'd like (it does save battary if that's important to you).


    I sure hope Mavearicks comes soon and fixes this issue.

  • tristian9 Level 1 (5 points)

    Now one of the screens started blinking with 2 second intervals - turning on and then off in endless cycles.


    This helped me:

  • ricw Level 1 (0 points)

    This is still occuring on OS X Mavericks. The fix does work. Very disappointing Apple!

  • vinhsane Level 1 (0 points)

    Apple really needs to fix this because it is so annoying for my Dell 2711. Sometimes it works and sometimes it doesn't. I tried deleting the windowsever and it works 20% of the time.

    The windowserver includes the 2560 by 1440 when you view the plist, however the display option is not display for the external monitor.

    I bet the Apple Monitors won't have issues.......

  • Mazzlefizz Level 1 (0 points)

    Yeah, Vin, I have a Dell 2711 too, and I'm still having the issue as well.  None of the above solutions ever worked for me.  Fortunately, plugging in the monitor to the other TB port still works.


    By the way, I do use a 2560x1440 Apple display at work with the same laptop, and it doesn't have this issue.  I also have a 1920x1080 Dell monitor that presents no resolution issues either.

  • Mazzlefizz Level 1 (0 points)

    When I had previously tried the solution posted at, it didn't work for me.  On a whim, I just tried it again, and it worked.  Perhaps I did things slightly differently last time, but here's what worked for me:


    1. Unplug all other monitors except the problem one and restart

    2. Downloaded the script "patch-edid.rb" from  Note that the script is not in the first post.  Here's a direct link:

    3. Deleted the old color profile in /Library/ColorSync/Profiles/Displays.  You'll need to choose the right file for your monitor.  For example, I did:

      sudo rm /Library/ColorSync/Profiles/Displays/DELL\ U2711-000010AC-0000-A057-3145-4A4C00000000.icc

    4. Run the script by executing the following command in a terminal window from the directory you downloaded the script to.

      ruby patch-edid.rb

      For me, this created a folder called "DisplayVendorID-10ac/"

    5. Copy that folder to /System/Library/Displays/Overrides/

      sudo mv DisplayVendorID-10ac/ /System/Library/Displays/Overrides/

    6. Restart

Previous 1 2 Next