10 Replies Latest reply: Jul 11, 2013 5:22 PM by Dick1151
Dick1151 Level 1 Level 1 (0 points)

After successfully editing a half hour project in iMovie '11, I tried to burn a DVD in iDVD, but failed because the media files could not be rendered (?).  Thinking I may have inadvertently specified some parameter incorrectly, I decided to return to iMovie and try again, but follow the suggestions I found elesewhere in these Discussions.

 

As soon as I clicked on Share > iDVD, I recieved a mesage saying "Media Missing" and specifying the name of a folder in which most of the project clips are located. I believe erred when I moved this file duing the last day of editing (I now know that's a no-no), so I used Time Machine to restore that file to its condition on the day before that.  The file name has a apostrophe ( ' ), also probably not a good idea, since I gather iMovie may not like that.

 

Nothing I do seems to eliminate this message, even though the clips are visible in the Event and Project panes.  I have:

 

     Restarted

     Trashed

          com.apple.iMovieApp.plist

          com.apple.iApps.plist

          ....then restarted

     Repaired Permissions

 

Since the clips are all in the Event and Project panes, will the DVD include them, in spite of this message?

 

Dick


iMac, OS X Mountain Lion (10.8.4)
  • JacobQuick Level 1 Level 1 (10 points)

    If your using a school MacBook or something you might have to do it in the school wifi.       Or try restoring iDVD maybe some files are missing

  • AppleMan1958 Level 7 Level 7 (27,395 points)

    I think the apostrophe should be OK.

    For an iMovie Project to work, it needs to be in the Movies/iMovie Projects/ folder. (If it is on an external drive, it should be in the iMovie Projects/ folder at the top level of the drive. The drive must be formatted as Mac OS Extended (journaled) - not FAT32.

     

    The iMovie Project is really just a text file in hexadecimal. It references the actual video clips, which are stored in iMovie Events (or sometimes in iPhoto or Aperture Events.).

     

    It is important not to move these events, except from within iMovie, or the links from the Project will no longer make sense. Events should be in the Movies/iMovie Events/<event name> folder on the internal drive, or they can be in the iMovie Events folder at the top level of the external drive.

     

    Here is how to move projects and events from within iMovie.

    https://discussions.apple.com/docs/DOC-4141

     

    To fix your issue, the general strategy would be to move everything back to where it was. Make sure the Event folders are back where they were. If music or photos have been moved, that could also be an issue.

  • Dick1151 Level 1 Level 1 (0 points)

    Thanks, AppleMan1958.  You've prompted me to look closer at the "Missing" file.

     

    I've checked Time Machine and discovered I never moved the events file folder named in the Missing Media error message. It has always been in the Movies/iMovie Events folder on my internal HD, but I did rename it. I've relabled it to its original name and rebooted my iMac, but that hasn't helped.  I've never changed the names for the individual event clips.

     

    I've tried clicking Contine when I get the Missing Media error message, hoping iDVD would get the files anyhow, but that leads to another eror:

     

         The project could not be prepared for publishing because an error occurred. (ParamErr: error in user parameter list)

     

    Since iMovie has always found the files well enough to display them on the Events and Project panes, it is finding the events (so they're not totally "Missing"), but is having trouble "telling" iDVD where they are.  Any ideas?

     

    Thanks again for your help!

     

    Dick

     


  • Dick1151 Level 1 Level 1 (0 points)

    Thanks JacobQuick, but I'm using my own iMac and the error message is coming from iMovie.

     

    Dick

  • AppleMan1958 Level 7 Level 7 (27,395 points)

    Try SHARE/EXPORT MOVIE in Large size and see if you get the same error message.

  • AppleMan1958 Level 7 Level 7 (27,395 points)

    I had another idea. You said you changed the name back, but it still did not work.

     

    The iMovie Event folder must have the extension .localized if that extension is not there, the events will not work.

     

    So I would suggest trying this:

    1) In the Finder, right click on the iMovie Events folder and choose GET INFO in the popup menu. Make sure that the .localized extension is there. I do not think that this extension is needed on the individual Event Folders.

     

    localized example.png

  • Dick1151 Level 1 Level 1 (0 points)

    I don't recall ever seeing this Extension!  Unfortunately, adding it didn't help.  I did so before exporting, as per your earlier message.

  • Dick1151 Level 1 Level 1 (0 points)

    AppleMan1958

     

    This worked like a charm!  ...It worked for both Large and HD formats, based on the reviews I did for each in QuickTime!

     

    Many thanks for saving a re-edit that would have taken well over a week!

     

    It is a 7GB, 1/2 hour project; is that too big to expect the Share function to work right?

     

    I've imported the HD file into iDVD.  Would you expect the Chapter marks in the iMovie Project to work there?

     

    BTW, I very much appreciate your tenacity and clear instructions!

     

    All the best....

     

    Dick

  • AppleMan1958 Level 7 Level 7 (27,395 points)

    Yes, the chapter marks should work fine.

     

    Keep in mind that iDVD will convert your file to standard definition 640x480. That is why I suggested sharing in Large 960x540 so it wouldn't have so much work to do. But no worries, your 1920x1080 file should work fine in iDVD. It just may take longer to crunch it down.

  • Dick1151 Level 1 Level 1 (0 points)

    AppleMan1958

     

    Thanks again!

     

    Just as you said, everything turned out very well, including the chapters!  It only took about ten minutes to burn, so my use of the larger file didn't lead to an all-nighter...  I'll know better next time, though.  Thanks for the explanation.

     

    Many thanks for the great help and prompt replies!

     

    Best wishes...

     

    Dick