2 Replies Latest reply: Jul 11, 2013 3:55 AM by applecore_eater
applecore_eater Level 1 Level 1 (0 points)

I have an external drive Samsung 500 GB that was failing. I think my MacBook Air (10.6.8) caused it to fail because it wouldn't allow me to eject the disk even though I forced quit all programs. I eventually had to just unplug the drive and this caused the external disk to fail as it had not been ejected properly. Not my fault. It's the MBA's fault for not letting me eject the disk. Now the Samsung disk won't mount properly and I get a message that the drive is failing and I should save the data.

 

Anyhow, I used the free version of Data Rescue 3 to try and save the data on the failing Samsung 500 GB drive and move it onto a brand new Toshiba 1 TB drive.

 

I was unable to use the normal scanning function of Data Rescue 3 as the hardware of the drive was too damaged, and so I used the clone function on Data Rescue 3 to clone the data onto a non-failing hard drive, with the intent of restoring the data later.

 

I am not sure if I was successful in making the disk image. It hung up at the 99.6% point for about 12 hours when I decided to give up on it, and I shut down Data Rescue so I could eject the hard disks.

 

However, it would not let me do it. I tried force ejecting but still I could not eject the disks.

 

I ended up just unplugging the drives. I think the Samsung drive died almost completely then because it made a whole lot of clicking noises after that (it was only making a few clicking noises before that).

 

Anyhow, I plugged the Toshiba 1 TB drive into the computer again and used Data Rescue to scan the drive with the disk image on it to see if I could detect files on that drive.

 

It opened up the structure and I was able to see that most or all of the files were there (abbout 450GB of data) just from seeing the information about the files in the structure tree - the labels of the files (file type labels such as jpg, mp4 etc) and the size of the files, although I could not open up the files to check all of them.

 

I tested out the restore function of Data Rescue by downloading one file (<10MB) file. I am using the free version and can download one file for free to test things out.

 

It worked and I was able to save that file onto a second external drive (Western Digital 500 GB) I had plugged in. I had bought this drive just to do the data rescue.

 

So I think the files are salvageable and the disk image is OK.

 

However, when I tried to open the disk image in Disk Utility, by opening it as the source and choosing the WD drive as the destination I could not open it. I got an error message. I can't remember what the message was.

 

I tried just opening the disk image in Finder by just clicking on the disk image but it won't mount.

 

Is that because my hard drive doesn't have enough space? My Desktop on the MBA only has 12 GB free and the WD drive has only 500 GB on it even though the disk image is about 501 GB.

 

I don't know why the disk image is that size when the failing Samsung drive only had 450 GB of data on it.

 

Anyway, what should I do to mount the disk image?

 

I want to mount the disk image so that I can copy or move the files from it to another external drive so that I can save those files.

 

Is it because the WD is only 500 GB or does it mean there's a problem with the disk image I made?

 

Should I try Carbon Clone Copy? I use that to make backups of my MBA internal HDD though I have never used it for opening or making disk images.

 

I have never dealt with disk images before except for dmg files of applications downloaded from the internet.

 

I am trying to avoid using Data Rescue 3 as I have to pay for it and if there is a free option, such as Disk Utility, CCC or other, I want to try it to restore the data in the disk image.

 

Sadly, I think the Samsung drive is ruined beyong repair as it's making a lot of clicking sounds and doesn't mount properly in Disk Image and I get a message that it's beyond repair or something like that in Disk Utility.

 

So I am relying on the disk image I made on the Toshiba drive to restore my files.

 

(I think it was the last movie file that caused the problem because it was when I was trying to copy it onto the Samsung external drive, all the problems began - hanging up when copying it, not being able to eject the Samsung disk, causing hardware issues on Samsung disk and getting warning messages on Disk Utility.)

 

BTW, I learned how to eject a drive when it won't eject the normal way, I have to use command window and type in commands, but that's another post ....

 

Any advice?

 

I am thinking of going out and buying a second 1 TB external drive so that I have a disk with enough space to open the 501GB disk image on it, just in case that was the sole problem.

 

However, I am not sure that is the case, and I think there may be a problem with the disk image or I am not going the right way about opening it.

 

Thanks for any advice.


MBA v 3.2, 256GB SSD, 2.13GHz, 4GB, Other OS, 10.6.8
  • applecore_eater Level 1 Level 1 (0 points)

    The error message when I double-click on the disk image is:

     

    No mountable file systems

     

    Or something similar to that. What can I do?

     

    Does this mean there is something wrong with the disk image?

     

    I could not complete the making of the disk image as it hung up near the end (at the 99.6% point) because I think there was some bad sectors or bad files.

     

    However, I was able to see the directory tree of the disk image in Data Recovery 3 so I think most of the files are in the disk image.

     

    I don't want to use Data Recovery if I can avoid it.

     

    Do you think I can just open the disk image another way or is the disk image not proper and I have to use recovery software to restore the data in the disk image?

  • applecore_eater Level 1 Level 1 (0 points)

    I think I've found the solution to this problem.

     

    http://superuser.com/questions/19426/im-unable-to-mount-a-dmg-getting-a-no-mount able-filesystems-error

     

    I am following the instructions here:

     

    I ran into a similar situation. I did what simonair suggested and I received a message in Terminal that Volume mounted successfully. However It did not help me access the mounted Volume neither was I able to confirm the mounted Volume. Nor was I able to mount the image using Disk Drill or even scan through. Nothing succeeded.

    Here is what I did to solve my problem. I see that in this post some suggested that we should convert name.dmg to writable file. I used the command from Terminal to convert but was not successful. INSTEAD alternatively, I used Disk Utility, attached the Volume (yes I got the same message again, ''no mountable system files'' however, Disk Utility nevertheless attached the image, which I was able to do before anyways. This time, I selected it and then clicked New image, and then selected image format read/write, not the compressed option. I created a new image. This time this image was writable however, it still would not mount using Simonair's solution. However, this time I was able to scan it with Disk Drill with exact file locations and folder hierarchy as I had. Recovering all from thereon was a breeze. Just remember: when you create new image of an attached volume and chose not compressed but read/write, you need to have a disk with exact amount of space that totals the total space allocated within that name.dmg file (not the amount of space the data takes). Mine was huge, and luckily I had an external disk with enough space to do that and it took about 5 hours for about 400GB of disk allocation. Good luck.

     

    And so far it seems to be working. Even though the volume is grayed out on the left side of Disk Utility, I am still able to select it as the source for making a new disk image. I chose Read and Write and no compression.

     

    The only thing I might be doing differently is that instead of choosing the disk image as the source, I chose the volume as the source. The volume is grayed out, but the disk image is not.

     

    It seems to be working all right. Keep my fingers crossed.

     

    If this doesn't work, I will use Data Recovery 3 as a last resort.