8 Replies Latest reply: Aug 19, 2014 12:57 PM by British Bulldog
WoodlandPotter Level 1 Level 1 (10 points)

Hi,

 

Hope someone can help me fix this.

 

I have a 4th generation iPod Touch. Location services used to work on this iPod. By this I mean that when I opened Apple's map app it would show my location with a blue dot. The Location Services arrow icon (purple) would appear on the top right corner and all was well. Then, a couple of days ago, it stopped working. "It can't determine location" is the message I now get in Apple's map app. Just spins and spins, unable to locate itself in the Local weather app. On other apps, it just can't find where the iPod is. So.. can't use any of the location functions of any of the apps.

 

Location services is set to "on," in privacy settings. Location services is on for all the apps. I know the router is registered with Apple, since my 2nd gen iPod Touch has no problems locating itself on it's map app, and in other apps. Also, tested the 4th gen iPod Touch's location services on an different router and it didn't work there, either.

 

I noticed several weeks ago that it didn't work and then it did. So.. something is up with this.

 

Whenever I press the home button, the arrow icon appears. When I put in my passcode and slide to unlock and it goes to the home screen, the arrow icon disappears.

 

I have restarted the iPod Touch by pressing the wake/sleep button and sliding it to off.

 

I have reset the iPod Touch by pressing and holding both the wake/sleep button and the home button until the Apple icon reapears in the boot process.

 

Still Location services doesn't work.

 

Suggestions?

 

Thank you so much.


iPod touch (4th generation), iOS 6.1.3
  • Jessi Rashel Level 1 Level 1 (0 points)

    I also have this issue. I have had it ever since getting my Ipod touch 4th gen. I'm trying to figure out why it's such a big issue because I've done everything. I AM CONNECTED TO A WIFI ROUTER. ALL LOCATION SERVICES ARE ON. IOS IS UPDATED AS MUCH AS IT CAN GO. Even with that still no luck. EVERY once in a while location icon will pop on and then go off within seconds. Not to mention it's very laggy and glitchy even with apps closed down. Sometimes it even takes a while to come on. I'm guessing ?maybe? it's just and ipod 4th gen problem?

    Things I've Tried:

    Making sure location services are on

    Reset and restore

    My WIFI box has be unplugged and then plugged back

    any possiblity I've seen so far

     

    My nexus tab can get my location but I do like using my Ipod Touch because it's a bit more mobile than my tablet especially with listening to music.

  • MasSaSeen Level 1 Level 1 (0 points)

    Were either of you able to fix this? I have the same thing going on.

    Thanks

  • WoodlandPotter Level 1 Level 1 (10 points)

    Hi MasSaSeen,

     

    Wow.. I have learned a lot since posting my original question.

     

    Yeah.. Location Services is great when it works and ***** when it doesn't, since so many apps use it to function correctly.

     

    The thing is, for Location Services to work, your device needs to got out to the internet and look in the database of registered routers, to see where the router, that your device is talking to, is located. iPhones and cellular enabled iPads can talk to cell towers, coupled with Global Position Satellites and determine their location if the router's location is not known. iPod Touches and WiFi only iPads have no such luxury.

     

    Thing is, in the old days, before iOS 6, location information for routers was kept by the third party company Skyhook. If Skyhook's database knew about and had your router registered, you were golden and Location Services on your device would work. If it didn't, Skyhook even had a way to register your router with them so your device's location services would work. Well, that was all good and everything, but Apple decided to bring this in house and for those who upgraded to iOS 6, or bought new devices, suddenly everything was starting from scratch again and for some, Location Services no longer worked. I was one of them with my WiFi only iPod Touch.

     

    To build their database, Apple made it so iPhones would (without the need to connect to the network of the routers) anonymously call home to the Apple servers and record the location of the routers, thus building the database. The other way for the location of routers be added to Apple's database was for routers to look around themselves and report the location of other routers that they see.

     

    So here was my situation. I had my iPod Touch and an Apple Airport Express as my main router. I live in the woods with only one neighbor relatively close-ish by, a rental house that frequently sat empty. Here's what happened. Location Services did not work. Got someone to come by and use their iPhone at my house in the hopes that would add my router to the database. Registered it with Skyhook.After a bit, Location services suddenly worked. Worked for a while. Then, it didn't work anymore when Apple booted Skyhook and brought all that in-house. Then I think someone rented the neighbor house and set up a router and probably had an iPhone, or a friend with an iPhone visited. Suddenly Location Services worked again. Fabulous! I bought a new router, upgrading the Airport Express to the latest one. Location Services stopped working because Apple database didn't know this new router. Gosh darn it! But I suspected this would happen. I still used the old router, but in bridge mode. A very knowledgeable Apple guru friend of mine thought that, over time, the new router would be added to Apple database because of the presence of the old router. It took a couple of months and Location Services suddenly worked again. Maybe this happened because of the router, coupled with the house nearby being rented again and maybe someone coming along with their iPhone. Whatever, something informed the Apple servers the location of my new router, and all things that needed Location Services worked fine.

     

    It is interesting that when looking on the map on my iPod Touch that it now shows my location (presumably of my router) at my mailbox, like it doesn't really get the being in the woods thing.

     

    All this is to give you a background for what is going on when WiFi only iOS devices try to access anything that needs Location Services. Sorry for the length.

     

    Does your iOS device work fine on other people's networks, but not your own for Location Services? Does it get stuck on the last time it found a registered router? For instance, I went on a trip to Columbus, OH and my iPod Touch joined the network of the hotel there. Obviously their router was registered. When I got home, though, my iPod Touch would indicate that it was still in Columbus, because that was it's last known location. A real bother. If this is the case, it's because Apple's database doesn't know your router, yet. Give it time. Help it along by having someone come over and use their iPhone around your router. Does not need to join your network to do this. You may want your friend with iPhone to walk around outside and let it see the other routers in the area and connect to GPS, as this may help. Eventually, that iPhone will call home to the Apple servers and get your router added. Once it is added, Location Services should work.

     

    If it's just your device that is having the problem, you could try turning Location Services slider to off, in Settings, and let it sit a moment before sliding it back on. This should force the device to talk to Apple's servers again, resetting the connection and hopefully this gets Location Services working.

     

    You could try reseting Location Services for all your apps. It will delete the permissions and will cause each app to ask for your permission again for it to use Location Services. A bother, I know, but it may fix some funky thing going on with one of the apps that may be messing things up. A long shot I know, but worth a try.

     

    Of course, it never hurts to power cycle (reboot) your iOS device. That may clear something that got kind of messed up and fixes the problem.

     

    I have, at one point, or other, tried all these things and gotten Location Services to work.

     

    It has been a real roll coaster ride concerning Location Services on an WiFi only device, but it's been an interesting learning experience.

     

    Hope something in this helps.

     

    If not, reply with more detail of your problem and hopefully we can sort it out.

     

    Hope you are enjoying a fine day.

  • lllaass Level 10 Level 10 (160,565 points)

    Apple stopped using SkyHook for location services in 2010 (iOS 3.2 or later).

    http://techcrunch.com/2010/07/29/apple-location/

  • British Bulldog Level 2 Level 2 (205 points)

    On Skyhook website there is a page where you can manually update the location of your Access Points. Do Apple have something similar? I've been trying to sort this for ages. I work on a yacht and we have over 100 APs and we have been registered somehow in New Zealand and we left there 6 months ago but it still tells us the same location. We are always moving around but I can update the location.

  • lllaass Level 10 Level 10 (160,565 points)

    Not that as could find. As I stated in my previous reply, Apple uses data from iPhones and likely cellular iPads to construct/update their database since iPhones and cellular iPad have GPS chips.

  • British Bulldog Level 2 Level 2 (205 points)

    Yes I read about this recently. It's causing real problems for us as evrything that uses these services onboard thinks we are in New Zealand and we are in Alaska!

     

    It would appear they don't update it too often as that data is 6 months old.