Previous 1 2 Next 17 Replies Latest reply: Jul 24, 2013 5:31 AM by John Cogdell
marmar2010 Level 1 (0 points)

Hi! First time on the discussion boards. Usually I am able to figure something out myself, and if not, a quick search online gives me the answer...but not this problem.


I have my wedding footage that I am trying to edit and compile to make a video. Original footage was captured in some format that is not compatible with quicktime; I believe its UNIX (or something). I converted all clips to mp4 and have been transferring them to iMovie so I can begin editting. Here is the issue.


There are a couple of clips that, even though they are in the proper format, will not open iMovie. All other clips that I converted opened up fine in iMovie. I selected an event, imported movie, found clip, and it optimized, processed, and generated the clips into frames. There are a couple that will not open in iMovie. It begins the process, and then nothing happens. Whats confusing is that it is in the proper mp4 format because when I open the clip in the folder that it is saved in, it plays just fine in quicktime. Also, all other clips that did transfer properly, I did the same thing to them for the entire process (converting to transferring).


I then tried opening the video in iPhoto (I was told that sometimes corrects any error with the video). It is in iPhoto, plays in iPhoto, but won't transfer to iMovie.


I restarted everything multiple times. I even took the original footage and converted it into mp4 again (thinking something happend during the original conversion).


I don't know what else to do. Hope you were able to bear with my ramblings and I hope someone knows what to do!!


Thanks so much! Look forward to any and all assistance!

MacBook Pro (13-inch Mid 2012), OS X Mountain Lion (10.8.4)
  • Karsten Schlüter Level 7 (31,925 points)

    marmar2010 wrote:

    … Whats confusing is that it is in the proper mp4 format …

    meant as background info:

    mp4 is no 'format', nor 'proper' for iMovie

    it's a container or 'media wrapper', such as avi or mov - could contain 'anything'.


    iMovie is meant by concept for camcorder imports, not 'all movin' images' - only via camcorder, the needed import routines get triggered.


    you're not alone with your problem - a high percentage of 'issues' on this board are based upon manual conversions. e.g. a popular tool is a thing called 'Handbrake' which converts into wrong codec and adds text-tracks, which make it impossible for iM to import ...




    to solve your problem:

    get the free and most recommended converter on this board, MpegStreamclip.

    open your allready 'converted' mp4 with it

    Export to Quicktime

    in its many options, select AppleIntermediateCodec as … codec.

    that is iMovies internal, native format.


    import those into iMovie


    happy movie making!

  • marmar2010 Level 1 (0 points)

    Thank you for your promt response Karsten!!


    I will follow your advice and return with an update on my situation!


    Ps. I will immediately delte Handbrake

  • marmar2010 Level 1 (0 points)



    Thankful for the Apple Support Community. I will definitely use again!



  • Karsten Schlüter Level 7 (31,925 points)

    marmar2010 wrote:


    what a start in the day (7am here)  - THANK YOU for 'the flowers'


    note: Handbrake is very handy to convert DVDs into iPad/AppleTV/iTunes compatible formats .... but no good for conversion to iM .............

  • marmar2010 Level 1 (0 points)

    Follow up question please...


    As I followed your instructions, I was able to properly convert one of the trouble files that I had; and I have added it to iMove and all is well.


    What trouble shooting should I look for if my original problem continues? I followed the same steps with another problem clip (from the same group of videos). Opened MPegStreamclip, selected my .mp4 file. Exported to QuickTIme. Selected AppleIntermediateCodec, and it saved the under .mov.


    It seemed to be the same steps as the other, yet one worked properly and opened in iMovie; the othe seemed to save properly, yet it won't open in iMovie.


    Thanks Karsten! I know you will have another great answer for me! Sorry for my lack of knowledge in this area!

  • Karsten Schlüter Level 7 (31,925 points)

    marmar2010 wrote:

    …  What trouble shooting should I look for if my original problem continues? …

    Original footage was captured in some format that is not compatible with quicktime; I believe its UNIX (or something). …

    uhm, well… I dare to say, the Originals WERE compatible, but they were saved in an odd way:


    that generic 'Unix file' icon …

    unix file icon.jpg

    appears only, when a file has no suffix nor a 'header' which could tell the MacOS, what sort of file that is.


    So, to solve the root cause, it would be interesting, what camera was in use?

    iMovie 'swallows' lots of formats, …


    maybe, we find a smarter way to 'convert' those mysterious files


    Can you select such a file in Finder (not in iM!), hit cmd-i and tell us, what the says about it (=apply a screenshot of the Info Window)


    I guess (stab into foggy dark), this was an AVCHD/mts file ... and some Windows user 'prepped' them for you

  • marmar2010 Level 1 (0 points)

    You're correct about the Windows user. The files I transferred are all in the generic UNIX icon as you said. Here is the info from the file I'm having problems with.


    Kind: Unix Executable File

    Size: 1.74 GB

    (nothing under more info)


    Here is the info from the same file once I followed your directions and took .mp4 and corrected through MPegStreamClip.


    Kind: QuickTime movie

    Size: 4.88 GB

    Dimensions: 1920x1080

    Codecs: Apple Intermediate Codec, Linear PCM

    Duration: 08:51

    Audio Channels: 2


    Same situation as before, it plays fine in QuickTime, but won't open in iMovie or generate thumbs, etc.


    I compared the info listed of the with the, and all codecs,dimensions, etc match.


    Look forward to your response.


    Oh yea, the camera used was a Canon.

  • Karsten Schlüter Level 7 (31,925 points)

    marmar2010 wrote:

    … Same situation as before, it plays fine in QuickTime, but won't open in iMovie or generate thumbs, etc.…

    oops - did I miss something?

    the one with AIC codec does NOT open in iMovie?!

    that'd be odd ...


    that file … is on your internal drive?

    or still on some external?



    to that 'unix' file ... :

    my assumption (hard to tell from remote) is, it is, or was a normal AVCHD/mts ...

    … it would be a process like in those 'Airplane' movies - I had to 'talk you down' step by step, using all sorts of tools .... as long as MpgStreamclip does its job, converting those beasts into something useful, we should stay with that.


    1st we have to check: where are those stubborn files - my assumption:

    on some external drive, your Windows friend used, right?


    then, there's an instrument with a horizon on it in front of you and two red ....


    ooops, wrong text!!

  • marmar2010 Level 1 (0 points)

    Yep, files were on an external. I transferred them onto my Mac. All files are internal.


    Lol, you didn't miss anything! That's what is strange to me. It made sense originally when you explained that .mp4 is not a "format" and that I needed to change the codec to AIC. I did that with one of my problem clips, turned it to .mov and codec is listed as AIC, and it worked like a charm. I repeated the same process with another clip with issues...and iMovie isn't processing it.


    I'll try to list my step-by-step process on iMovie. This is what is happening with the "problem clip"


    I right click on an event. Select import movies.

    Then window pops up, I select desired clip (in .mov)

    What then happens is a small box pops up that says "Optimizing Video" and says processing with a status bar. It immediately says "less than one min", one second later the screen vanishes, and nothing is transferred to my event.


    Usually what happens, when it works properly, when Optimizing Video box pops up, it takes anywhere from 1min to 15min to do its thing (process, optimize, generate thumbnails)....


    so I don't know what to say my friend. Direct me home!!

  • Karsten Schlüter Level 7 (31,925 points)

    Rex Cramer here …


    ok - where to start?

    my first idea was, you try to save >4GB files onto a fat/Windows-formatted drive => which doesn't work/causes issue.

    or,your firend uses a ntsf-formatted drive => which can be read by MacOS, not by iMovie, and can not be written-on.

    but, now, you're telling me, all is on your internal, local drive - right?


    I think, we should forget to 'fix' the original problem - somewhere, somehow, the easy-to-use AVCHD-stucture got lost, was stripped off, orphanized, you name it. So, let's get busy with your local files:


    • you successfully converted one file#1 into an, which iM swallowed? ok.-

    • there's another one #2, you opened in Streamclip, Export with QT/codec: aic, which does NOT import?

    • can you - doubel-click in Finder - playback THAT mov#2 with QuicktimePlayer?

    • if so, cmd-i, post that info-window, please ..


    < taking a pull from cigarette >

    this movie is rated R

  • marmar2010 Level 1 (0 points)

    Alright, here we go!


    Initially, I had problems with file#1 and file#2. Both (along with all clips in discussion) were transferred originally from a Windows origin, and now are all saved internally on my macbook.


    after following your instruction, file#1 was succesfully converted and iM swallowed. Yes! (swallowed means it accepted it properly and into iMovie...right? lol)


    file#2 I did all the same things and yet is NOT importing into iM.


    Below are the images of info window from file#2.


    The first screen shot below is file#2 after it went through streamclip


    Screen Shot 2013-07-18 at 7.56.28 AM.png


    The one below is file#2 after handbreak...still in .mp4


    Screen Shot 2013-07-18 at 8.07.15 AM.png


    Here are a couple of extra images. They are the cmd-i from the playback of original file via VLC player.

    Screen Shot 2013-07-18 at 8.24.57 AM.png

    Screen Shot 2013-07-18 at 8.26.40 AM.png



    PS. All other files I am using to compile and create a complete wedding video were "converted" through handbrake only (did not run through streamclip), and have all worked fine in iMovie.


    PPS. I very much appreciate your help! You have spent much time on this and have not given up..THANKS!!!

  • Karsten Schlüter Level 7 (31,925 points)

    marmar2010 wrote:

    … You have spent much time on this and have not given up..

    Germans are stubborn …


    your screen-shots confuse me (and that's not based upon 'lost in translation') ... .


    a) you're saving your files into the Application folder!! NoGo!!

    < father's voice > keep your place tidy, Kid!


    not of real relevance, but … I've seen Macs with 'special' user-priviledges esp for the Apps folder (=to avoid spontanous erasing of programs) so this could cause issues, if an app like iM gets lost in your special 'system'...

    but, movies>>Movies folder; or, to any ext. drive (for iMovie: MacOS formatted), …



    b) avoid 'special characters in naming files, esp . : / (dot, colon, slash), don't name your file "Reception Video:First Dance", but "Reception Videos First Dance" or "RV_FD" or "Here-comes-the-bride" or "ShakeThat" or ....


    . : / are 'control characters' in MacOS/UNix - e.g. naming a file with a leading dot ".dance" - and it vanishes!



    c) …  as you can see in #2: it's h264, some very odd frame-rate (29.91 -wot?), it's anamorph (1440) - and in it's orriginal (#3) it was 60fps (59.94fps) AND 4:2:0 encoded ..... which indicates, it was shot with some 'pro' equipment.- And some 'pro' codec, iMovie doesn't support.




    let's try a few things:

    1) create a copy in Finder of the nasty file ... (ctrl-click, duplicate), so we do no harm to the precious original ....

    2) Open the COPY of file #2 in Streamclip again;

    3) this file is huuuuuge - play it in Streamclip for a few seconds; pause; hit O (=out point), hit cmd-T (=trim); save as Quicktime, ...

    4) still in Streamclip! save as Quicktime, select Apple DV / NTSC as codec (this 'downsizes' your video, but for test-purposes)

    5) test to import file from #4 and file from #5 ....


    any results from the jury.....?

  • marmar2010 Level 1 (0 points)

    Verdict is in...


    I don't know who you are, or what kind of magic you practice...BUT YOU'RE AWESOME!!!


    I followed the steps, downsized a test portion of the clip, and it iMovie swallowed it just fine (see, I'm using terms that I've learned!)


    Once that worked, I decided to do it with the full problem file, and it worked. Initially it changed the format to a full-screen instead of wide as the rest of the clips were. But I figured how to reformat it following your instructions, and EVERYTHING IS IN WORKING ORDER!!


    Very very very very very Very VERY VERY VERY VERY thankful for your help!!



    And sorry about my messy folders I've had the Mac for nearly a year now, and as I transitioned from PC use, I believe I have brought over some nasty habits. Whilst I have your would you suggest I organize my files? To be honest I didn't realize they were under my application folder. I just started a folder as to save all work under. I pretty much trust any advice you will ever offer, so offer away! Any and all pointers welcome!


    Until next time good sir!

  • Karsten Schlüter Level 7 (31,925 points)

    marmar2010 wrote:

    …  I don't know who you are, or what kind of magic you practice...

    just trussssst me …

    my name is Kaa-sten ....


    Thanks for the flowers!

    I'm just a hobbyist on a shoestring-budget, therefor needing lots of tricks, workarounds, dirty hacks ...

    a few hundred years ago, I made this website

    offering some help … site isn't maintained for years (still tips for iMHD6 avail LOL)  … maybe you'll find helpful hints and suggestions.



    marmar2010 wrote:

    … and as I transitioned from PC use, I believe I have brought over some nasty habits. would you suggest I organize my files?

    a few general advices:

    • some apps do have the habit, to open in any 'save'-dialogue the last opened location - which can be the apps-folder! so, just have a look in the save-window-top-bar, where you are actually. In Finder, you can 'repair' such stray-cats, givin' them a new home. file-location.


    • some people do have the habit, to save 'everything' on Desktop - in any save-dialog, pressing cmd-D jumps straight to that location - which can lead to some hodgepodge on your screen. ok, for fast working, as a 'interim location' fine, but 'keep your room tidy!" - ahh, we had that


    • your Mac came with a pre-structured harddrive: you notice Music, Movies, Documents ... for me, this is a good start.


    • now, trusssst me, evangelizing starts NOW:

    I'm noticing on the Windows frontline, a habitually ritual to organize 'manually'. Example: thousands of folders (and folders within folders) to 'structure' a music library of 10.000th of songs.

    DIFFERENT on MacOS, different for this example in iTunes, the magic is: TAGS


    by concept, there's no need to bore the user with file-locations!


    MacOS and its applications make widely use of tags, keywords.- And it has built-in powerful search- and filter features. Look upper right, the tiny loupe: Spotlight indexes EVERY file ever on your Mac! You have written thousands of letters - where's the one mentioning the 'intoxicated neighbours'? Type these two words into Spotlight - presto! your document is there. No need to know where or when or in which app you saved it.


    In iMovie, you can use keywords

    in its bigger brother, FCPX, you have a whole data-base-app at hands! (a popular request there is 'sub folders' - let the app do it, automatically!)


    I like to explain it with two examples:

    • in your music library, you're looking for 'oompah oompah yeah' - in a manual organized library, YOU have to know, is it in folder 'Kraut Hits 99' or in 'Kraut Hits 98' - if your files are well tagged (and in iTunes, you can automate this process!), just type 'oompah' - done.


    • in your photo library, you're looking for that very nice pic, Grandma smiling - in a manual organized library, YOU have to know, is it in folder 'XMas2010', or 'funeral_2011' … ?  if your files are well tagged (and in iPhoto, you can tag persons automatically), just type 'Grandma' - done.



    lots of text - sorry!

    in short:

    use keywords. tag your files. let the dumb but fast computer do the work it can do best - search&organize. keep your head free for creativity.


    although, I recommend to avoid clutter, but I also recommend to avoid 'over organization' - tags are best!


    enjoy movie making!


    and sorry for my, sometimes corny humor ....

Previous 1 2 Next