0 Replies Latest reply: Jul 13, 2013 3:53 PM by SGoldsmith
SGoldsmith Level 1 Level 1 (0 points)

I accidentally plugged my external HDD into a friend's computer, thinking I could transfer a few files quickly. Didn't realize, or remember, until it was too late that it doesn't work that way..he has a PC, I have a Macbook Pro. The HDD did some beeping, but I unplugged it before anything could happen.

 

Not thinking much else about it, I waited a few hours before plugging it back into my Macbook. At first, it said can't read and gave me the "initialize, ignore, eject" option...Since it's never done that before, I sort of freaked out and unplugged it right away. After leaving it unplugged for 5 minutes or so, I plugged it back in and everything worked fine for almost 2 days.

 

Like I said, I didn't think this was a big deal....until I got home today and began getting the same error as before. It's now saying it's a Segate Desktop Media and has 4.14 GB available. THIS IS A 2TB EXPANSION HDD! I really need help, can't figure out what went wrong, and now I'm afraid of messing it up and losing almost 500gb of important video production work and family pics and things.

 

Also...I have already restarted everything. Left things unplugged for 20 minutes. Switched the standard USB cord to a y-cord to assure enough power. Etc. 

 

Thank you for reading, and thank you in advance for your response. I'm starting to get desperate.

 

 

 

Specs:

Seagate 2TB Expansion External Drive (USB)

Macbook Pro 13in - Mountain Lion OS X 10.7.5


MacBook Pro (13-inch Early 2011), Mac OS X (10.7.5)