7 Replies Latest reply: Dec 6, 2015 2:16 PM by Pedro
JamesFSchultz Level 1 (0 points)

Bootcamped per the manual, settings are all maxed out...


MacBook Pro, OS X Mountain Lion (10.8.4), laptop "17-inch, early 2011"
  • woodmeister50 Level 5 (5,170 points)

    Have you run all the windows updates?  If so, you may need

    to go to the Intel video control and use the advanced settings

    and adjust gamma, brightness, and contrast. 

     

    Also, have you tried the keyboard display brightness adjust key?

    Saw some thing similar after installing Win8 on my 2011 13" MBP.

    All software adjustments did not give any desirable results.  Then hit

    the display brightness key on the keyboard, and all was fine.  It was

    odd but some how it seemed the hardware brightness control via the

    keyboard does not interact with the software when running Win8.  Not

    sure if this is an issue with the driver or if it is by design.

  • Wildebeest50 Level 1 (0 points)

    Windows has a built-in feature that auto-adjusts the brightness of your screen based on the MBP's light sensor. This feature automatically sets the brightness fairly low, so if you want to turn it off, just hit the start button and search for "adjust screen brightness automatically" under settings and hit the button to turn it off.

  • JamesFSchultz Level 1 (0 points)

    Odd there's a "conflict" with that, but hey it worked & I'm off & running with a screen I can see - thanks!

  • woodmeister50 Level 5 (5,170 points)

    JamesFSchultz wrote:

     

    Odd there's a "conflict" with that, but hey it worked & I'm off & running with a screen I can see - thanks!

    You're welcome and it does seem odd.  May be the difference

    in the way OSX handles the drivers for the hardware vs. Windows.

  • sanitysake Level 1 (20 points)

    I know this is an old thread, but I wanted to share with others who might come across this that I had the problem of a dim screen on Windows thru bootcamp as well, and Wildebeest50's answer solved my problem! Thank you.

     

    Using the Metro menu I went to Start -->

    Searched for "Settings" ---->

    Clicked on "Settings" on the right hand column bar --->

    A whole list of settings pop up, and I clicked on "Adjust my screen brightness automatically" --->

    I was taken to "PC Settings", and under "General", I found "Screen" underneath "Time", "App Switching", and "Spelling". --->

    I slid the option for automatically adjusting screen brightness to OFF

  • ben9242367r Level 1 (0 points)

    Thanks, your solution seems to be working for me so far. Here was my workaround until today:

    • start, control panel, device manager
    • doubleclick Display Adapters
      • rightclick on Amd Radeon then left-click DISABLE.
    • Rightclick. ENABLE

    Now it's back to full brightness will full control.  But if I ever tap the F1 button (dim) or F2 (lighten), then the brightness goes down again, and I can't get to full brightness. I had the same problem with Lenovo in the past: it would spontaneously go dim, and I was unable to control brightness with the Function keys or the slider (under Power Controls). Short of rebooting, the only solution I found was to disable/enable the display adapter. So this is not unique to Bootcamp.

  • Pedro Level 2 (455 points)

    My 5k iMac has the same issue running Win8.1. Shortly after booting Windows the screen dims and stays that way. The problem for iMacs is that these use a  mobile CPU. Windows sees that and assumes all iMacs are laptops and likely to run on battery power. The low light level is a huge disadvantage for gamers like me and irritation enough when using non-game apps. It's just too dim. I found the Apple keyboard screen brightness keys do not work. Anyway the normal Windows brightness setting was found at maximum anyway. Subsequently I switched to using a PC USB keyboard for needs not addressed by the Apple keyboard.

     

    The screen dimming fix? Visit the Advanced Power Manager. There are many settings in there that set themselves as for a laptop to conserve battery power. There is probably a dozen there that you will want to change. But there are three important settings that will make a world of difference.

     

    Adaptive Power — set that to off — probably optional. Not quite sure what this does. But it likely relates to the ambient light level. I never use auto brightness control on my Macs anyway.

    Brightness — increase to a level that will suit your working. Find the setting by trial and error. I found 75% was a good number. But nothing will happen until you adjust the dimming level.

    Dimming — found set at 50%, far too low a light level for a desktop in normal working. Since the iMac has no battery issues I've also set that at 75%. I do not need my screen dimmed at any time especially while playing a game in which certain scenes can be very dark anyway.

     

    A reboot might be needed to set these changes in stone.

     

    I hope this helps.

    Peter S.