14 Replies Latest reply: Feb 7, 2014 4:03 AM by hyphennz
dipflyboy77 Level 1 Level 1 (0 points)

I just did a routine software update (ML 10.8.4), and now it refuses to accept my log on, recycling back to the user account log in display every time. Also lots of spinning ball delay.  I can access the "guest" account, but not my normal one.  Advice?


MacBook Air, OS X Mountain Lion (10.8.4)
  • 1. Re: macbook air won't let me log in
    Kappy Level 10 Level 10 (226,700 points)

    Forgot Your Account Password

     

    For Lion/Mountain Lion

     

        Boot to the Recovery HD:

     

    Restart the computer and after the chime press and hold down the COMMAND and R keys until the menu screen appears. Alternatively, restart the computer and after the chime press and hold down the OPTION key until the boot manager screen appears. Select the Recovery HD and click on the downward pointing arrow button.

     

         When the menubar appears select Terminal from the Utilities menu.

         Enter resetpassword at the prompt and press RETURN. Follow

         instructions in the dialog window that will appear.

     

         Or see Reset a Mac OS X 10.7 Lion Password, OS X Mountain Lion- Reset a login password, and

         OS X Lion- Apple ID can be used to reset your user account password.

     

    For Snow Leopard and earlier with installer DVD

     

         Mac OS X 10.6- If you forget your administrator password

     

    For Snow Leopard and earlier without installer DVD

     

        How to reset your Mac OS X password without an installer disc | MacYourself

  • 2. Re: macbook air won't let me log in
    dipflyboy77 Level 1 Level 1 (0 points)

    I did all of this and reset the password.  But after restart the original problem is unchanged.  Entering the correct/correct password simply results in a return to the user account screen.  And so on again and again.

  • 3. Re: macbook air won't let me log in
    Kappy Level 10 Level 10 (226,700 points)

    Then you will need to reinstall OS X.

     

    Reinstalling Lion/Mountain Lion Without Erasing the Drive

     

    Boot to the Recovery HD: Restart the computer and after the chime press and hold down the COMMAND and R keys until the menu screen appears. Alternatively, restart the computer and after the chime press and hold down the OPTION key until the boot manager screen appears. Select the Recovery HD and click on the downward pointing arrow button.

     

    Repair the Hard Drive and Permissions: Upon startup select Disk Utility from the main menu. Repair the Hard Drive and Permissions as follows.

     

    When the recovery menu appears select Disk Utility. After DU loads select your hard drive entry (mfgr.'s ID and drive size) from the the left side list.  In the DU status area you will see an entry for the S.M.A.R.T. status of the hard drive.  If it does not say "Verified" then the hard drive is failing or failed. (SMART status is not reported on external Firewire or USB drives.) If the drive is "Verified" then select your OS X volume from the list on the left (sub-entry below the drive entry,) click on the First Aid tab, then click on the Repair Disk button. If DU reports any errors that have been fixed, then re-run Repair Disk until no errors are reported. If no errors are reported click on the Repair Permissions button. Wait until the operation completes, then quit DU and return to the main menu.

     

    Reinstall Lion/Mountain Lion: Select Reinstall Lion/Mountain Lion and click on the Continue button.

     

    Note: You will need an active Internet connection. I suggest using Ethernet if possible because it is three times faster than wireless.

  • 4. Re: macbook air won't let me log in
    dipflyboy77 Level 1 Level 1 (0 points)

    I've now done the above, but no success.  Twice.  Additional ideas?

     

    For diagnostic purposes, it might be interesting for you to know that when I log in (with what is I assure you the correct password) it does not provoke the usual "earthquake" wobble of an incorrect password. Rather it proceeds with what looks like a logical next window, only to revert after about 10 seconds to where I started.  I even created a new user account, with the same password, and all to the same effect.  The only way in is via the unpassworded guest account.

     

    Thanks for any advice.

  • 5. Re: macbook air won't let me log in
    Kappy Level 10 Level 10 (226,700 points)

    Now, you've got me. That's very unusual unless there is an issue with the keychain. Perhaps you should try repairing it:

     

      1. Open Keychain Access (located in Applications/Utilities)

      2. Go to the "Keychain Access" menu and select "Preferences"

      3. Click the "First Aid" tab

      4. Make sure the "Synchronize login keychain password" box is checked

      5. Close the Preferences window

      6. Go to the "Keychain Access" menu and select "Keychain First Aid"

      7. Enter your username and password

      8. Click the "Repair" button

     

    See if this helps. Be sure to use the password you have most recently configured.

  • 6. Re: macbook air won't let me log in
    dipflyboy77 Level 1 Level 1 (0 points)

    Repairing Keychain Access did not work, unfortunately.  I'm at wit's end.  Any other ideas?

  • 7. Re: macbook air won't let me log in
    Kappy Level 10 Level 10 (226,700 points)

    You can give this a try. It will allow you to return to the Setup Assistant where you can create a new admin user account.

     

    How to Create a New User Account if You Cannot Access Your Admin Account

     

    Reboot the computer. At the chime press and hold down the COMMAND-S keys to start into Single-user Mode.

     

    You will boot to a black screen with scrolling white text, release the keys and wait for it finish.

     

    Enter the following lines at the command prompt pressing RETURN after each:

     

    mount -uw /

    rm /var/db/.applesetupdone

    reboot

     

    After you reboot the computer you will be taken to the Setup Assistant. When you get to the point where you are asked to setup your new user account, create a new admin account. Be sure to name this user account something different than the admin user account that already exists on the system. When you finish the Setup Assistant, it will automatically log you into the new account.

     

    You can transfer your files from the old account to the new one. See: Transferring files from one User Account to another. Once you have moved all your files into your new account, you can delete the old account using Accounts or Users & Groups preferences.

  • 8. Re: macbook air won't let me log in
    mrsmee829 Level 1 Level 1 (0 points)

    i'm having the exact same issues. I've tried SafeBoot, single users mode, now all I can get is my machine to boot with a gray screen and a mouse on it I try to restore the software through recovery partition, it does not connect to the app store any new good Wi-Fi. When I attempt to repair and reset the disk or reset the permissions and the ACL's from the terminal command in recovery mode, it still does not fix the issue.

  • 9. Re: macbook air won't let me log in
    mmacygin Level 1 Level 1 (0 points)

    I have tried all f the above trouble shooting steps as well, and am having the EXACT same problem.  I was even able to use the Guest Account to create a NEW ADMIN ACCOUNT using my original log in credentials.  Then when I try loging into the new account, I get the same issue of accepting the password, but cycling back to the log in page.

  • 10. Re: macbook air won't let me log in
    nreimert Level 1 Level 1 (0 points)

    I, too, am having this exact same issue and having zero luck.  Just purchased a new iPad air and unable to log in so not able to back up old iPad before setting up the new.  Very frustrated and would love to have a solution.

  • 11. Re: macbook air won't let me log in
    Sfodill Level 1 Level 1 (0 points)

    i have an airmac bought in 2011. tried to reboot. turn off. safe mode. holding down shift button.

    no change gray screen with icon twirling? any suggesttions?

    thanks

  • 12. Re: macbook air won't let me log in
    laup22 Level 1 Level 1 (0 points)

    I'm having the same issue, my HD actually crashed last week and just got it back today from the shop with a replaced hard drive, however they didn't update it to Mavricks like I'd previously had, so it prompted me to do the Update (ML 10.8.4) listed above I believe and now it turns on but won't let me get past the log in screen even with the correct password.  I'm super frustrated, any help is appreciated!

  • 13. Re: macbook air won't let me log in
    donasbury Level 1 Level 1 (0 points)

    I see that most of these posts are several months old.  Did anyone find a solution?  I am having the same issue with a coworker's Macbook Air.  It was unused for quite a while and so a software update was needed (it currently has OS Lion).  After updating and restarting, it will go to the login screen, I will enter her password, and it will load for a couple seconds and go back to the login screen.  It will not allow me to try any of the above suggestions (command+S, command+R).  Thank you.

  • 14. Re: macbook air won't let me log in
    hyphennz Level 1 Level 1 (0 points)

    I would also like to get an answer to this.  I have a new MacBook Air, only a week old and was doing some updates when the same issue occurred.  I have tried to create a new account , but get the same result as @mrsmee829 above, it appears to login, but leaves you with a grey screen and mouse pointer.