Previous 1 2 Next 17 Replies Latest reply: Jul 22, 2013 10:57 AM by fruhulda
Carola Clavo Level 1 (40 points)

I have to open a few text documents. No matter of they are three or six, sometimes it will open but most of times, they won't. Also, Pages won't start after jumping for a while in the Dock.


If you open the documents from the Open menu it will work but the Dock icon is buggy.


There is no way to fix this as this may be a bug that sometimes happens and other times does not…


But thanks for reading.

MacBook Pro, OS X Mountain Lion (10.8.2)
  • PeterBreis0807 Level 7 (34,572 points)

    No, it is a problem on your particular set-up, whatever that is. You haven't said.


    You haven't said what the problem files are either.


    Pages will open multiple documents fine. You can select more than one at a time from the Open dialogue, or drag them onto the icon or double click on multiple selected files.



  • Carola Clavo Level 1 (40 points)

    Hi there!


    Thanks for your comment. My set up is on my signature (actually the system is 10.8.4). The documents are normal .doc files with text in them. No longer than 1 page, and nothing special on them.


    The Open option in the File menu usually works fine but the dock icon is terrible. I tried to drag it off the dock and create it again in the past but still have the problem and its annoying. Pages is updated to the latest version so I don't know what else can be wrong.



  • PeterBreis0807 Level 7 (34,572 points)

    You didn't said what version of Pages, and "the latest" is often only what the poster thinks is the latest.


    You haven't actually said that it is Pages '09 v4.3, but we assume it might be, even though you could be running Pages '08.


    So the problem appears to be they are actually Word .docs and not .pages.


    Just guessing but it is possible that one or more are throwing up conversion errors, missing fonts etc, and that is interrupting the subsequent files launch.



  • Carola Clavo Level 1 (40 points)

    Hi again,


    Yes, my version in the latest possible. Therefore can't be any prior version than the latest one you mention… No updates pending. Again, the documents are pretty normal boring text documents that open fine using the Open option in the file menu BUT they don't open all together when I drag them to the dock. Yes, these are Word files, .doc files, as I said in my previous message.


    There are no missing fonts, no conversion errors when I open them from the menu.


    Thanks for the reply but if you are not happy replying to this topic, don't do it, it's ok. :)


    I almost gave up trying to open more than one document from the dock every time I'd like to do so. It's very annoying for me but that's it. I haven't found a way to fix it. I thought someone else could have this problem too.

  • fruhulda Level 6 (15,120 points)

    Do you mean that only parts of the Word documents ope or do you mean that only one of for example three Word documents open?

    If you do the same with Pages document how does that work?


    Have you tried deleting the Pages icon from the Dock and adding it again?


    Have restarted you computer lately? Have you done any maintenance of the computer like rebinding permissions, deleting caches etc.?

  • PeterBreis0807 Level 7 (34,572 points)



    To get a usable answer you have to provide useful details so that we can test and verify the results.


    Vague or incomplete questions get vague or incomplete replies and whilst posters like the first, they don't like the second.


    We still do not know for sure you have either Pages '09, nor that it is in fact the latest version (v4.3) because you haven't actually said so, just implied that it might be.


    A simple quick test suggests that what you are doing is opening Word templates .dotx possibly mixed in with .doc.


    Pages will open multiple .doc files so long as they don't flag warnings but each .dotx requires an extra conversion process to a regular document and that appears to stop at that particular file and not proceed to the next one.


    Word will open multiple .dotx files because that is a single step conversion, it is in its native format.


    Pages is not Word, it just opens and converts Word files to its own .pages format and exports to .doc format.



  • Carola Clavo Level 1 (40 points)

    Thank you again for taking the time to reply again in this topic.


    "The latest" Pages app only can be… the latest version released, but again I can confirm as in my previous comment, YES the version is 4.3. There can be only *one* latest version possible! Pages 08 can't be the "latest".


    Aside, yes, as I commented I created the Pages icon dock again but the problem is still happening. Also, I'm referring to full documents, not parts of them. One of three documents won't open, for example.


    Computer is up to date, permissions are Ok, etc. No problem on maintenance.


    The documents are .doc or .docx, not templates, not uncommon documents, not .dotx files. Just text document they made using Windows. I'm a graphic designer and I receive the localizations to translate Photoshop designs into 5 or 6 languages, so they send me those texts in one document each language, so the files are small, 1 page documents with no images, macros or anything else than a few text lines.


    I've been using Pages for many years now and can't remember when it started to behave like this. Sometimes I just open those documents with Text Edit because it's faster and never fails.


    If I open the documents dragging them to the dock icon, one by one, with Pages all of them will open fine. If I use the menu option, the documents will all open fine. It just fails when opening a bunch of them using the dock. Sometimes three out of five are open, in rare cases all of them are open or Pages is just stalled and won't do anything.


    One example. I dragged all of these documents to Pages icon in the dock.

    Captura de pantalla 2013-07-22 a la(s) 10.47.30.jpg

    Five of them opened instantly except the last one: "Traducción mailing Son Antem_RU.doc".


    If I drag this single document to the dock, it opens just fine like all the others. If I choose this one and 4 others, all of the five docs open fine. It looks like if there was a limit to open documents at a time from Pages dock icon, but this doesn't make any sense, I can open 15 documents at the same time from Photoshop, for example.


    If I open all these 6 items from the menu File > Open… all of them are opened, no problems.


    This eandom behaviour with no sense at all made me wanted to know what's happening with my Pages! It's really bothering me. Maybe I'll just have to change my habits and start using the File menu but I'm more of a drag and drop person.


    Thanks for your attention and bearing with this little, but annoying problem.

  • PeterBreis0807 Level 7 (34,572 points)

    Yes you can have the latest version of Pages '08 running in Mountain Lion. Also what you think is the latest version of Pages '09 isn't necessarily what is the latest version, which is why we ask and like to see the actual numbers.


    We frequently have people refusing to say exactly what they have installed, or done, only to finally own up after innumerable requests and surprise, it isn't what they said it was.


    Now that you have actually said what you have and elaborated on the details, we can test.


    Best would be if you clicked on my blue name and emailed the documents in question to see if I can reproduce the problem. I could keep testing various documents that I think may be similar to yours, but that won't fix your particular symptoms.



  • Carola Clavo Level 1 (40 points)

    If you like to have a look at the documents, you can download them from


    This problem has been occurring with other similar documents created by the same people.


    Thanks for bothering, I'm curious about what is the reason for this to happen. Something may be wrong with my dock but other apps just do it fine.

  • PeterBreis0807 Level 7 (34,572 points)

    OK I've just done some quick tests using:


    Traducción mailing Son Antem_DE.doc

    Traducción mailing Son Antem_EN.doc

    Traducción mailing Son Antem_FR.doc

    Traducción mailing Son Antem_IT.doc

    Traducción mailing Son Antem_PT.docx

    Traducción mailing Son Antem_RU.doc


    NB that Traducción mailing Son Antem_PT.docx is the odd one out.


    1. If I attempt to open all 6 only Traducción mailing Son Antem_PT.docx opens


    2. The exact same thing happens if I try it with TextEdit.


    3. The other 5 files selected as a set all open in one go


    4. If I reopen all 6 files as a set they all open in either Pages or TextEdit


    5. Word opens all 6 files as a set


    It seems to me that it is the .docx that is using a separate OSX filter that interrupts the opening process, but once used is cached and then works without interruption.


    Whilst this should not be happening, there are a few workarounds you can try:


    1. View the files by Kind in the Finder and open sets of the same kind.


    2. Initialise the opening process and you should then be able to do subsequent multiple openings.


    3. Ask your translators to supply their files in consistent formats, I suggest as .txt files. Having to use a wide range of translators for over a decade, good luck with that.


    4. Do your own tests along similar lines and having taken careful note of what happens:


    Menu > Pages > Provide Pages feedback



  • Carola Clavo Level 1 (40 points)

    Thank you again Peter for taking the time to test and understand the problem.


    I also find the documents should open just fine as they do if you use the menu and not the dock icon. The "best" solution for me will be change my habits and open the documents from the menu. It's faster and easier than asking the agency to change formats, or spend time to group documents by kind - my works is always a fast run with no time to stop by :) So I will use Text Edit which is great for simple text documents like this, or I will star to use the menu or a command open - this, if works as expected, can be a time saver too.


    Thank you again and have a nice day.

  • Carola Clavo Level 1 (40 points)

    On a side note, yes I will send feedback to Apple just in case some engineer knows about this problem. It looks like a bug, almost always reproducible.


    Regards from Spain.

  • VikingOSX Level 6 (15,706 points)



    I am running 10.8.4 and Pages '09 v4.3. I downloaded your files, selected all of them, and dragged them over my Pages icon in the dock. Nothing opened (including the inspector) and I had to force-quit Pages.


    I then subsequently tried with TextEdit, Preview, and LibreOffice v4.04, all in the dock, and no files opened in any application. Had to force-quit each time.


    Next, I then emptied the Cache contents in my local Library folder. Rebooted into safe boot mode which cleans some system caches and rebuilds the font database, etc. I then emptied my Trash. While in safe boot mode, I tried the drag and drop on the Pages dock icon with the same results. I rebooted.


    After the reboot, I dragged all six file icons onto the Pages dock icon -- still no joy. Then I selected just three (excluding the .docx) and they all opened immediately. Then five (excluding the .docx) and they opened immediately. Then all six and all opened instantly.


    Unfortunately, I do not have a good explanation for this behavior. You might consider clearing local Cache and then rebooting in Safe Boot mode as I described above.


    What is Safe Boot Mode

    Starting up in Safe Boot Mode


    Best wishes.

  • Carola Clavo Level 1 (40 points)



    That's amazing! A different setup and the same problem. The .docx document doesn't make a difference for me, sometimes it will be opened as the others, sometimes it won't.


    The only "difference" for me, if any, it's the amount of files I drag to the dock icon.


    Good to see another example, what is going on with Pages dock icon? It's fascinating.

Previous 1 2 Next